summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-02-09 21:47:21 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-02-09 21:47:21 +0000
commitc1ee08b3a1a65219d0ec5e92724c2890bef5c840 (patch)
tree0e7183536469f63bf540101d8dc7c5f4526a29d2 /media-plugins
parentNew and improved alpha build with debug functionality. Bugs still upstream, t... (diff)
downloadgentoo-2-c1ee08b3a1a65219d0ec5e92724c2890bef5c840.tar.gz
gentoo-2-c1ee08b3a1a65219d0ec5e92724c2890bef5c840.tar.bz2
gentoo-2-c1ee08b3a1a65219d0ec5e92724c2890bef5c840.zip
New and improved alpha build with debug functionality. Bugs still upstream, thank you.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog8
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-2.3_alpha2.ebuild122
2 files changed, 129 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index a9fbab8e2d42..14c42786f6e1 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.163 2010/02/07 14:53:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.164 2010/02/09 21:47:21 chainsaw Exp $
+
+*audacious-plugins-2.3_alpha2 (09 Feb 2010)
+
+ 09 Feb 2010; <chainsaw@gentoo.org> +audacious-plugins-2.3_alpha2.ebuild:
+ New and improved alpha build with debug functionality. Bugs still
+ upstream, thank you.
07 Feb 2010; Raúl Porcel <armin76@gentoo.org>
audacious-plugins-2.2-r2.ebuild:
diff --git a/media-plugins/audacious-plugins/audacious-plugins-2.3_alpha2.ebuild b/media-plugins/audacious-plugins/audacious-plugins-2.3_alpha2.ebuild
new file mode 100644
index 000000000000..869a95f4ab96
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-2.3_alpha2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-2.3_alpha2.ebuild,v 1.1 2010/02/09 21:47:21 chainsaw Exp $
+
+inherit eutils flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="aac adplug alsa aqua bs2b cdda cue debug esd ffmpeg flac fluidsynth gnome icecast ipv6 jack
+lame lirc midi mp3 mtp nls oss pulseaudio projectm sdl sid sndfile sse2 vorbis wavpack"
+
+RDEPEND="app-arch/unzip
+ >=dev-libs/dbus-glib-0.60
+ dev-libs/libxml2
+ >=media-sound/audacious-2.3_alpha2
+ >=net-misc/neon-0.26.4
+ >=x11-libs/gtk+-2.14
+ aac? ( >=media-libs/faad2-2.7 )
+ adplug? ( >=dev-cpp/libbinio-1.4 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ bs2b? ( media-libs/libbs2b )
+ cdda? ( >=media-libs/libcddb-1.2.1
+ >=dev-libs/libcdio-0.79-r1 )
+ cue? ( media-libs/libcue )
+ esd? ( >=media-sound/esound-0.2.38-r1 )
+ ffmpeg? ( media-video/ffmpeg )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1 )
+ fluidsynth? ( media-sound/fluidsynth )
+ icecast? ( media-libs/libshout )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit )
+ lame? ( media-sound/lame )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-libs/libmad )
+ mtp? ( media-libs/libmtp )
+ projectm? ( >=media-libs/libprojectm-1.2.0
+ >=media-libs/libsdl-1.2.5
+ x11-libs/gtkglext )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ sid? ( >=media-libs/libsidplay-2.1.1-r2 )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ vorbis? ( >=media-libs/libvorbis-1.2.0
+ >=media-libs/libogg-1.1.3 )
+ wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! use mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ econf \
+ --enable-chardet \
+ --enable-dbus \
+ --enable-modplug \
+ --enable-neon \
+ --disable-projectm \
+ --disable-scrobbler \
+ $(use_enable adplug) \
+ $(use_enable aac) \
+ $(use_enable alsa) \
+ $(use_enable alsa bluetooth) \
+ $(use_enable alsa amidiplug-alsa) \
+ $(use_enable aqua coreaudio) \
+ $(use_enable aqua dockalbumart) \
+ $(use_enable bs2b) \
+ $(use_enable cdda cdaudio) \
+ $(use_enable cue) \
+ $(use_enable debug) \
+ $(use_enable esd) \
+ $(use_enable ffmpeg ffaudio) \
+ $(use_enable flac flacng) \
+ $(use_enable fluidsynth amidiplug-flsyn) \
+ $(use_enable flac filewriter_flac) \
+ $(use_enable icecast) \
+ $(use_enable ipv6) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lame filewriter_mp3) \
+ $(use_enable lirc) \
+ $(use_enable mp3) \
+ $(use_enable midi amidiplug) \
+ $(use_enable mtp mtp_up) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable projectm projectm-1.0) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable sdl paranormal) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable sse2) \
+ $(use_enable vorbis) \
+ $(use_enable vorbis filewriter_vorbis) \
+ $(use_enable wavpack)
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ mp3_warning
+}