summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 00:39:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 00:39:15 +0000
commitb7281967cfe45f5caa10eee238785059491f9cb8 (patch)
treeb220160dab645b67d350230b0b447ba675614dbe /media-plugins
parentstable ppc64, bug 224743 (diff)
downloadgentoo-2-b7281967cfe45f5caa10eee238785059491f9cb8.tar.gz
gentoo-2-b7281967cfe45f5caa10eee238785059491f9cb8.tar.bz2
gentoo-2-b7281967cfe45f5caa10eee238785059491f9cb8.zip
Version bump, remove patches that are fixed upstream, update the automagic patch (pushed upstream), and use EAPI=2 to make sure the rate plugin is enabled in alsa-lib when building resampler plugins (ffmpeg, speex and samplerate USE flags).
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog11
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild72
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch72
3 files changed, 154 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index ba97480e21a1..c38c75df6d42 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.79 2008/09/01 18:04:13 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.80 2008/11/13 00:39:15 flameeyes Exp $
+
+*alsa-plugins-1.0.18 (13 Nov 2008)
+
+ 13 Nov 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsa-plugins-1.0.18-automagic.patch, +alsa-plugins-1.0.18.ebuild:
+ Version bump, remove patches that are fixed upstream, update the automagic
+ patch (pushed upstream), and use EAPI=2 to make sure the rate plugin is
+ enabled in alsa-lib when building resampler plugins (ffmpeg, speex and
+ samplerate USE flags).
01 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
-alsa-plugins-1.0.13.ebuild, -alsa-plugins-1.0.14_rc1-r1.ebuild,
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild
new file mode 100644
index 000000000000..58c2f1e5670c
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.18.ebuild,v 1.1 2008/11/13 00:39:15 flameeyes Exp $
+
+EAPI=2
+
+inherit libtool autotools eutils flag-o-matic
+
+MY_P="${P/_/}"
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}
+ ffmpeg? ( media-video/ffmpeg
+ media-libs/alsa-lib[alsa_pcm_plugins_rate] )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ libsamplerate? (
+ media-libs/libsamplerate
+ media-libs/alsa-lib[alsa_pcm_plugins_rate] )
+ pulseaudio? ( media-sound/pulseaudio )
+ speex? ( media-libs/speex
+ media-libs/alsa-lib[alsa_pcm_plugins_rate] )
+ !media-plugins/alsa-jack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.18-automagic.patch"
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ "${S}/pulse/Makefile.am"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ use debug || append-flags -DNDEBUG
+
+ econf \
+ $(use_with ffmpeg avcodec) \
+ $(use_with jack) \
+ $(use_with libsamplerate samplerate) \
+ $(use_with pulseaudio) \
+ $(use_with speex speex lib) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd "${S}/doc"
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use pulseaudio && dodoc README-pulse
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch
new file mode 100644
index 000000000000..8720f8c4852b
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.18-automagic.patch
@@ -0,0 +1,72 @@
+From 4aed9c0b2ae244f1a57337ff8c3dc6070c087c49 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Diego=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Thu, 13 Nov 2008 01:23:35 +0100
+Subject: [PATCH] Allow opt-out from jack, pulseaudio and avcodec dependencies.
+
+Without this patch the jack, pulseaudio and avcodec discovery was
+"automagic", without a way for the user to disable the relative
+plugins if the dependencies are installed but the plugin is unwanted.
+
+This patch does not change the default behaviour but allows to opt-out
+from the plugins by passing the relative --without option at
+./configure time.
+---
+ configure.in | 31 ++++++++++++++++++++++++++-----
+ 1 files changed, 26 insertions(+), 5 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 9efb890..ffb6528 100644
+--- a/configure.in
++++ b/configure.in
+@@ -15,13 +15,28 @@ PKG_CHECK_MODULES(ALSA, alsa >= 1.0.11)
+ AC_CHECK_LIB(asound, snd_pcm_ioplug_create,,
+ AC_ERROR([*** libasound has no external plugin SDK]), -ldl)
+
+-PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
++AC_ARG_WITH([jack],
++ AS_HELP_STRING([--without-jack], [Disable building of JACK plugin]))
++
++if test "x$with_jack" != "xno"; then
++ PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
++fi
+ AM_CONDITIONAL(HAVE_JACK, test x$HAVE_JACK = xyes)
+
+-PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
++AC_ARG_WITH([pulseaudio],
++ AS_HELP_STRING([--without-pulseaudio], [Disable building of pulseaudio plugin]))
++
++if test "x$with_pulseaudio" != "xno"; then
++ PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
++fi
+ AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
+
+-PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
++AC_ARG_WITH([samplerate],
++ AS_HELP_STRING([--without-samplerate], [Disable building of samplerate plugin]))
++
++if test "x$with_samplerate" != "xno"; then
++ PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
++fi
+ AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
+
+ AC_ARG_ENABLE([maemo-plugin],
+@@ -45,8 +60,14 @@ if test "$use_maemo_rm" = "yes"; then
+ fi
+ fi
+
+-PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+-if test "$HAVE_AVCODEC" != "yes"; then
++AC_ARG_WITH([avcodec],
++ AS_HELP_STRING([--without-avcodec], [Don't build plugins depending on avcodec (a52)]))
++
++if test "x$with_avcodec" != "xno"; then
++ PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
++fi
++
++if test "$HAVE_AVCODEC" = "no"; then
+ AC_ARG_WITH([avcodec-includedir],
+ AS_HELP_STRING([--with-avcodec-includedir=dir],
+ [AVcodec include directory]),
+--
+1.6.0.3
+