summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2007-06-26 17:21:46 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2007-06-26 17:21:46 +0000
commit97a563d2edac19c57691a4ca4fa17ee58ee0c765 (patch)
treecc1ae2c885442e4684a3c91e04e99f913fbcbd53 /media-plugins
parentalpha stable wrt #183253 (diff)
downloadgentoo-2-97a563d2edac19c57691a4ca4fa17ee58ee0c765.tar.gz
gentoo-2-97a563d2edac19c57691a4ca4fa17ee58ee0c765.tar.bz2
gentoo-2-97a563d2edac19c57691a4ca4fa17ee58ee0c765.zip
patch added, fix for compile probs >= vdr-1.5.3
(Portage version: 2.1.2.7)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-live/ChangeLog7
-rw-r--r--media-plugins/vdr-live/files/0.1.0/vdr-live-0.1.0_vdr-1.5.3-compile.diff32
-rw-r--r--media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild5
3 files changed, 41 insertions, 3 deletions
diff --git a/media-plugins/vdr-live/ChangeLog b/media-plugins/vdr-live/ChangeLog
index e6458297544a..a154a75f9b30 100644
--- a/media-plugins/vdr-live/ChangeLog
+++ b/media-plugins/vdr-live/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/vdr-live
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.4 2007/06/01 18:46:02 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.5 2007/06/26 17:21:46 hd_brummy Exp $
+
+ 26 Jun 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/0.1.0/vdr-live-0.1.0_vdr-1.5.3-compile.diff,
+ vdr-live-0.1.0-r1.ebuild:
+ patch added, fix for compile probs >= vdr-1.5.3
*vdr-live-0.1.0-r1 (01 Jun 2007)
diff --git a/media-plugins/vdr-live/files/0.1.0/vdr-live-0.1.0_vdr-1.5.3-compile.diff b/media-plugins/vdr-live/files/0.1.0/vdr-live-0.1.0_vdr-1.5.3-compile.diff
new file mode 100644
index 000000000000..9196ee9189f5
--- /dev/null
+++ b/media-plugins/vdr-live/files/0.1.0/vdr-live-0.1.0_vdr-1.5.3-compile.diff
@@ -0,0 +1,32 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 92_live-0.1.0-1.5.3.dpatch by Thomas Günther <tom@toms-cafe.de>
+## http://toms-cafe.de/vdr/download/live-0.1.0-1.5.3.diff
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Changes for VDR >= 1.5.3.
+
+@DPATCH@
+--- live-0.1.0/pages/timers.ecpp
++++ live-0.1.0/pages/timers.ecpp
+@@ -59,7 +59,11 @@ using namespace vdrlive;
+ <table class="timers" cellspacing="0" cellpadding="0">
+ <%cpp>
+ for (SortedTimers::iterator timer = timers.begin(); timer != timers.end(); ++timer) {
++#if VDRVERSNUM >= 10503
++ string currentDay = timer->WeekDays() > 0 ? *cTimer::PrintDay(0, timer->WeekDays(), true) : FormatDateTime(tr("%A, %x"), timer->Day());
++#else
+ string currentDay = timer->WeekDays() > 0 ? *cTimer::PrintDay(0, timer->WeekDays()) : FormatDateTime(tr("%A, %x"), timer->Day());
++#endif
+ if (previousDay != currentDay) {
+ if (!previousDay.empty()) {
+ </%cpp>
+@@ -73,7 +77,7 @@ using namespace vdrlive;
+ <tr class="head">
+ <td colspan="10">
+ <div class="boxheader"><div><div>
+- <$ timer->WeekDays() > 0 ? *cTimer::PrintDay(0, timer->WeekDays()) : FormatDateTime(tr("%A, %x"), timer->Day()) $>
++ <$ currentDay $>
+ </div></div></div>
+ </td>
+ </tr>
+
diff --git a/media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild
index 0d1dffd54d0a..c9ed4dd6b8b2 100644
--- a/media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild,v 1.1 2007/06/01 18:46:02 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.1.0-r1.ebuild,v 1.2 2007/06/26 17:21:46 hd_brummy Exp $
inherit vdr-plugin
@@ -20,4 +20,5 @@ DEPEND="media-video/vdr
PATCHES="${FILESDIR}/${PV}/new-tntnet.diff
${FILESDIR}/${PV}/linking.diff
- ${FILESDIR}/${PV}/timerdelete.diff"
+ ${FILESDIR}/${PV}/timerdelete.diff
+ ${FILESDIR}/${PV}/${P}_vdr-1.5.3-compile.diff"