summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-31 09:16:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-31 09:16:24 +0000
commit941cee19fd573817a907d0f7ab78164a8ef309b5 (patch)
tree0192d5afedd48a529186e6d6e2f2c74b796f0982 /media-plugins
parentVersion bump to latest version, and remove release candidate. (diff)
downloadgentoo-2-941cee19fd573817a907d0f7ab78164a8ef309b5.tar.gz
gentoo-2-941cee19fd573817a907d0f7ab78164a8ef309b5.tar.bz2
gentoo-2-941cee19fd573817a907d0f7ab78164a8ef309b5.zip
Version bump to latest version, and remove release candidate.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog10
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.12.ebuild77
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.12-automagic.patch52
-rw-r--r--media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.123
4 files changed, 141 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index 65000b111138..a828736773c3 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.10 2006/08/11 21:50:05 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.11 2006/08/31 09:16:24 flameeyes Exp $
+
+*alsa-plugins-1.0.12 (31 Aug 2006)
+
+ 31 Aug 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsa-plugins-1.0.12-automagic.patch,
+ -alsa-plugins-1.0.12_rc1.ebuild, -alsa-plugins-1.0.12_rc1-r1.ebuild,
+ +alsa-plugins-1.0.12.ebuild:
+ Version bump to latest version, and remove release candidate.
11 Aug 2006; Markus Rothe <corsair@gentoo.org>
alsa-plugins-1.0.12_rc1-r1.ebuild:
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.12.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.12.ebuild
new file mode 100644
index 000000000000..7859e2067a8c
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.12.ebuild,v 1.1 2006/08/31 09:16:24 flameeyes Exp $
+
+inherit libtool autotools eutils flag-o-matic
+
+MY_P="${P/_/}"
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="jack ffmpeg libsamplerate pulseaudio debug"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.12_rc1
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ ffmpeg? ( media-video/ffmpeg )
+ libsamplerate? ( media-libs/libsamplerate )
+ pulseaudio? ( media-sound/pulseaudio )
+ !media-plugins/alsa-jack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-automagic.patch"
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ "${S}/pulse/Makefile.am"
+
+ eautoreconf
+
+ elibtoolize
+}
+
+src_compile() {
+ use debug || append-flags -DNDEBUG
+ econf \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable pulseaudio) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd "${S}/doc"
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use pulseaudio && dodoc README-polyp
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ elog "This version of alsa-plugins does not support PulseAudio under this name."
+ elog "as it was developed when it was called PolypAudio."
+ elog "For this reason all the documentation refers to PolypAudio and"
+ elog "the plugin is called polyp."
+ elog "This situation is going to be solved in next release."
+ fi
+}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.12-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.12-automagic.patch
new file mode 100644
index 000000000000..d1b380cbaa0d
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.12-automagic.patch
@@ -0,0 +1,52 @@
+Index: alsa-plugins-1.0.12rc1/configure.in
+===================================================================
+--- alsa-plugins-1.0.12rc1.orig/configure.in
++++ alsa-plugins-1.0.12rc1/configure.in
+@@ -13,15 +13,29 @@ PKG_CHECK_MODULES(ALSA, alsa >= 1.0.11)
+ AC_CHECK_LIB(asound, snd_pcm_ioplug_create,,
+ AC_ERROR([*** libasound has no external plugin SDK]), -ldl)
+
+-PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
++AC_ARG_ENABLE([jack],
++ AC_HELP_STRING([--disable-jack], [Disable building of JACK plugin]))
++if test "x$enable_jack" != "xno"; then
++ PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
++fi
+ AM_CONDITIONAL(HAVE_JACK, test x$HAVE_JACK = xyes)
+
+-PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
++AC_ARG_ENABLE([pulseaudio],
++ AC_HELP_STRING([--disable-pulseaudio], [Disable building of pulseaudio plugin]))
++if test "x$enable_pulseaudio" != "xno"; then
++ PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
++fi
+ AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
+
+-PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
++AC_ARG_ENABLE([samplerate],
++ AC_HELP_STRING([--disable-samplerate], [Disable building of samplerate plugin]))
++if test "x$enable_samplerate" != "xno"; then
++ PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
++fi
+ AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
+
++AC_ARG_ENABLE([avcodec],
++ AC_HELP_STRING([--disable-avcodec], [Disable building of avcodec code (a52 plugin)]))
+ AC_ARG_WITH([avcodec-includedir],
+ [--with-avcodec-includedir=dir AVcodec include directory],
+ [AVCODEC_CFLAGS="-I$withval"], [AVCODEC_CFLAGS=""])
+@@ -35,9 +49,11 @@ LDFLAGS="$LDFLAGS $AVCODEC_LIBS"
+ AC_SUBST(AVCODEC_CFLAGS)
+ AVCODEC_LIBS="$AVCODEC_LIBS -lavcodec"
+ AC_SUBST(AVCODEC_LIBS)
+-AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+-if test x$HAVE_AVCODEC = xyes; then
+- AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
++if test "x$enable_avcodec" != "xno"; then
++ AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
++ if test x$HAVE_AVCODEC = xyes; then
++ AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
++ fi
+ fi
+ AM_CONDITIONAL(HAVE_AVCODEC, test x$HAVE_AVCODEC = xyes)
+ CFLAGS="$CFLAGS_saved"
diff --git a/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.12 b/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.12
new file mode 100644
index 000000000000..908265d647bc
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.12
@@ -0,0 +1,3 @@
+MD5 f64f0321292a240408bd7ea3e11871a3 alsa-plugins-1.0.12.tar.bz2 230159
+RMD160 5d5c37c720f3399c185c503c4ba3ceb056796069 alsa-plugins-1.0.12.tar.bz2 230159
+SHA256 ad78b94bdbff363a376ee94670f699174e4699432b45509faf8b68f65b2dfbf1 alsa-plugins-1.0.12.tar.bz2 230159