summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2008-06-22 17:43:35 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2008-06-22 17:43:35 +0000
commit86567ed04d642e9973a6de30bd912c93074ff97f (patch)
treee7822e4f59248067780c0e98667904e9f6d262e0 /media-plugins
parentAdd ~sparc keyword (diff)
downloadgentoo-2-86567ed04d642e9973a6de30bd912c93074ff97f.tar.gz
gentoo-2-86567ed04d642e9973a6de30bd912c93074ff97f.tar.bz2
gentoo-2-86567ed04d642e9973a6de30bd912c93074ff97f.zip
add patches to compile with new header structur of imagemagick-6.4.x and gcc-4.3.x
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog8
-rw-r--r--media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff11
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff14
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild9
4 files changed, 39 insertions, 3 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 71f583ce2734..96f64ee9ebcc 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.5 2008/06/22 11:56:51 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.6 2008/06/22 17:43:34 hd_brummy Exp $
+
+ 22 Jun 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff,
+ +files/gcc-4.3-missing_includes.diff, vdr-graphtft-0.1.18_alpha.ebuild:
+ add patches to compile with new header structur of imagemagick-6.4.x and
+ gcc-4.3.x
22 Jun 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
-files/vdr-graphtft-0.1.16_alpha-gentoo.diff,
diff --git a/media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff b/media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff
new file mode 100644
index 000000000000..c5124bd445c2
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff
@@ -0,0 +1,11 @@
+diff -Naur graphtft-0.1.18.alpha.orig/tcpchannel.c graphtft-0.1.18.alpha/tcpchannel.c
+--- graphtft-0.1.18.alpha.orig/tcpchannel.c 2008-06-22 19:32:19.000000000 +0200
++++ graphtft-0.1.18.alpha/tcpchannel.c 2008-06-22 19:32:59.000000000 +0200
+@@ -15,6 +15,7 @@
+ #include <fcntl.h>
+ #include <netdb.h>
+ #include <errno.h>
++#include <string.h>
+
+ #include "tcpchannel.h"
+ #include "common.h"
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff
new file mode 100644
index 000000000000..e071e6765bb5
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff
@@ -0,0 +1,14 @@
+diff -Naur graphtft-0.1.18.alpha.orig/Makefile graphtft-0.1.18.alpha/Makefile
+--- graphtft-0.1.18.alpha.orig/Makefile 2008-06-22 19:12:45.000000000 +0200
++++ graphtft-0.1.18.alpha/Makefile 2008-06-22 19:16:56.000000000 +0200
+@@ -122,6 +122,10 @@
+ HAVE_FFMPEG = 1
+ endif
+
++ifdef HAVE_IMAGE_MAGICK
++ INCLUDES += -I/usr/include/ImageMagick
++endif
++
+ ifdef HAVE_GTOP
+ GTOP_INC = `pkg-config libgtop-2.0 --cflags`
+ GTOP_LIB = `pkg-config libgtop-2.0 --libs`
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild
index ca3bf00557da..382137c7275f 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild,v 1.2 2008/05/15 12:22:21 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild,v 1.3 2008/06/22 17:43:34 hd_brummy Exp $
MY_PV="${PV/_alpha/.alpha}"
MY_P="${PN}-${MY_PV}"
@@ -26,7 +26,8 @@ DEPEND=">=media-video/vdr-1.4.7-r9
directfb? ( dev-libs/DirectFB )
graphtft-fe? ( $(qt4_min_version 4.0.0) )"
-PATCHES=("${FILESDIR}/${P}-gentoo.diff")
+PATCHES=("${FILESDIR}/${P}-gentoo.diff"
+ "${FILESDIR}/gcc-4.3-missing_includes.diff")
S="${WORKDIR}/graphtft-${MY_PV}"
@@ -58,6 +59,10 @@ src_unpack() {
epatch "${FILESDIR}/${P}-ffmpeg-0.4.9_p20080326-new_header.diff"
fi
+ if has_version ">=media-gfx/imagemagick-6.4" ; then
+ epatch "${FILESDIR}/${P}-imagemagick-6.4-new_header.diff"
+ fi
+
use directfb && sed -i Makefile \
-e "s:#HAVE_DFB = 1:HAVE_DFB = 1:"