summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-24 18:15:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-24 18:15:16 +0000
commit6b8d5c6869d941666e754aeccb249a4afca83575 (patch)
tree805df6260780d5a9aeb35f0c663b96b31f818e60 /media-plugins
parentVersion bump (diff)
downloadgentoo-2-6b8d5c6869d941666e754aeccb249a4afca83575.tar.gz
gentoo-2-6b8d5c6869d941666e754aeccb249a4afca83575.tar.bz2
gentoo-2-6b8d5c6869d941666e754aeccb249a4afca83575.zip
Fix building with GCC 4.4 wrt #273840.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog7
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-gcc44.patch15
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-glibc210.patch12
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild6
4 files changed, 37 insertions, 3 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 6ad83049bd0f..15717f5157ce 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.15 2009/03/25 09:10:59 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.16 2009/07/24 18:15:15 ssuominen Exp $
+
+ 24 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ vdr-graphtft-0.2.2-r1.ebuild, +files/vdr-graphtft-0.2.2-gcc44.patch,
+ +files/vdr-graphtft-0.2.2-glibc210.patch:
+ Fix building with GCC 4.4 wrt #273840.
*vdr-graphtft-0.2.2-r1 (25 Mar 2009)
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-gcc44.patch b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-gcc44.patch
new file mode 100644
index 000000000000..69b2536d7d3d
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-gcc44.patch
@@ -0,0 +1,15 @@
+diff -NrU5 graphtft-0.2.2.original/common.h graphtft-0.2.2/common.h
+--- graphtft-0.2.2.original/common.h 2009-06-30 19:47:15.000000000 -0600
++++ graphtft-0.2.2/common.h 2009-06-30 19:49:28.000000000 -0600
+@@ -15,10 +15,11 @@
+ #ifndef ___COMMON_H
+ #define ___COMMON_H
+
+ #include <string>
+ #include <iconv.h>
++#include <stdint.h>
+
+ using std::string;
+
+ enum TimeConst
+ {
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-glibc210.patch b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-glibc210.patch
new file mode 100644
index 000000000000..231f3989a64e
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-glibc210.patch
@@ -0,0 +1,12 @@
+diff -ur graphtft-0.2.2.orig/display.c graphtft-0.2.2/display.c
+--- graphtft-0.2.2.orig/display.c 2008-11-01 16:20:50.000000000 +0200
++++ graphtft-0.2.2/display.c 2009-07-24 21:08:35.000000000 +0300
+@@ -141,7 +141,7 @@
+
+ int cGraphTFTDisplay::Init(const char* dev, const char* cfgDir, int port)
+ {
+- char* pos = 0;
++ const char* pos = 0;
+ int devnum = na;
+
+ #ifdef HAVE_DFB
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild
index 70b7335d1326..22138c8fd3c3 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild,v 1.2 2009/03/27 14:34:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild,v 1.3 2009/07/24 18:15:15 ssuominen Exp $
EAPI="2"
@@ -28,7 +28,9 @@ DEPEND=">=media-video/vdr-1.6.0_p2-r1[graphtft]
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}_gentoo.diff" )
+PATCHES=( "${FILESDIR}/${P}_gentoo.diff"
+ "${FILESDIR}/${P}-gcc44.patch"
+ "${FILESDIR}/${P}-glibc210.patch" )
extpatch_v_check() {