summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-03-26 08:33:45 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-03-26 08:33:45 +0000
commit60cb620b802ccbec00b5d890e55e4e89c1bc2e0c (patch)
tree3f7d4506c95fefb14134d5537011d73cef23e131 /media-plugins
parentremove install of depreciated mysql.txt. added msgs for ieee1394 and nvidia U... (diff)
downloadgentoo-2-60cb620b802ccbec00b5d890e55e4e89c1bc2e0c.tar.gz
gentoo-2-60cb620b802ccbec00b5d890e55e4e89c1bc2e0c.tar.bz2
gentoo-2-60cb620b802ccbec00b5d890e55e4e89c1bc2e0c.zip
add exif support
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythgallery/ChangeLog8
-rw-r--r--media-plugins/mythgallery/files/digest-mythgallery-0.17-r11
-rw-r--r--media-plugins/mythgallery/mythgallery-0.17-r1.ebuild32
3 files changed, 40 insertions, 1 deletions
diff --git a/media-plugins/mythgallery/ChangeLog b/media-plugins/mythgallery/ChangeLog
index ca61d07ce556..0edd72867aa4 100644
--- a/media-plugins/mythgallery/ChangeLog
+++ b/media-plugins/mythgallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythgallery
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.24 2005/02/11 15:59:16 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.25 2005/03/26 08:33:45 cardoe Exp $
+
+*mythgallery-0.17-r1 (26 Mar 2005)
+
+ 26 Mar 2005; Doug Goldstein <cardoe@gentoo.org>
+ +mythgallery-0.17-r1.ebuild:
+ add exif support
*mythgallery-0.17 (11 Feb 2005)
diff --git a/media-plugins/mythgallery/files/digest-mythgallery-0.17-r1 b/media-plugins/mythgallery/files/digest-mythgallery-0.17-r1
new file mode 100644
index 000000000000..d3be96d4dc9d
--- /dev/null
+++ b/media-plugins/mythgallery/files/digest-mythgallery-0.17-r1
@@ -0,0 +1 @@
+MD5 349d6e81d1b53a3650a1a8c30a7f9e11 mythgallery-0.17.tar.bz2 73707
diff --git a/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild b/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild
new file mode 100644
index 000000000000..dc1a42141ad4
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.17-r1.ebuild,v 1.1 2005/03/26 08:33:45 cardoe Exp $
+
+inherit myth
+
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="opengl exif"
+
+DEPEND=">=sys-apps/sed-4
+ opengl? ( virtual/opengl )
+ exif? ( media-libs/libexif )
+ media-libs/tiff
+ || ( ~media-tv/mythtv-${PV} ~media-tv/mythfrontend-${PV} )"
+
+setup_pro() {
+ return 0
+}
+
+src_compile() {
+ econf \
+ `use_enable exif` \
+ `use_enable opengl` || die "econf failed"
+
+ myth_src_compile || die "compile failed"
+}