summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-07 20:19:47 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-07 20:19:47 +0000
commit546cc72b61ffa7475bebb81ac4eaa8467aeb80b1 (patch)
treea1b1fcf78c02756929d67ffc4f81160caa85c543 /media-plugins
parentReplace the virtual with USE=libav. (diff)
downloadgentoo-2-546cc72b61ffa7475bebb81ac4eaa8467aeb80b1.tar.gz
gentoo-2-546cc72b61ffa7475bebb81ac4eaa8467aeb80b1.tar.bz2
gentoo-2-546cc72b61ffa7475bebb81ac4eaa8467aeb80b1.zip
Replace the virtual with USE=libav.
(Portage version: 2.2.16/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mediastreamer-x264/ChangeLog10
-rw-r--r--media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/media-plugins/mediastreamer-x264/ChangeLog b/media-plugins/mediastreamer-x264/ChangeLog
index 3f04d5879b4c..9da405568d72 100644
--- a/media-plugins/mediastreamer-x264/ChangeLog
+++ b/media-plugins/mediastreamer-x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mediastreamer-x264
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-x264/ChangeLog,v 1.26 2014/11/12 14:22:07 bircoph Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-x264/ChangeLog,v 1.27 2015/02/07 20:19:47 mgorny Exp $
+
+*mediastreamer-x264-1.4.2-r1 (07 Feb 2015)
+
+ 07 Feb 2015; Michał Górny <mgorny@gentoo.org>
+ +mediastreamer-x264-1.4.2-r1.ebuild:
+ Replace the virtual with USE=libav.
12 Nov 2014; Andrew Savchenko <bircoph@gentoo.org> metadata.xml:
Add myself to maintainers
diff --git a/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..743da04319de
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild,v 1.1 2015/02/07 20:19:47 mgorny Exp $
+
+EAPI=5
+
+MY_P="msx264-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add H264 support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="libav"
+
+RDEPEND=">=media-libs/mediastreamer-2.7.0:=[video]
+ >=media-libs/x264-0.0.20100118:=
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # strict: don't want -Werror
+ econf \
+ --disable-strict
+}