summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-10 19:25:01 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-10 19:25:01 +0000
commit3ab0c34c52be9289e0ada049d1f992b1dac0c79e (patch)
tree585a4cf9689972a8aa2b98b44326f7e2bf9114fd /media-plugins
parentEnable multilib support, bug #493176. (diff)
downloadgentoo-2-3ab0c34c52be9289e0ada049d1f992b1dac0c79e.tar.gz
gentoo-2-3ab0c34c52be9289e0ada049d1f992b1dac0c79e.tar.bz2
gentoo-2-3ab0c34c52be9289e0ada049d1f992b1dac0c79e.zip
Enable multilib support, bug #493176.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-xvideo/ChangeLog10
-rw-r--r--media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/media-plugins/gst-plugins-xvideo/ChangeLog b/media-plugins/gst-plugins-xvideo/ChangeLog
index a16054348e88..be7983330290 100644
--- a/media-plugins/gst-plugins-xvideo/ChangeLog
+++ b/media-plugins/gst-plugins-xvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-xvideo
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/ChangeLog,v 1.201 2013/03/05 22:06:29 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/ChangeLog,v 1.202 2014/06/10 19:25:01 mgorny Exp $
+
+*gst-plugins-xvideo-0.10.36-r1 (10 Jun 2014)
+
+ 10 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +gst-plugins-xvideo-0.10.36-r1.ebuild:
+ Enable multilib support, bug #493176.
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-gst-plugins-xvideo-0.10.35.ebuild, -gst-plugins-xvideo-0.10.35-r1.ebuild:
diff --git a/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild
new file mode 100644
index 000000000000..883237a2fae6
--- /dev/null
+++ b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild,v 1.1 2014/06/10 19:25:01 mgorny Exp $
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-base
+inherit gstreamer
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libXv[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-proto/videoproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/xextproto[${MULTILIB_USEDEP}]"
+
+# xshm is a compile time option of xvideo
+# x is needed to build any X plugins, but we build/install only xv anyway
+GST_PLUGINS_BUILD="x xvideo xshm"
+GST_PLUGINS_BUILD_DIR="xvimage"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+
+ gstreamer_system_link \
+ gst-libs/gst/video:gstreamer-video \
+ gst-libs/gst/interfaces:gstreamer-interfaces
+}