summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-11 19:44:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-11 19:44:01 +0000
commit331e87e9130b37f4a50510782c328f873cf66fac (patch)
tree573af7747f8fa433a685239fce1d0825cfb150f0 /media-plugins
parentVersion bump. (diff)
downloadgentoo-2-331e87e9130b37f4a50510782c328f873cf66fac.tar.gz
gentoo-2-331e87e9130b37f4a50510782c328f873cf66fac.tar.bz2
gentoo-2-331e87e9130b37f4a50510782c328f873cf66fac.zip
Version bump.
(Portage version: 2.1.2_rc3-r2)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog9
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc1.ebuild76
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-automagic.patch64
-rw-r--r--media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc13
4 files changed, 151 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index 60d7f9059bf5..5940cb57e5b7 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.32 2006/11/25 18:00:28 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.33 2006/12/11 19:44:01 flameeyes Exp $
+
+*alsa-plugins-1.0.14_rc1 (11 Dec 2006)
+
+ 11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsa-plugins-1.0.14_rc1-automagic.patch,
+ +alsa-plugins-1.0.14_rc1.ebuild:
+ Version bump.
25 Nov 2006; Bryan Østergaard <kloeri@gentoo.org>
alsa-plugins-1.0.13.ebuild:
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc1.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc1.ebuild
new file mode 100644
index 000000000000..6a1425ead9be
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:44:01 flameeyes Exp $
+
+WANT_AUTOMAKE=latest
+WANT_AUTOCONF=latest
+
+inherit libtool autotools eutils flag-o-matic
+
+MY_P="${P/_/}"
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="jack ffmpeg libsamplerate pulseaudio debug"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.12_rc1
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ ffmpeg? ( media-video/ffmpeg )
+ libsamplerate? ( media-libs/libsamplerate )
+ pulseaudio? ( media-sound/pulseaudio )
+ !media-plugins/alsa-jack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.14_rc1-automagic.patch"
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ "${S}/pulse/Makefile.am"
+
+ eautoreconf
+
+ elibtoolize
+}
+
+src_compile() {
+ use debug || append-flags -DNDEBUG
+
+ # D-Bus is used for Maemo SDK, that standing to the
+ # changelog is related to n770... disable it until
+ # someone ask for it explicitely, to be on the safe
+ # side.
+ econf \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable pulseaudio) \
+ --disable-dbus \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd "${S}/doc"
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use pulseaudio && dodoc README-pulse
+}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-automagic.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-automagic.patch
new file mode 100644
index 000000000000..4e86d5f428d4
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.14_rc1-automagic.patch
@@ -0,0 +1,64 @@
+Index: alsa-plugins-1.0.12rc1/configure.in
+===================================================================
+--- alsa-plugins-1.0.12rc1.orig/configure.in
++++ alsa-plugins-1.0.12rc1/configure.in
+@@ -13,22 +13,40 @@ PKG_CHECK_MODULES(ALSA, alsa >= 1.0.11)
+ AC_CHECK_LIB(asound, snd_pcm_ioplug_create,,
+ AC_ERROR([*** libasound has no external plugin SDK]), -ldl)
+
+-PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
++AC_ARG_ENABLE([jack],
++ AC_HELP_STRING([--disable-jack], [Disable building of JACK plugin]))
++if test "x$enable_jack" != "xno"; then
++ PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
++fi
+ AM_CONDITIONAL(HAVE_JACK, test x$HAVE_JACK = xyes)
+
+-PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
++AC_ARG_ENABLE([pulseaudio],
++ AC_HELP_STRING([--disable-pulseaudio], [Disable building of pulseaudio plugin]))
++if test "x$enable_pulseaudio" != "xno"; then
++ PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
++fi
+ AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
+
+-PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
++AC_ARG_ENABLE([samplerate],
++ AC_HELP_STRING([--disable-samplerate], [Disable building of samplerate plugin]))
++if test "x$enable_samplerate" != "xno"; then
++ PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
++fi
+ AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
+
+-PKG_CHECK_MODULES(DBUS, [dbus-1], [HAVE_DBUS=yes], [HAVE_DBUS=no])
++AC_ARG_ENABLE([dbus],
++ AC_HELP_STRING([--disable-dbus], [Disable using of dbus server as resource manager plugin]))
++if test "x$enable_dbus" != "xno"; then
++ PKG_CHECK_MODULES(DBUS, [dbus-1], [HAVE_DBUS=yes], [HAVE_DBUS=no])
++fi
+ AM_CONDITIONAL(HAVE_DBUS, test x$HAVE_DBUS = xyes)
+
+ if test "$HAVE_DBUS" = "yes"; then
+ AC_DEFINE(USE_RESOURCE_MANAGER, 1,"Use dbus server as a resouce manager")
+ fi
+
++AC_ARG_ENABLE([avcodec],
++ AC_HELP_STRING([--disable-avcodec], [Disable building of avcodec code (a52 plugin)]))
+ AC_ARG_WITH([avcodec-includedir],
+ [--with-avcodec-includedir=dir AVcodec include directory],
+ [AVCODEC_CFLAGS="-I$withval"], [AVCODEC_CFLAGS=""])
+@@ -35,9 +49,11 @@ LDFLAGS="$LDFLAGS $AVCODEC_LIBS"
+ AC_SUBST(AVCODEC_CFLAGS)
+ AVCODEC_LIBS="$AVCODEC_LIBS -lavcodec"
+ AC_SUBST(AVCODEC_LIBS)
+-AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+-if test x$HAVE_AVCODEC = xyes; then
+- AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
++if test "x$enable_avcodec" != "xno"; then
++ AC_CHECK_LIB([avcodec], [avcodec_open], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
++ if test x$HAVE_AVCODEC = xyes; then
++ AC_CHECK_HEADER([ffmpeg/avcodec.h], [], [HAVE_AVCODEC=no])
++ fi
+ fi
+ AM_CONDITIONAL(HAVE_AVCODEC, test x$HAVE_AVCODEC = xyes)
+ CFLAGS="$CFLAGS_saved"
diff --git a/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc1 b/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc1
new file mode 100644
index 000000000000..de09a286d941
--- /dev/null
+++ b/media-plugins/alsa-plugins/files/digest-alsa-plugins-1.0.14_rc1
@@ -0,0 +1,3 @@
+MD5 d1dc60951c867fbdb5eb9f6a7ac4cf6b alsa-plugins-1.0.14rc1.tar.bz2 247068
+RMD160 dba9585ac2f1b154c67300c2c340b25b3ddad50b alsa-plugins-1.0.14rc1.tar.bz2 247068
+SHA256 c061433cd0568ffcb448f570d92e77caf3bcab4b8e1c1d0db45651653db0b794 alsa-plugins-1.0.14rc1.tar.bz2 247068