summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-12-15 13:27:34 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-12-15 13:27:34 +0000
commit187be542731a1586ca88bc8be3aa5d37e315787a (patch)
tree815f298fb3d78e52e51c0111af7d63c1ea08d68d /media-plugins
parentkeyword ~x86-linux (diff)
downloadgentoo-2-187be542731a1586ca88bc8be3aa5d37e315787a.tar.gz
gentoo-2-187be542731a1586ca88bc8be3aa5d37e315787a.tar.bz2
gentoo-2-187be542731a1586ca88bc8be3aa5d37e315787a.zip
compile fix for >=vdr-1.7.33; eapi=5
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-epgsearch/ChangeLog6
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff120
-rw-r--r--media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild8
3 files changed, 131 insertions, 3 deletions
diff --git a/media-plugins/vdr-epgsearch/ChangeLog b/media-plugins/vdr-epgsearch/ChangeLog
index 5a087143bff4..d3d696a2db96 100644
--- a/media-plugins/vdr-epgsearch/ChangeLog
+++ b/media-plugins/vdr-epgsearch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-epgsearch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/ChangeLog,v 1.58 2012/06/05 19:59:38 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/ChangeLog,v 1.59 2012/12/15 13:27:34 hd_brummy Exp $
+
+ 15 Dec 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ vdr-epgsearch-1.0.0-r1.ebuild, +files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff:
+ compile fix for >=vdr-1.7.33; eapi=5
05 Jun 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-epgsearch-1.0.0-r1.ebuild:
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff
new file mode 100644
index 000000000000..aa51685cb282
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff
@@ -0,0 +1,120 @@
+diff -Naur epgsearch-1.0.0.orig/epgsearchsvdrp.c epgsearch-1.0.0/epgsearchsvdrp.c
+--- epgsearch-1.0.0.orig/epgsearchsvdrp.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/epgsearchsvdrp.c 2012-12-15 11:44:38.000000000 +0100
+@@ -564,7 +564,7 @@
+ strftime(bufStart, sizeof(bufStart), "%H%M", localtime_r(&start, &tm_r));
+ strftime(bufEnd, sizeof(bufEnd), "%H%M", localtime_r(&stop, &tm_r));
+
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool hasTimer = false;
+ if (Timers.GetMatch(pEvent, &timerMatch))
+ hasTimer = (timerMatch == tmFull);
+diff -Naur epgsearch-1.0.0.orig/mail.c epgsearch-1.0.0/mail.c
+--- epgsearch-1.0.0.orig/mail.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/mail.c 2012-12-15 11:45:02.000000000 +0100
+@@ -49,7 +49,7 @@
+ const cEvent* pEvent = GetEvent();
+ if (!pEvent) return "";
+
+- int TimerMatch = tmNone;
++ eTimerMatch TimerMatch = tmNone;
+ cTimer* pTimer = Timers.GetMatch(pEvent, &TimerMatch);
+ if (!pTimer) return "";
+
+diff -Naur epgsearch-1.0.0.orig/menu_commands.c epgsearch-1.0.0/menu_commands.c
+--- epgsearch-1.0.0.orig/menu_commands.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_commands.c 2012-12-15 11:45:40.000000000 +0100
+@@ -121,7 +121,7 @@
+ {
+ if (!event) return osContinue;
+
+- int timerMatch = tmNone;
++ eTimerMatch timerMatch = tmNone;
+ cTimer* timer = Timers.GetMatch(event, &timerMatch);
+ if (timerMatch == tmFull)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_event.c epgsearch-1.0.0/menu_event.c
+--- epgsearch-1.0.0.orig/menu_event.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_event.c 2012-12-15 11:46:17.000000000 +0100
+@@ -92,7 +92,7 @@
+ cEventObj* eventObjPrev = GetPrev(event);
+ cEventObj* eventObjNext = GetNext(event);
+
+- int timerMatch = tmNone;
++ eTimerMatch timerMatch = tmNone;
+ Timers.GetMatch(event, &timerMatch);
+ const char* szRed = trVDR("Button$Record");
+ if (timerMatch == tmFull)
+diff -Naur epgsearch-1.0.0.orig/menu_main.c epgsearch-1.0.0/menu_main.c
+--- epgsearch-1.0.0.orig/menu_main.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_main.c 2012-12-15 11:47:08.000000000 +0100
+@@ -181,7 +181,7 @@
+ if (item) {
+ if (item->timerMatch == tmFull)
+ {
+- int tm = tmNone;
++ eTimerMatch tm = tmNone;
+ cTimer *timer = Timers.GetMatch(item->event, &tm);
+ if (timer)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_searchresults.c epgsearch-1.0.0/menu_searchresults.c
+--- epgsearch-1.0.0.orig/menu_searchresults.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_searchresults.c 2012-12-15 11:51:12.000000000 +0100
+@@ -217,7 +217,7 @@
+ if (item) {
+ if (item->timerMatch == tmFull)
+ {
+- int tm = tmNone;
++ eTimerMatch tm = tmNone;
+ cTimer *timer = Timers.GetMatch(item->event, &tm);
+ if (timer)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_searchresults.h epgsearch-1.0.0/menu_searchresults.h
+--- epgsearch-1.0.0.orig/menu_searchresults.h 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_searchresults.h 2012-12-15 11:51:57.000000000 +0100
+@@ -50,7 +50,7 @@
+ bool episodeOnly;
+ cMenuTemplate* menuTemplate;
+ public:
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool inSwitchList;
+ const cEvent *event;
+ const cSearchExt* search;
+diff -Naur epgsearch-1.0.0.orig/menu_whatson.c epgsearch-1.0.0/menu_whatson.c
+--- epgsearch-1.0.0.orig/menu_whatson.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_whatson.c 2012-12-15 11:52:37.000000000 +0100
+@@ -527,7 +527,7 @@
+ {
+ if (item->timerMatch == tmFull)
+ {
+- int tm = tmNone;
++ eTimerMatch tm = tmNone;
+ cTimer *timer = Timers.GetMatch(item->event, &tm);
+ if (timer)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_whatson.h epgsearch-1.0.0/menu_whatson.h
+--- epgsearch-1.0.0.orig/menu_whatson.h 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_whatson.h 2012-12-15 11:53:09.000000000 +0100
+@@ -35,7 +35,7 @@
+ const cEvent *event;
+ cChannel *channel;
+ showMode mode;
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool inSwitchList;
+ cMenuTemplate* menuTemplate;
+
+diff -Naur epgsearch-1.0.0.orig/services.c epgsearch-1.0.0/services.c
+--- epgsearch-1.0.0.orig/services.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/services.c 2012-12-15 11:53:34.000000000 +0100
+@@ -143,7 +143,7 @@
+ strftime(bufStart, sizeof(bufStart), "%H%M", localtime_r(&start, &tm_r));
+ strftime(bufEnd, sizeof(bufEnd), "%H%M", localtime_r(&stop, &tm_r));
+
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool hasTimer = false;
+ if (Timers.GetMatch(pEvent, &timerMatch))
+ hasTimer = (timerMatch == tmFull);
diff --git a/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
index b58d2827494b..e0604647ba71 100644
--- a/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
+++ b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild,v 1.4 2012/06/05 19:59:38 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild,v 1.5 2012/12/15 13:27:34 hd_brummy Exp $
-EAPI="4"
+EAPI="5"
inherit vdr-plugin-2
@@ -46,6 +46,10 @@ src_prepare() {
sed -i "s:SetRecording(recording->FileName(), recording->Title:SetRecording(recording->FileName:" menu_searchresults.c
fi
+ if has_version ">=media-video/vdr-1.7.33"; then
+ epatch "${FILESDIR}/${P}_vdr-1.7.33.diff"
+ fi
+
# disable automagic deps
sed -i Makefile -e '/^AUTOCONFIG=/s/^/#/'