summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-01-24 13:35:38 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-01-24 13:35:38 +0000
commit06c1be90c332a9eaf1b5fa1c2a9dd13239e4cc02 (patch)
tree39596ebb78046ff5058fe535d9c17b8b7069dc16 /media-plugins
parentppc stable #256029 (diff)
downloadgentoo-2-06c1be90c332a9eaf1b5fa1c2a9dd13239e4cc02.tar.gz
gentoo-2-06c1be90c332a9eaf1b5fa1c2a9dd13239e4cc02.tar.bz2
gentoo-2-06c1be90c332a9eaf1b5fa1c2a9dd13239e4cc02.zip
gcc-4.3.x compile fix added; thx to Arrtu Valo on bug 255873
(Portage version: 2.1.6.4/cvs/Linux 2.6.21-xen-main-r1 i686)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-xxvautotimer/ChangeLog10
-rw-r--r--media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_compile-warn.diff37
-rw-r--r--media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.3.x.diff37
-rw-r--r--media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild7
4 files changed, 87 insertions, 4 deletions
diff --git a/media-plugins/vdr-xxvautotimer/ChangeLog b/media-plugins/vdr-xxvautotimer/ChangeLog
index ad91868421b1..f8a195bbf174 100644
--- a/media-plugins/vdr-xxvautotimer/ChangeLog
+++ b/media-plugins/vdr-xxvautotimer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-xxvautotimer
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/ChangeLog,v 1.1 2008/03/22 18:27:10 hd_brummy Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/ChangeLog,v 1.2 2009/01/24 13:35:38 hd_brummy Exp $
+
+ 24 Jan 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/vdr-xxvautotimer-0.1.2_compile-warn.diff,
+ +files/vdr-xxvautotimer-0.1.2_gcc-4.3.x.diff,
+ vdr-xxvautotimer-0.1.2.ebuild:
+ gcc-4.3.x compile fix added; thx to Arrtu Valo on bug 255873
*vdr-xxvautotimer-0.1.2 (22 Mar 2008)
diff --git a/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_compile-warn.diff b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_compile-warn.diff
new file mode 100644
index 000000000000..56ba37f08a57
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_compile-warn.diff
@@ -0,0 +1,37 @@
+diff -Naur xxvautotimer-0.1.2.orig/setup.h xxvautotimer-0.1.2/setup.h
+--- xxvautotimer-0.1.2.orig/setup.h 2009-01-24 13:24:34.245788686 +0100
++++ xxvautotimer-0.1.2/setup.h 2009-01-24 13:25:52.750838304 +0100
+@@ -22,19 +22,19 @@
+ class cXxvAutotimerSetup
+ {
+ public:
+- char *allowed;
+- char *strHost;
+- char *strTelnetPort;
+- char *strDatabase;
+- char *strDatabasePort;
+- char *strDatabaseUser;
+- char *strDatabasePasswd;
+- char *strLifetime;
+- char *strPriority;
+- char *strPrevMinutes;
+- char *strAfterMinutes;
+- char *strXXV020;
+- char *strDefaultDone;
++ const char *allowed;
++ const char *strHost;
++ const char *strTelnetPort;
++ const char *strDatabase;
++ const char *strDatabasePort;
++ const char *strDatabaseUser;
++ const char *strDatabasePasswd;
++ const char *strLifetime;
++ const char *strPriority;
++ const char *strPrevMinutes;
++ const char *strAfterMinutes;
++ const char *strXXV020;
++ const char *strDefaultDone;
+
+ char host[50];
+ int telnetPort;
+
diff --git a/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.3.x.diff b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.3.x.diff
new file mode 100644
index 000000000000..77e082bfd003
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.3.x.diff
@@ -0,0 +1,37 @@
+http://bugs.gentoo.org/show_bug.cgi?id=255873
+diff -Naur xxvautotimer-0.1.2.orig/inifile.cpp xxvautotimer-0.1.2/inifile.cpp
+--- xxvautotimer-0.1.2.orig/inifile.cpp 2009-01-24 12:55:58.165959458 +0100
++++ xxvautotimer-0.1.2/inifile.cpp 2009-01-24 12:58:41.539432919 +0100
+@@ -43,6 +43,9 @@
+ #include <stdarg.h>
+ #include <fstream>
+ #include <float.h>
++#include <cstdlib>
++#include <cstring>
++#include <climits>
+
+ #ifdef WIN32
+ #include <windows.h>
+diff -Naur xxvautotimer-0.1.2.orig/mysqlwrapped-1.4/enum_t.h xxvautotimer-0.1.2/mysqlwrapped-1.4/enum_t.h
+--- xxvautotimer-0.1.2.orig/mysqlwrapped-1.4/enum_t.h 2009-01-24 12:55:58.165959458 +0100
++++ xxvautotimer-0.1.2/mysqlwrapped-1.4/enum_t.h 2009-01-24 12:57:48.299275050 +0100
+@@ -22,6 +22,7 @@
+
+ #include <string>
+ #include <map>
++#include <cstring>
+ #ifdef WIN32
+ #include <config-win.h>
+ #include <mysql.h>
+diff -Naur xxvautotimer-0.1.2.orig/mysqlwrapped-1.4/SysLog.cpp xxvautotimer-0.1.2/mysqlwrapped-1.4/SysLog.cpp
+--- xxvautotimer-0.1.2.orig/mysqlwrapped-1.4/SysLog.cpp 2009-01-24 12:55:58.165959458 +0100
++++ xxvautotimer-0.1.2/mysqlwrapped-1.4/SysLog.cpp 2009-01-24 12:57:14.999276857 +0100
+@@ -25,6 +25,7 @@
+
+ #include <mysql/mysql.h>
+ #include <syslog.h>
++#include <cstring>
+
+ #include "Database.h"
+ #include "Query.h"
+
diff --git a/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild
index e16b9e226d79..b4860be1c927 100644
--- a/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild
+++ b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild,v 1.1 2008/03/22 18:27:10 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2.ebuild,v 1.2 2009/01/24 13:35:38 hd_brummy Exp $
inherit vdr-plugin
@@ -17,6 +17,9 @@ DEPEND=">=media-video/vdr-1.3.0"
RDEPEND=">=net-www/xxv-0.30"
+PATCHES=("${FILESDIR}/${P}_gcc-4.3.x.diff"
+ "${FILESDIR}/${P}_compile-warn.diff")
+
src_unpack() {
vdr-plugin_src_unpack