summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-24 20:29:50 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-24 20:29:50 +0000
commit5f55e66720ee4ca6f58854927a48e37a0fe17fed (patch)
tree298878a36bd91d2e460e9bfcd73ca044a349ceda /media-plugins/xmms-musepack
parentmanifest (diff)
downloadgentoo-2-5f55e66720ee4ca6f58854927a48e37a0fe17fed.tar.gz
gentoo-2-5f55e66720ee4ca6f58854927a48e37a0fe17fed.tar.bz2
gentoo-2-5f55e66720ee4ca6f58854927a48e37a0fe17fed.zip
touchups
Diffstat (limited to 'media-plugins/xmms-musepack')
-rw-r--r--media-plugins/xmms-musepack/Manifest6
-rw-r--r--media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild25
-rw-r--r--media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild12
3 files changed, 20 insertions, 23 deletions
diff --git a/media-plugins/xmms-musepack/Manifest b/media-plugins/xmms-musepack/Manifest
index 136908380cbd..9940ec4eb7c8 100644
--- a/media-plugins/xmms-musepack/Manifest
+++ b/media-plugins/xmms-musepack/Manifest
@@ -1,6 +1,6 @@
-MD5 6497444c45707adc926fdc89246bea9c xmms-musepack-0.94.ebuild 778
-MD5 4eb40475215aaf439b801c073a5d3b7a ChangeLog 680
-MD5 d8c447bcfa21155556ec090fe2048cde xmms-musepack-0.94-r1.ebuild 1199
MD5 a9df10edf2898414b6f2958643b63477 files/digest-xmms-musepack-0.94 70
MD5 a9df10edf2898414b6f2958643b63477 files/digest-xmms-musepack-0.94-r1 70
MD5 ed030d04fa02f984be113732ad39b061 files/xmms-musepack-0.94-bad-makefile.patch 956
+MD5 4eb40475215aaf439b801c073a5d3b7a ChangeLog 680
+MD5 688a798b7035136166b5d6d06a625efa xmms-musepack-0.94.ebuild 713
+MD5 d05e26b446c9ef29cb22c0d457e4f2f7 xmms-musepack-0.94-r1.ebuild 1135
diff --git a/media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild b/media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild
index e5039e0b7350..3568dc6094b1 100644
--- a/media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild
+++ b/media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild,v 1.1 2003/06/03 12:03:27 robh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-musepack/xmms-musepack-0.94-r1.ebuild,v 1.2 2003/06/24 20:29:50 vapier Exp $
-DESCRIPTION="This plugin for XMMS can play audio files which are encoded with Andree Buschmann's encoder Musepack. These files have the filename postfixes mpc, mp+ or mpp."
+inherit flag-o-matic eutils
+
+# Enabling -mfpath=sse can cause high-pitched whine, at least on Pentiums.
+# This drops the entire flag for safety. Reports of success with any variations
+# would be welcomed, but mind those eardrums!
+filter-flags "-mfpmath=sse -mfpmath=387 -mfpmath=sse,387"
+
+DESCRIPTION="XMMS plugin to play audio files encoded with Andree Buschmann's encoder Musepack (mpc, mp+, mpp)"
HOMEPAGE="http://sourceforge.net/projects/mpegplus/"
SRC_URI="mirror://sourceforge/mpegplus/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
IUSE=""
-DEPEND=">=media-sound/xmms-1.2.7-r15"
-
-inherit flag-o-matic eutils
-# Enabling -mfpath=sse can cause high-pitched whine, at least on Pentiums.
-# This drops the entire flag for safety. Reports of success with any variations
-# would be welcomed, but mind those eardrums!
-filter-flags "-mfpmath=sse -mfpmath=387 -mfpmath=sse,387"
+DEPEND=">=media-sound/xmms-1.2.7-r15"
src_unpack() {
unpack ${A}
@@ -27,9 +27,8 @@ src_unpack() {
}
src_compile() {
- # Makefile will use ARCH when calling gcc.
- ARCH="${CFLAGS}"
- emake || die
+ # Makefile will use ARCH when calling gcc
+ emake ARCH="${CFLAGS}" || die
}
src_install() {
diff --git a/media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild b/media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild
index 7fe1ebef8e0d..46a2be262273 100644
--- a/media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild
+++ b/media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild
@@ -1,26 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild,v 1.1 2003/03/15 09:24:50 jje Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-musepack/xmms-musepack-0.94.ebuild,v 1.2 2003/06/24 20:29:50 vapier Exp $
-DESCRIPTION="This plugin for XMMS can play audio files which are encoded with Andree Buschmann's encoder Musepack. These files have the filename postfixes mpc, mp+ or mpp."
+DESCRIPTION="XMMS plugin to play audio files encoded with Andree Buschmann's encoder Musepack (mpc, mp+, mpp)"
HOMEPAGE="http://sourceforge.net/projects/mpegplus/"
SRC_URI="mirror://sourceforge/mpegplus/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
IUSE=""
+
DEPEND=">=media-sound/xmms-1.2.7-r15"
src_compile() {
- # Makefile uses ARCH when calling gcc.
- ARCH="${CFLAGS}"
- emake || die
+ # Makefile uses ARCH when calling gcc
+ emake ARCH="${CFLAGS}" || die
}
src_install() {
exeinto `xmms-config --input-plugin-dir`
doexe ${P}.so
}
-