summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-10-06 13:32:40 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-10-06 13:32:40 +0000
commit87c8941429d1e978c420f38ecb0dfcfb991eb10d (patch)
tree47669d2754d87557269e55ea6417d3b8138f742e /media-plugins/vdr-xineliboutput
parentFix build-time dependencies. (diff)
downloadgentoo-2-87c8941429d1e978c420f38ecb0dfcfb991eb10d.tar.gz
gentoo-2-87c8941429d1e978c420f38ecb0dfcfb991eb10d.tar.bz2
gentoo-2-87c8941429d1e978c420f38ecb0dfcfb991eb10d.zip
Version bumped. Mostly a bugfix release.
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-tuxonice-r6 i686)
Diffstat (limited to 'media-plugins/vdr-xineliboutput')
-rw-r--r--media-plugins/vdr-xineliboutput/ChangeLog8
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.2.ebuild109
2 files changed, 116 insertions, 1 deletions
diff --git a/media-plugins/vdr-xineliboutput/ChangeLog b/media-plugins/vdr-xineliboutput/ChangeLog
index 0aae6741da8d..d7cd2bd0e4b7 100644
--- a/media-plugins/vdr-xineliboutput/ChangeLog
+++ b/media-plugins/vdr-xineliboutput/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-xineliboutput
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/ChangeLog,v 1.40 2008/08/01 20:00:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/ChangeLog,v 1.41 2008/10/06 13:32:40 zzam Exp $
+
+*vdr-xineliboutput-1.0.2 (06 Oct 2008)
+
+ 06 Oct 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +vdr-xineliboutput-1.0.2.ebuild:
+ Version bumped. Mostly a bugfix release.
01 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.2.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.2.ebuild
new file mode 100644
index 000000000000..899ff124d3e1
--- /dev/null
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xineliboutput/vdr-xineliboutput-1.0.2.ebuild,v 1.1 2008/10/06 13:32:40 zzam Exp $
+
+inherit vdr-plugin eutils multilib versionator
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+SO_VERSION="${PV%_p*}"
+SO_VERSION="${SO_VERSION/_/}"
+
+DESCRIPTION="Video Disk Recorder Xinelib PlugIn"
+HOMEPAGE="http://sourceforge.net/projects/xineliboutput/"
+SRC_URI="mirror://sourceforge/${PN#vdr-}/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="fbcon X libextractor"
+
+RDEPEND=">=media-video/vdr-1.4.0
+ >=media-libs/xine-lib-1.1.1
+ media-libs/jpeg
+ libextractor? ( >=media-libs/libextractor-0.5.20 )
+ X? (
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto
+ x11-proto/renderproto
+ )"
+
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ X? (
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXext
+ x11-libs/libXrender
+ )"
+
+S=${WORKDIR}/${MY_P#vdr-}
+
+VDR_CONFD_FILE=${FILESDIR}/confd-1.0.0_pre6
+
+use_onoff() {
+ if use "$1"; then
+ echo 1
+ else
+ echo 0
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ cd "${S}"
+
+ XINE_PLUGIN_DIR=$(xine-config --plugindir)
+ if [[ ${XINE_PLUGIN_DIR} = "" ]]; then
+ eerror "Could not find xine plugin dir"
+ die "Could not find xine plugin dir"
+ fi
+ # stop some automagic overwriting the stuff we set
+ sed -e '/XINELIBOUTPUT_VDRPLUGIN = 1/s/^/#/' \
+ -e '/HAVE_EXTRACTOR_H = 1/s/^/#/' \
+ -i Makefile
+
+ cat >>Make.config <<-EOF
+ XINELIBOUTPUT_XINEPLUGIN = 1
+ XINELIBOUTPUT_VDRPLUGIN = 1
+
+ XINELIBOUTPUT_FB = $(use_onoff fbcon)
+ XINELIBOUTPUT_X11 = $(use_onoff X)
+
+ HAVE_XRENDER = 1
+ HAVE_XDPMS = 1
+ HAVE_EXTRACTOR_H = $(use_onoff libextractor)
+ EOF
+
+ # patching makefile to work with this
+ # $ rm ${outdir}/file; cp file ${outdir}/file
+ # work in the sandbox
+ sed -i Makefile \
+ -e 's:XINEPLUGINDIR.*=.*:XINEPLUGINDIR = '"${WORKDIR}/lib:" \
+ -e 's:VDRINCDIR.*=.*:VDRINCDIR ?= /usr/include:'
+ mkdir -p "${WORKDIR}/lib"
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ use fbcon && dobin vdr-fbfe
+ use X && dobin vdr-sxfe
+
+ # There may be no sub-plugin, depending on use-flags
+ insinto ${VDR_PLUGIN_DIR}
+ local f
+ for f in libxineliboutput*.so.${SO_VERSION}; do
+ [[ -f "$f" ]] || continue
+ doins "${f}" || die "could not install sub-plugin ${f}"
+ done
+
+ insinto "${XINE_PLUGIN_DIR}"
+ doins xineplug_inp_*.so
+
+ insinto "${XINE_PLUGIN_DIR}"/post
+ doins xineplug_post_*.so
+}