summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-01-20 15:39:35 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-01-20 15:39:35 +0000
commitb819c1a8245d583f9a30596bbf25a0d6501bdd75 (patch)
treeec3231580a1db74c9339b27ca1703f7c5f346313 /media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild
parentAdd exception for findutils dependency for BSDs since they bring their own. (diff)
downloadgentoo-2-b819c1a8245d583f9a30596bbf25a0d6501bdd75.tar.gz
gentoo-2-b819c1a8245d583f9a30596bbf25a0d6501bdd75.tar.bz2
gentoo-2-b819c1a8245d583f9a30596bbf25a0d6501bdd75.zip
Fix bash script announcing itself as needing /bin/sh
(Portage version: 2.1.6.6/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild')
-rw-r--r--media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild b/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild
new file mode 100644
index 000000000000..0368fd5d4af8
--- /dev/null
+++ b/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild,v 1.1 2009/01/20 15:39:35 zzam Exp $
+
+inherit vdr-plugin eutils
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="VDR plugin: show weather for specified place"
+HOMEPAGE="http://www.vdr.glaserei-franz.de/vdrplugins.htm"
+SRC_URI="mirror://vdrfiles/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2 stardock-images"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dxr3"
+
+DEPEND="media-libs/imlib2
+ >=media-video/vdr-1.3.34"
+
+S="${WORKDIR}/weatherng-${MY_PV}"
+
+VDR_CONFD_FILE="${FILESDIR}/confd-0.0.8"
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.0.8.sh"
+
+PATCHES=("${FILESDIR}/${P}-i18n-fix.diff")
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if ! built_with_use media-libs/imlib2 jpeg gif ; then
+ echo
+ eerror "Please recompile media-libs/imlib2 with"
+ eerror "USE=\"jpeg gif\""
+ die "media-libs/imlib2 need jpeg and gif support"
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-timeout.diff"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
+ use dxr3 && epatch "${FILESDIR}/${P}-dxr3.diff"
+
+ # /bin/sh is not necessaryly bash, so explicitly use /bin/bash
+ sed -e 's#/bin/sh#/bin/bash#' -i examples/weatherng.sh
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ insinto /usr/share/vdr/weatherng/images
+ doins "${S}"/images/*.png
+
+ diropts -m0755 -ovdr -gvdr
+ dodir /var/vdr/${VDRPLUGIN}
+
+ insinto /var/vdr/${VDRPLUGIN}
+ insopts -m755 -ovdr -gvdr
+ doins "${S}"/examples/weatherng.sh
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ echo
+ elog "To display the weather for your location"
+ elog "you have to find out its ID on weather.com"
+ elog
+ elog "Go to http://uk.weather.com/search/drilldown/ and search for your city (i.e. Herne)"
+ elog "in the list of results click on the right one and then look at its URL"
+ elog
+ elog "It contains a code for your city"
+ elog "For Herne this is GMXX0056"
+ elog
+ elog "Now you have to enter this code in /etc/conf.d/vdr.weatherng WEATHERNG_STATIONID(x)"
+ echo
+}