summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-11-24 21:51:36 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-11-24 21:51:36 +0000
commit2d0ca4e33a89b581f9847db16fd4d2cbc818c251 (patch)
tree917ad122d2816b7bbcdeb117967cf3708ee5355f /media-plugins/vdr-softdevice
parentAdded ~ppc64; bug #155342 (diff)
downloadgentoo-2-2d0ca4e33a89b581f9847db16fd4d2cbc818c251.tar.gz
gentoo-2-2d0ca4e33a89b581f9847db16fd4d2cbc818c251.tar.bz2
gentoo-2-2d0ca4e33a89b581f9847db16fd4d2cbc818c251.zip
Added cvs-snapshot that will perhaps solve Bug #145590.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'media-plugins/vdr-softdevice')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog8
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1.200611243
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061124.ebuild136
3 files changed, 146 insertions, 1 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index d5544b8468bb..c6c7a7e733b2 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.29 2006/11/23 12:44:16 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.30 2006/11/24 21:51:36 zzam Exp $
+
+*vdr-softdevice-0.3.1.20061124 (24 Nov 2006)
+
+ 24 Nov 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +vdr-softdevice-0.3.1.20061124.ebuild:
+ Added cvs-snapshot that will perhaps solve Bug #145590.
*vdr-softdevice-0.3.1-r2 (23 Nov 2006)
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1.20061124 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1.20061124
new file mode 100644
index 000000000000..7fcd71db4f4f
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1.20061124
@@ -0,0 +1,3 @@
+MD5 9f249fdd5c631cc86f805110d4fde586 vdr-softdevice-cvs-20061124.tar.bz2 131902
+RMD160 b0bf6df5570a0bcfd8c17e36d43b868b8daac2a4 vdr-softdevice-cvs-20061124.tar.bz2 131902
+SHA256 e6f12f790de569090277513d40fa8a4658063d5c4d006e9788cfc4c1b2cf0aae vdr-softdevice-cvs-20061124.tar.bz2 131902
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061124.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061124.ebuild
new file mode 100644
index 000000000000..b451e5e66391
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061124.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1.20061124.ebuild,v 1.1 2006/11/24 21:51:36 zzam Exp $
+
+inherit vdr-plugin
+
+MY_P="${PN}-cvs-${PV#0.3.1.}"
+S="${WORKDIR}/${MY_P#vdr-}"
+
+DESCRIPTION="VDR Plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~zzam/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )
+ dev-util/pkgconfig"
+
+
+PATCHES="
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/softdevice-cvs-xinerama-configure-opts.patch
+ ${FILESDIR}/vdr-softdevice-0.3.1-osdmode-software-default.diff"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+
+ # Check for ffmpeg relying on libtheora without pkg-config-file
+ # Bug #142250
+ if built_with_use media-video/ffmpeg theora && \
+ has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+ eerror "This package will not work when using ffmpeg with"
+ eerror "USE=\"theora\" combined with media-libs/libtheora"
+ eerror "older than version 1.0_alpha4."
+ eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+ die "Please update to at least media-libs/libtheora-1.0_alpha4."
+ fi
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ # MMX-Support
+ # hardcode mmx for amd64 - do not disable even without use-flag
+ if ! use amd64; then
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+ if use !mmx && use !mmxext; then
+ ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+ ewarn 'Please enable at least one of these two use-flags.'
+ die "${PN}"' does not compile with USE="-mmx -mmxext".'
+ fi
+ fi
+
+ use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ einfo configure ${MYOPTS}
+ ./configure ${MYOPTS} || die "configure failed"
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ cd ${S}
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsoftdevice-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+
+ insinto /usr/include/vdr-softdevice
+ doins *.h
+}
+