summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-04-28 19:17:57 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-04-28 19:17:57 +0000
commitb0c547b8d6be963348952143b7d908b0168471a6 (patch)
tree777414986ab8409159e74bf934a118569d44b51e /media-plugins/vdr-osdpip
parentKeyworded on alpha, bug #219466 (diff)
downloadgentoo-2-b0c547b8d6be963348952143b7d908b0168471a6.tar.gz
gentoo-2-b0c547b8d6be963348952143b7d908b0168471a6.tar.bz2
gentoo-2-b0c547b8d6be963348952143b7d908b0168471a6.zip
Version bumped.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'media-plugins/vdr-osdpip')
-rw-r--r--media-plugins/vdr-osdpip/ChangeLog9
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.9-ffmpeg-0.4.9_p20080326-new_header.diff24
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.0.9.ebuild34
3 files changed, 66 insertions, 1 deletions
diff --git a/media-plugins/vdr-osdpip/ChangeLog b/media-plugins/vdr-osdpip/ChangeLog
index 56593a5fbab8..03cb7bd635e8 100644
--- a/media-plugins/vdr-osdpip/ChangeLog
+++ b/media-plugins/vdr-osdpip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-osdpip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.5 2008/04/28 08:58:39 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.6 2008/04/28 19:17:57 zzam Exp $
+
+*vdr-osdpip-0.0.9 (28 Apr 2008)
+
+ 28 Apr 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-osdpip-0.0.9-ffmpeg-0.4.9_p20080326-new_header.diff,
+ +vdr-osdpip-0.0.9.ebuild:
+ Version bumped.
28 Apr 2008; Matthias Schwarzott <zzam@gentoo.org>
vdr-osdpip-0.0.8-r1.ebuild, vdr-osdpip-0.0.8-r2.ebuild:
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.9-ffmpeg-0.4.9_p20080326-new_header.diff b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.9-ffmpeg-0.4.9_p20080326-new_header.diff
new file mode 100644
index 000000000000..36d9a56c6b09
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.9-ffmpeg-0.4.9_p20080326-new_header.diff
@@ -0,0 +1,24 @@
+diff -ru osdpip-0.0.9-orig/decoder.h osdpip-0.0.9/decoder.h
+--- osdpip-0.0.9-orig/decoder.h 2008-04-28 21:08:38.871652831 +0200
++++ osdpip-0.0.9/decoder.h 2008-04-28 21:08:49.391651668 +0200
+@@ -12,7 +12,7 @@
+ #ifdef HAVE_FFMPEG_STATIC
+ # include <avcodec.h>
+ #else
+-# include <ffmpeg/avcodec.h>
++# include <libavcodec/avcodec.h>
+ #endif
+ }
+
+diff -ru osdpip-0.0.9-orig/osdpip.c osdpip-0.0.9/osdpip.c
+--- osdpip-0.0.9-orig/osdpip.c 2008-04-28 21:08:38.871652831 +0200
++++ osdpip-0.0.9/osdpip.c 2008-04-28 21:08:59.111649204 +0200
+@@ -9,7 +9,7 @@
+ #ifdef HAVE_FFMPEG_STATIC
+ # include <avcodec.h>
+ #else
+-# include <ffmpeg/avcodec.h>
++# include <libavcodec/avcodec.h>
+ #endif
+ }
+
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.0.9.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.9.ebuild
new file mode 100644
index 000000000000..27c5df0e9d80
--- /dev/null
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2003-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.0.9.ebuild,v 1.1 2008/04/28 19:17:57 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: Show another channel in the OSD"
+HOMEPAGE="http://www.magoa.net/linux"
+SRC_URI="http://home.arcor.de/andreas.regel/files/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.4.0
+ >=media-libs/libmpeg2-0.4.0
+ >=media-video/ffmpeg-0.4.8
+ "
+
+#PATCHES=("${FILESDIR}/${P}-vdr-1.5.0.diff")
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ /bin/sed -i Makefile \
+ -e 's+^FFMDIR.*$+FFMDIR = /usr/include/ffmpeg+' \
+ -e 's+-I\$(FFMDIR)/libavcodec+-I$(FFMDIR)+' \
+ -e 's+-L\$(FFMDIR)/libavcodec++'
+
+ if has_version ">=media-video/ffmpeg-0.4.9_p20080326" ; then
+ epatch "${FILESDIR}/${P}-ffmpeg-0.4.9_p20080326-new_header.diff"
+ fi
+}