summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-13 07:38:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-13 07:38:37 +0000
commitceb74922c384a738571922e6b52d761017647f5a (patch)
tree5639cc3af2b0214143baf67f0be49b57e79004db /media-plugins/swh-plugins
parentMask >=sci-chemistry/burrow-owl-1.4 pending unmasking of guile-gnome-platform... (diff)
downloadgentoo-2-ceb74922c384a738571922e6b52d761017647f5a.tar.gz
gentoo-2-ceb74922c384a738571922e6b52d761017647f5a.tar.bz2
gentoo-2-ceb74922c384a738571922e6b52d761017647f5a.zip
Use system libgsm, bug #252890
(Portage version: 2.2_rc21/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'media-plugins/swh-plugins')
-rw-r--r--media-plugins/swh-plugins/ChangeLog10
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.15-system_gsm.patch48
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.15-r1.ebuild70
3 files changed, 126 insertions, 2 deletions
diff --git a/media-plugins/swh-plugins/ChangeLog b/media-plugins/swh-plugins/ChangeLog
index 82860e679c46..7ef2f2bc9589 100644
--- a/media-plugins/swh-plugins/ChangeLog
+++ b/media-plugins/swh-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/swh-plugins
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.38 2008/10/05 11:31:01 aballier Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.39 2009/01/13 07:38:36 aballier Exp $
+
+*swh-plugins-0.4.15-r1 (13 Jan 2009)
+
+ 13 Jan 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/swh-plugins-0.4.15-system_gsm.patch, +swh-plugins-0.4.15-r1.ebuild:
+ Use system libgsm, bug #252890
05 Oct 2008; Alexis Ballier <aballier@gentoo.org>
swh-plugins-0.4.15.ebuild:
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.15-system_gsm.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-system_gsm.patch
new file mode 100644
index 000000000000..cc80af1f58c5
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.15-system_gsm.patch
@@ -0,0 +1,48 @@
+Index: swh-plugins-0.4.15/Makefile.am
+===================================================================
+--- swh-plugins-0.4.15.orig/Makefile.am
++++ swh-plugins-0.4.15/Makefile.am
+@@ -33,7 +33,7 @@ plugin_LTLIBRARIES = \
+ latency_1914.la xfade_1915.la sc4m_1916.la \
+ mbeq_1197.la pitch_scale_1193.la pitch_scale_1194.la imp_1199.la
+
+-SUBDIRS = m4 po util gsm gverb metadata
++SUBDIRS = m4 po util gverb metadata
+
+ # Wacky stuff to stop automake getting confused
+ EXTRA_DIST = @top_srcdir@/*.xml @top_srcdir@/*.c @top_srcdir@/*.h \
+@@ -72,7 +72,7 @@ sc3_1427_la_LIBADD = util/libdb.la util/
+ sc4_1882_la_LIBADD = util/libdb.la util/librms.la
+ sc4m_1916_la_LIBADD = util/libdb.la util/librms.la
+ se4_1883_la_LIBADD = util/libdb.la util/librms.la
+-gsm_1215_la_LIBADD = gsm/libgsm.la
++gsm_1215_la_LIBADD = @GSM_LIBS@
+ gverb_1216_la_LIBADD = gverb/libgverb.la
+ lcr_delay_1436_la_DEPENDENCIES = util/biquad.h
+
+Index: swh-plugins-0.4.15/configure.in
+===================================================================
+--- swh-plugins-0.4.15.orig/configure.in
++++ swh-plugins-0.4.15/configure.in
+@@ -136,17 +136,19 @@ else
+ AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datadir}/${PACKAGE}")
+ fi
+
+-subdirs="util gsm gverb metadata"
++GSM_LIBS=-lgsm
++
++subdirs="util gverb metadata"
+
+ AC_SUBST(subdirs)
+ AC_SUBST(FFTW_LIBS)
+ AC_SUBST(STATIC_FFTW_LIBS)
+ AC_SUBST(FFTW_CFLAGS)
++AC_SUBST(GSM_LIBS)
+ AC_SUBST(LIBTOOL)
+ AC_OUTPUT([ m4/Makefile
+ Makefile
+ util/Makefile
+-gsm/Makefile
+ gverb/Makefile
+ metadata/Makefile
+ po/Makefile.in
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.15-r1.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.15-r1.ebuild
new file mode 100644
index 000000000000..1146f8089b24
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.15-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.15-r1.ebuild,v 1.1 2009/01/13 07:38:36 aballier Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Large collection of LADSPA audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="3dnow nls sse"
+
+RDEPEND="media-libs/ladspa-sdk
+ media-sound/gsm
+ >=sci-libs/fftw-3"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/cvs
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-pic.patch"
+ epatch "${FILESDIR}/${P}-plugindir.patch"
+ epatch "${FILESDIR}/${P}-riceitdown.patch"
+ epatch "${FILESDIR}/${P}-gettext.patch"
+
+ # Use system libgsm, bug #252890
+ rm -rf gsm
+ epatch "${FILESDIR}/${P}-system_gsm.patch"
+
+ # This is to update gettext macros, otherwise they are incompatible with
+ # recent libtools, bug #231767
+ autopoint -f || die
+
+ # it doesn't get updated otherwise
+ rm -f missing
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ econf ${myconf} \
+ $(use_enable sse) \
+ $(use_enable 3dnow) \
+ $(use_enable nls) \
+ $(use_enable userland_Darwin darwin) \
+ --enable-fast-install \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the"
+ ewarn "swh plugins. Be sure to lower your sound volume"
+ ewarn "and then play around a bit with the plugins so"
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that."
+}