summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:59:25 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:59:25 +0000
commitdd13a3870dac1e5bb4c5c9d53a42aced2670833a (patch)
tree1509b5a4036e319fb88d776fa702521adff3c5c4 /media-plugins/mythvideo
parentinitial check-in (diff)
downloadgentoo-2-dd13a3870dac1e5bb4c5c9d53a42aced2670833a.tar.gz
gentoo-2-dd13a3870dac1e5bb4c5c9d53a42aced2670833a.tar.bz2
gentoo-2-dd13a3870dac1e5bb4c5c9d53a42aced2670833a.zip
initial check-in
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/ChangeLog36
-rw-r--r--media-plugins/mythvideo/Manifest4
-rw-r--r--media-plugins/mythvideo/files/digest-mythvideo-0.101
-rw-r--r--media-plugins/mythvideo/mythvideo-0.10.ebuild71
4 files changed, 110 insertions, 2 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
new file mode 100644
index 000000000000..ec24eda1c35c
--- /dev/null
+++ b/media-plugins/mythvideo/ChangeLog
@@ -0,0 +1,36 @@
+# ChangeLog for media-plugins/mythvideo
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.1 2003/07/08 23:54:58 johnm Exp $
+
+ 03 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythvideo-0.8.ebuild:
+ Set KEYWORDS to ~x86.
+
+*mythvideo-0.10 (01 Jul 2003)
+
+ 01 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythvideo-0.10.ebuild:
+ Bump version to 0.10. Add similar note as mythtv regarding the importance of
+ keeping database up to date between upgrades.
+
+ 26 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythvideo-0.8.ebuild:
+ Fix proper USE flag syntax.
+
+ 22 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythvideo-0.9.ebuild:
+ Cleanup and consistancy: depend on sed-4, die if sed fails. Drop unused
+ myconf setting.
+
+ 18 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythvideo-0.9.ebuild:
+ Change depend to media-tv/mythtv.
+
+*mythvideo-0.9 (09 Jun 2003)
+
+ 09 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythvideo-0.9.ebuild:
+ Bump to 0.9. Make all sed operations inline. Drop all config file handling
+ as it is all done online in the database now.
+
+ 14 Apr 2003; Jeremy Johnson <jeremy@ic.ucsb.edu> mythvideo-0.8.ebuild:
+ Generate a default mythvideo-settings.txt file and add xine and DVD support.
+
+*mythvideo-0.8 (27 Mar 2003)
+
+ 27 Mar 2003; Matt Taylor <liverbugg@juno.com> mythvideo-0.8.ebuild:
+ Initial import.
diff --git a/media-plugins/mythvideo/Manifest b/media-plugins/mythvideo/Manifest
index 3c284e7bc123..12fefc987a25 100644
--- a/media-plugins/mythvideo/Manifest
+++ b/media-plugins/mythvideo/Manifest
@@ -1,3 +1,3 @@
-MD5 092c6d390a93eb6fe2af637ad21012ec mythvideo-0.10.ebuild 1708
-MD5 f5d614ef3349dbdec44c81783096f682 ChangeLog 1401
+MD5 ddde854faa7cf78930840df3c0cba83b mythvideo-0.10.ebuild 1717
+MD5 a7ff67be94c10c17387ea6b6dcc56f4a ChangeLog 1410
MD5 bdd77fadda8f0eb40802ceb421042c18 files/digest-mythvideo-0.10 67
diff --git a/media-plugins/mythvideo/files/digest-mythvideo-0.10 b/media-plugins/mythvideo/files/digest-mythvideo-0.10
new file mode 100644
index 000000000000..bfeb08cc7185
--- /dev/null
+++ b/media-plugins/mythvideo/files/digest-mythvideo-0.10
@@ -0,0 +1 @@
+MD5 84637bcd01e07f49986ee2c6bde2bbf2 mythvideo-0.10.tar.bz2 197885
diff --git a/media-plugins/mythvideo/mythvideo-0.10.ebuild b/media-plugins/mythvideo/mythvideo-0.10.ebuild
new file mode 100644
index 000000000000..8474504406a3
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.10.ebuild,v 1.1 2003/07/08 23:54:58 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="Video player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-tv/mythtv-${PV}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+
+}
+
+src_install () {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins videodb/*.sql
+
+ dodoc COPYING README
+ newdoc videodb/README README.db
+
+}
+
+pkg_postinst() {
+
+ einfo "If this is the first time you install MythVideo,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+
+}