summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-11-21 05:28:37 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-11-21 05:28:37 +0000
commit224764d070bdb4824db13fe87edc296e33c6fa73 (patch)
tree8e2712995d59cad39d9fff721f1f5d8db8bc113e /media-plugins/mythvideo
parentadd initial version to the tree. bug #109719 (diff)
downloadgentoo-2-224764d070bdb4824db13fe87edc296e33c6fa73.tar.gz
gentoo-2-224764d070bdb4824db13fe87edc296e33c6fa73.tar.bz2
gentoo-2-224764d070bdb4824db13fe87edc296e33c6fa73.zip
update upstream JAMU version. Improve JAMU support by installing depends (which are now in the tree) and optionally installing default cronjobs to do the right things with JAMU
(Portage version: 2.1.7.5/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/ChangeLog11
-rw-r--r--media-plugins/mythvideo/files/mtd.init.d3
-rw-r--r--media-plugins/mythvideo/files/mythvideo.daily7
-rw-r--r--media-plugins/mythvideo/files/mythvideo.hourly7
-rw-r--r--media-plugins/mythvideo/files/mythvideo.weekly6
-rw-r--r--media-plugins/mythvideo/metadata.xml4
-rw-r--r--media-plugins/mythvideo/mythvideo-0.22_p22864.ebuild49
7 files changed, 86 insertions, 1 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index 8815d8173d35..7aa051eff449 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-plugins/mythvideo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.81 2009/11/18 00:22:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.82 2009/11/21 05:28:37 cardoe Exp $
+
+*mythvideo-0.22_p22864 (21 Nov 2009)
+
+ 21 Nov 2009; Doug Goldstein <cardoe@gentoo.org>
+ +mythvideo-0.22_p22864.ebuild, files/mtd.init.d, +files/mythvideo.daily,
+ +files/mythvideo.hourly, +files/mythvideo.weekly, metadata.xml:
+ update upstream JAMU version. Improve JAMU support by installing depends
+ (which are now in the tree) and optionally installing default cronjobs to
+ do the right things with JAMU
18 Nov 2009; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
replace media-tv herd for MythTV
diff --git a/media-plugins/mythvideo/files/mtd.init.d b/media-plugins/mythvideo/files/mtd.init.d
index ada7cadb94ef..65a4d9c4eeb5 100644
--- a/media-plugins/mythvideo/files/mtd.init.d
+++ b/media-plugins/mythvideo/files/mtd.init.d
@@ -9,6 +9,9 @@ depend() {
start() {
+ # necessary so it can read the correct mysql.txt
+ export HOME=/etc/mythtv/
+
ebegin "Starting MythTV Transcoding Daemon"
start-stop-daemon --start --quiet \
--exec /usr/bin/mtd \
diff --git a/media-plugins/mythvideo/files/mythvideo.daily b/media-plugins/mythvideo/files/mythvideo.daily
new file mode 100644
index 000000000000..865cc7228769
--- /dev/null
+++ b/media-plugins/mythvideo/files/mythvideo.daily
@@ -0,0 +1,7 @@
+#!/bin/sh
+#Daily maintenance mode for Jamu
+DIRECTORY=$(grep ^mythtv /etc/passwd | awk -F : '{print $6}')
+if [ -f "$DIRECTORY/.mythtv/config.xml" ]; then
+ su mythtv -c "/usr/bin/python /usr/share/mythtv/mythvideo/scripts/jamu.py -M >> '/var/log/mythtv/jamu.log'"
+fi
+
diff --git a/media-plugins/mythvideo/files/mythvideo.hourly b/media-plugins/mythvideo/files/mythvideo.hourly
new file mode 100644
index 000000000000..ecb035d6b7a8
--- /dev/null
+++ b/media-plugins/mythvideo/files/mythvideo.hourly
@@ -0,0 +1,7 @@
+#!/bin/sh
+#Hourly massive update to ensure users see graphics coming in for upcoming recordings and current recordings
+DIRECTORY=$(grep ^mythtv /etc/passwd | awk -F : '{print $6}')
+if [ -f "$DIRECTORY/.mythtv/config.xml" ]; then
+ su mythtv -c "/usr/bin/python /usr/share/mythtv/mythvideo/scripts/jamu.py -MW >> '/var/log/mythtv/jamu.log'"
+fi
+
diff --git a/media-plugins/mythvideo/files/mythvideo.weekly b/media-plugins/mythvideo/files/mythvideo.weekly
new file mode 100644
index 000000000000..9a27d1bbd9b0
--- /dev/null
+++ b/media-plugins/mythvideo/files/mythvideo.weekly
@@ -0,0 +1,6 @@
+#!/bin/sh
+#Janitor mode to clean up stale stuff
+DIRECTORY=$(grep ^mythtv /etc/passwd | awk -F : '{print $6}')
+if [ -f "$DIRECTORY/.mythtv/config.xml" ]; then
+ su mythtv -c "/usr/bin/python /usr/share/mythtv/mythvideo/scripts/jamu.py -MJ >> '/var/log/mythtv/jamu.log'"
+fi
diff --git a/media-plugins/mythvideo/metadata.xml b/media-plugins/mythvideo/metadata.xml
index 43b06e4af630..4d8b60dc2b76 100644
--- a/media-plugins/mythvideo/metadata.xml
+++ b/media-plugins/mythvideo/metadata.xml
@@ -6,4 +6,8 @@
<email>cardoe@gentoo.org</email>
<description>Do not CC me on bugs</description>
</maintainer>
+<use>
+ <flag name='jamu'>Use and configure the Just Another Metadata Utility by
+ default</flag>
+</use>
</pkgmetadata>
diff --git a/media-plugins/mythvideo/mythvideo-0.22_p22864.ebuild b/media-plugins/mythvideo/mythvideo-0.22_p22864.ebuild
new file mode 100644
index 000000000000..ad7c9855714f
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.22_p22864.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.22_p22864.ebuild,v 1.1 2009/11/21 05:28:37 cardoe Exp $
+
+EAPI=2
+
+inherit qt4 mythtv-plugins
+
+DESCRIPTION="Video player module for MythTV."
+IUSE="+jamu"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/URI
+ dev-perl/XML-Simple
+ sys-apps/eject
+ dev-python/imdbpy"
+DEPEND=""
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init.d mtd
+
+ # correct permissions so MythVideo is actually usable
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.pl
+ fperms 755 /usr/share/mythtv/mythvideo/scripts/*.py
+
+ # setup JAMU cron jobs
+ if use jamu; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/mythvideo.daily" mythvideo
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}/mythvideo.hourly" mythvideo
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/mythvideo.weekly" mythvideo
+ fi
+}
+
+pkg_postinst() {
+ elog "MythVideo can use any media player to playback files if you"
+ elog "are *NOT* using Storage Groups. If you are using Storage"
+ elog "Groups, you *MUST* use the Internal player."
+ elog
+ elog "Otherwise, you can install mplayer, xine or any other video"
+ elog "player and use that instead by configuring the player to use."
+ elog "The default is 'Internal'."
+}