summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:51 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:51 +0000
commitb68987e9d0009c54474b882634e408881adae6a3 (patch)
tree285e8b16e509f6466697c03f98741d3f3d03013c /media-plugins/mythnews
parentversion bumps (diff)
downloadgentoo-2-b68987e9d0009c54474b882634e408881adae6a3.tar.gz
gentoo-2-b68987e9d0009c54474b882634e408881adae6a3.tar.bz2
gentoo-2-b68987e9d0009c54474b882634e408881adae6a3.zip
version bumps
Diffstat (limited to 'media-plugins/mythnews')
-rw-r--r--media-plugins/mythnews/ChangeLog7
-rw-r--r--media-plugins/mythnews/Manifest4
-rw-r--r--media-plugins/mythnews/files/digest-mythnews-0.131
-rw-r--r--media-plugins/mythnews/mythnews-0.13.ebuild39
4 files changed, 48 insertions, 3 deletions
diff --git a/media-plugins/mythnews/ChangeLog b/media-plugins/mythnews/ChangeLog
index 1079f68b54de..1ad7ef4c2ba2 100644
--- a/media-plugins/mythnews/ChangeLog
+++ b/media-plugins/mythnews/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythnews
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/ChangeLog,v 1.2 2003/10/28 16:35:34 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/ChangeLog,v 1.3 2003/12/11 21:55:46 aliz Exp $
+
+*mythnews-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythnews-0.13.ebuild:
+ Version bump.
28 Oct 2003; Max Kalika <max@gentoo.org> mythnews-0.12.ebuild:
Extend CPU detection.
diff --git a/media-plugins/mythnews/Manifest b/media-plugins/mythnews/Manifest
index 7a485f06b3c5..7244941d82df 100644
--- a/media-plugins/mythnews/Manifest
+++ b/media-plugins/mythnews/Manifest
@@ -1,6 +1,6 @@
-MD5 4b3a6e51e22a4694afce8a3094f4ad4d mythnews-0.13.ebuild 990
+MD5 3474e731ebbd54db323bd0ca0db98a49 mythnews-0.13.ebuild 992
MD5 4b3a6e51e22a4694afce8a3094f4ad4d mythnews-0.12.ebuild 990
-MD5 6dedd0011fc733757f1d29c5b1725379 ChangeLog 441
+MD5 8a8991d5a70d1220a4a188f61929663d ChangeLog 559
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 4173f85528c0fed69c65345d080ddc6b files/digest-mythnews-0.12 65
MD5 ba1aaa752cf2b8e1d989d5db1cb23b5d files/digest-mythnews-0.13 65
diff --git a/media-plugins/mythnews/files/digest-mythnews-0.13 b/media-plugins/mythnews/files/digest-mythnews-0.13
new file mode 100644
index 000000000000..7ee463813b8a
--- /dev/null
+++ b/media-plugins/mythnews/files/digest-mythnews-0.13
@@ -0,0 +1 @@
+MD5 e041cc050391b1be7d20448c86592d42 mythnews-0.13.tar.bz2 40454
diff --git a/media-plugins/mythnews/mythnews-0.13.ebuild b/media-plugins/mythnews/mythnews-0.13.ebuild
new file mode 100644
index 000000000000..1a77b9461eff
--- /dev/null
+++ b/media-plugins/mythnews/mythnews-0.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythnews/mythnews-0.13.ebuild,v 1.1 2003/12/11 21:55:46 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="RSS feed news reading module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README ChangeLog
+}