summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:51 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:51 +0000
commitb68987e9d0009c54474b882634e408881adae6a3 (patch)
tree285e8b16e509f6466697c03f98741d3f3d03013c /media-plugins/mythgame
parentversion bumps (diff)
downloadgentoo-2-b68987e9d0009c54474b882634e408881adae6a3.tar.gz
gentoo-2-b68987e9d0009c54474b882634e408881adae6a3.tar.bz2
gentoo-2-b68987e9d0009c54474b882634e408881adae6a3.zip
version bumps
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/Manifest4
-rw-r--r--media-plugins/mythgame/files/digest-mythgame-0.131
-rw-r--r--media-plugins/mythgame/mythgame-0.13.ebuild66
4 files changed, 75 insertions, 3 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 9cdf480fba14..942202737f56 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.8 2003/12/08 17:16:27 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.9 2003/12/11 21:55:46 aliz Exp $
+
+*mythgame-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythgame-0.13.ebuild:
+ Version bump.
08 Dec 2003; <max@gentoo.org> mythgame-0.10.ebuild:
Remove stale version.
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 92b5e79a781d..5c6e0546ccf6 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,7 +1,7 @@
MD5 e7b5eb2fce13a0317d734ffd6515a289 mythgame-0.12.ebuild 1979
MD5 3c46ea652d6e76a76eb15e34026c4777 mythgame-0.11.ebuild 1976
-MD5 2fd79b3947f14457fa99b84b5b80ee7c mythgame-0.13.ebuild 1980
-MD5 12c4b9497f4af92d5aaf427c224a43c3 ChangeLog 1863
+MD5 f749fb3dcc144909342fdcd44a667681 mythgame-0.13.ebuild 1981
+MD5 9ad229ec4c9fe99e7d9a6abf4d657a6f ChangeLog 1981
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
MD5 ace6a7f7f30d271f0c3e7bb1ea4ea89b files/digest-mythgame-0.12 65
diff --git a/media-plugins/mythgame/files/digest-mythgame-0.13 b/media-plugins/mythgame/files/digest-mythgame-0.13
new file mode 100644
index 000000000000..d488afcd7046
--- /dev/null
+++ b/media-plugins/mythgame/files/digest-mythgame-0.13
@@ -0,0 +1 @@
+MD5 2ee55ba79bfd5fb93328a537621b03e9 mythgame-0.13.tar.bz2 64292
diff --git a/media-plugins/mythgame/mythgame-0.13.ebuild b/media-plugins/mythgame/mythgame-0.13.ebuild
new file mode 100644
index 000000000000..e1356793378e
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.13.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.13.ebuild,v 1.1 2003/12/11 21:55:46 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}