summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-02-06 14:38:57 +0000
committerMax Kalika <max@gentoo.org>2004-02-06 14:38:57 +0000
commit5533302f63aa22a20b016c103c4cd9d4472bbef5 (patch)
tree6ae9d8387d9fa8a6e9f2b34ab18ff0517e08e2f5 /media-plugins/mythgame
parentDitch the postinst() message and don't attempt to install non-existant db fil... (diff)
downloadgentoo-2-5533302f63aa22a20b016c103c4cd9d4472bbef5.tar.gz
gentoo-2-5533302f63aa22a20b016c103c4cd9d4472bbef5.tar.bz2
gentoo-2-5533302f63aa22a20b016c103c4cd9d4472bbef5.zip
Ditch the postinst() message and don't attempt to install non-existant db files.
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog6
-rw-r--r--media-plugins/mythgame/mythgame-0.14.ebuild34
2 files changed, 9 insertions, 31 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 72afa35cd8e6..284119159025 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.12 2004/02/03 14:14:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.13 2004/02/06 14:38:57 max Exp $
+
+ 06 Feb 2004; Max Kalika <max@gentoo.org> mythgame-0.14.ebuild:
+ Ditch the postinst() message and don't attempt to install non-existant db
+ files.
*mythgame-0.14 (03 Feb 2004)
diff --git a/media-plugins/mythgame/mythgame-0.14.ebuild b/media-plugins/mythgame/mythgame-0.14.ebuild
index 3df83bb5a391..d01164dbe2ad 100644
--- a/media-plugins/mythgame/mythgame-0.14.ebuild
+++ b/media-plugins/mythgame/mythgame-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.14.ebuild,v 1.2 2004/02/06 14:38:57 max Exp $
inherit flag-o-matic
@@ -12,12 +12,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-DEPEND="sys-libs/zlib
- >=sys-apps/sed-4
+DEPEND=">=sys-apps/sed-4
+ sys-libs/zlib
|| ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
src_unpack() {
- unpack ${A}
+ unpack ${A} && cd "${S}"
for i in `grep -lr "usr/local" "${S}"` ; do
sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
@@ -36,31 +36,5 @@ src_compile() {
src_install () {
einstall INSTALL_ROOT="${D}"
-
- insinto "/usr/share/mythtv/database/${PN}"
- doins gamedb/*.sql
-
dodoc README UPGRADING gamelist.xml
}
-
-pkg_postinst() {
- einfo "If this is the first time you install MythGame,"
- einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
- einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
- einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
- einfo "to your MythTV database in that order."
- einfo
- einfo "You might run in this order:"
- einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
- einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
- einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
- einfo
- einfo "If you're upgrading from an older version and for more"
- einfo "setup and usage instructions, please refer to:"
- einfo " /usr/share/doc/${PF}/README.gz"
- einfo " /usr/share/doc/${PF}/UPGRADING.gz"
- ewarn "This part is important as there might be database changes"
- ewarn "which need to be performed or this package will not work"
- ewarn "properly."
- echo
-}