summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-29 07:03:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-29 07:03:26 +0000
commit66b8df3026dc2bf162634fbbd1a3f98ffb7f809a (patch)
treebfb99ed911a6de257c5748c4ed9a938bf4d55ea7 /media-plugins/live/files
parentgfceu became gfceux (diff)
downloadgentoo-2-66b8df3026dc2bf162634fbbd1a3f98ffb7f809a.tar.gz
gentoo-2-66b8df3026dc2bf162634fbbd1a3f98ffb7f809a.tar.bz2
gentoo-2-66b8df3026dc2bf162634fbbd1a3f98ffb7f809a.zip
version bump and link the libs with g++
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/live/files')
-rw-r--r--media-plugins/live/files/config.gentoo-so-r117
-rw-r--r--media-plugins/live/files/live-recursive.patch13
2 files changed, 30 insertions, 0 deletions
diff --git a/media-plugins/live/files/config.gentoo-so-r1 b/media-plugins/live/files/config.gentoo-so-r1
new file mode 100644
index 000000000000..76a603557344
--- /dev/null
+++ b/media-plugins/live/files/config.gentoo-so-r1
@@ -0,0 +1,17 @@
+COMPILE_OPTS = $(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
+C = c
+C_COMPILER = $(CC)
+C_FLAGS = $(COMPILE_OPTS) -fPIC $(CFLAGS)
+CPP = cpp
+CPLUSPLUS_COMPILER = $(CXX)
+CPLUSPLUS_FLAGS = $(COMPILE_OPTS) -fPIC $(CXXFLAGS)
+OBJ = o
+LINK = $(CXX) -o
+LINK_OPTS = -L.
+CONSOLE_LINK_OPTS = $(LINK_OPTS)
+LIBRARY_LINK = $(CXX) -o
+LIBRARY_LINK_OPTS = $(LINK_OPTS) -shared -Wl,-soname,$@
+LIB_SUFFIX = so
+LIBS_FOR_CONSOLE_APPLICATION =
+LIBS_FOR_GUI_APPLICATION =
+EXE =
diff --git a/media-plugins/live/files/live-recursive.patch b/media-plugins/live/files/live-recursive.patch
new file mode 100644
index 000000000000..63b210706634
--- /dev/null
+++ b/media-plugins/live/files/live-recursive.patch
@@ -0,0 +1,13 @@
+Index: live/Makefile.tail
+===================================================================
+--- live.orig/Makefile.tail
++++ live/Makefile.tail
+@@ -14,8 +14,6 @@ all:
+ cd $(GROUPSOCK_DIR) ; $(MAKE)
+ cd $(USAGE_ENVIRONMENT_DIR) ; $(MAKE)
+ cd $(BASIC_USAGE_ENVIRONMENT_DIR) ; $(MAKE)
+- cd $(TESTPROGS_DIR) ; $(MAKE)
+- cd $(MEDIA_SERVER_DIR) ; $(MAKE)
+
+ clean:
+ cd $(LIVEMEDIA_DIR) ; $(MAKE) clean