summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2012-10-19 13:25:45 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2012-10-19 13:25:45 +0000
commit1808af79a31e343fc3f73ea5061d175d47f9d4c5 (patch)
treed927c3c2a06a2b7ae16ad685a9a895f93df9a0b1 /media-plugins/gst-plugins-xvideo
parentPrevent unnecessary linking with libICE, libSM. Fixes #368753. (diff)
downloadgentoo-2-1808af79a31e343fc3f73ea5061d175d47f9d4c5.tar.gz
gentoo-2-1808af79a31e343fc3f73ea5061d175d47f9d4c5.tar.bz2
gentoo-2-1808af79a31e343fc3f73ea5061d175d47f9d4c5.zip
Prevent unnecessary linking with libICE, libSM. Fixes #368753.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 29C3E2EC)
Diffstat (limited to 'media-plugins/gst-plugins-xvideo')
-rw-r--r--media-plugins/gst-plugins-xvideo/ChangeLog8
-rw-r--r--media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-xvideo/ChangeLog b/media-plugins/gst-plugins-xvideo/ChangeLog
index d6636989ea92..628b8630949e 100644
--- a/media-plugins/gst-plugins-xvideo/ChangeLog
+++ b/media-plugins/gst-plugins-xvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-xvideo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/ChangeLog,v 1.185 2012/05/17 15:26:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/ChangeLog,v 1.186 2012/10/19 13:25:45 ford_prefect Exp $
+
+*gst-plugins-xvideo-0.10.35-r1 (19 Oct 2012)
+
+ 19 Oct 2012; Arun Raghavan <ford_prefect@gentoo.org>
+ +gst-plugins-xvideo-0.10.35-r1.ebuild:
+ Prevent unnecessary linking with libICE, libSM. Fixes #368753.
17 May 2012; Alexis Ballier <aballier@gentoo.org>
gst-plugins-xvideo-0.10.35.ebuild:
diff --git a/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35-r1.ebuild b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35-r1.ebuild
new file mode 100644
index 000000000000..75f82506296e
--- /dev/null
+++ b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35-r1.ebuild,v 1.1 2012/10/19 13:25:45 ford_prefect Exp $
+
+EAPI=3
+
+inherit gst-plugins-base
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libXv
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/videoproto
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+# xshm is a compile time option of xvideo
+# x is needed to build any X plugins, but we build/install only xv anyway
+GST_PLUGINS_BUILD="x xvideo xshm"
+GST_PLUGINS_BUILD_DIR="xvimage"
+
+src_prepare() {
+ gst-plugins-base_src_prepare
+
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+}