summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-04-28 23:50:23 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-04-28 23:50:23 +0000
commit2ef9d2955dc367816a920ad8b0e2748de69f9452 (patch)
tree5ad053bec11a4121fbbb00eef79994c2092b1e7a /media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild
parentmark ~ppc (diff)
downloadgentoo-2-2ef9d2955dc367816a920ad8b0e2748de69f9452.tar.gz
gentoo-2-2ef9d2955dc367816a920ad8b0e2748de69f9452.tar.bz2
gentoo-2-2ef9d2955dc367816a920ad8b0e2748de69f9452.zip
due to earlier cock-up, bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild')
-rw-r--r--media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild b/media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..276f1f6830ed
--- /dev/null
+++ b/media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-pitfdll/gst-plugins-pitfdll-0.8.1-r1.ebuild,v 1.1 2005/04/28 23:50:23 zaheerm Exp $
+
+inherit eutils
+
+DESCRIPTION="GStreamer plugin for Win32 DLL loading"
+HOMEPAGE="http://ronald.bitfreak.net/pitfdll.php"
+
+MY_PN=${PN/gst-plugins-/}
+MY_P=${MY_PN}-${PV}
+
+SRC_URI="mirror://sourceforge/$MY_PN/$MY_P.tar.bz2"
+
+# Create a major/minor combo for SLOT - stolen from gst-plugins-ffmpeg
+PVP=(${PV//[-\._]/ })
+SLOT=${PVP[0]}.${PVP[1]}
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=media-libs/gstreamer-0.8.9
+ >=media-libs/gst-plugins-0.8.8-r1"
+RDEPEND="$DEPEND
+ media-libs/win32codecs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/ext/pitfdll
+ epatch ${FILESDIR}/${P}-mutex.patch
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+# ripped from gst-plugins.eclass
+update_registry() {
+ einfo "Updating gstreamer plugins registry for gstreamer ${SLOT}..."
+ gst-register-${SLOT}
+}
+
+pkg_postinst() {
+ update_registry
+}
+
+pkg_postrm() {
+ update_registry
+}