summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-07-31 22:58:51 +0000
committerOlivier Crête <tester@gentoo.org>2008-07-31 22:58:51 +0000
commitfcaf5af43c8eed1d30802e258b4d3b665e779b4f (patch)
tree1b995f7f069ead55d3d53804068b31359504f98f /media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild
parentdrop gtk+-1 to ~mips for repoman check. clean up old revisions (diff)
downloadgentoo-2-fcaf5af43c8eed1d30802e258b4d3b665e779b4f.tar.gz
gentoo-2-fcaf5af43c8eed1d30802e258b4d3b665e779b4f.tar.bz2
gentoo-2-fcaf5af43c8eed1d30802e258b4d3b665e779b4f.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild')
-rw-r--r--media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild b/media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild
new file mode 100644
index 000000000000..ed6b36354f89
--- /dev/null
+++ b/media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-farsight/gst-plugins-farsight-0.12.9.ebuild,v 1.1 2008/07/31 22:58:51 tester Exp $
+
+inherit gst-plugins10
+
+DESCRIPTION="GStreamer plugin for Farsight"
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+#EDARCS_REPO_URI="http://projects.collabora.co.uk/darcs/farsight/gst-plugins-farsight"
+
+GST_MAJOR=0.10
+SLOT=${GST_MAJOR}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg2k gsm jingle msn yahoo"
+
+DEPEND=">=media-libs/gstreamer-0.10.13
+ >=media-libs/gst-plugins-base-0.10.13
+ dev-libs/libxml2
+ jpeg2k? ( media-libs/jasper )
+ gsm? ( media-sound/gsm )
+ jingle? ( net-libs/libjingle )
+ msn? ( media-libs/libmimic )
+ yahoo? ( media-libs/libj2k )"
+
+src_compile() {
+ econf \
+ --enable-g729 \
+ --disable-jrtplib \
+ $(use_enable jpeg2k jasper) \
+ $(use_enable gsm) \
+ $(use_enable jingle jingle-p2p) \
+ $(use_enable msn mimic) \
+ $(use_with yahoo libj2k) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+
+ rm -f "${D}/usr/lib*/*gstreamer*/*jpeg2k*"
+}