summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-11-24 17:14:53 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-11-24 17:14:53 +0000
commitf19a9353cf79401a85414572c3595d92b8e59e03 (patch)
tree6d0b0a14f4d0ae48caa03c62f1d5b8b21e1f8135 /media-plugins/audacious-plugins
parentgtkhtml is NOT an optional dependency. (diff)
downloadgentoo-2-f19a9353cf79401a85414572c3595d92b8e59e03.tar.gz
gentoo-2-f19a9353cf79401a85414572c3595d92b8e59e03.tar.bz2
gentoo-2-f19a9353cf79401a85414572c3595d92b8e59e03.zip
Disable faulty rootvis plugin, closes bug #244398 by Kai <gentoo@altkai.ml1.net>. Enable/disable filewriter FLAC support in sync with FLAC-NG plugin, closes bug #245835 by Alexis Ballier <aballier@gentoo.org>.
(Portage version: 2.1.6_rc1/cvs/Linux 2.6.28-rc6-00007-ged31348-dirty x86_64)
Diffstat (limited to 'media-plugins/audacious-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog10
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild123
2 files changed, 132 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index 19b44fb384da..831fbb8bb3b4 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.96 2008/09/03 12:28:03 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.97 2008/11/24 17:14:53 chainsaw Exp $
+
+*audacious-plugins-1.5.1-r3 (24 Nov 2008)
+
+ 24 Nov 2008; <chainsaw@gentoo.org> +audacious-plugins-1.5.1-r3.ebuild:
+ Disable faulty rootvis plugin, closes bug #244398 by Kai
+ <gentoo@altkai.ml1.net>. Enable/disable filewriter FLAC support in sync
+ with FLAC-NG plugin, closes bug #245835 by Alexis Ballier
+ <aballier@gentoo.org>.
*audacious-plugins-1.5.1-r2 (03 Sep 2008)
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild
new file mode 100644
index 000000000000..daafdf7563b9
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild,v 1.1 2008/11/24 17:14:53 chainsaw Exp $
+
+inherit eutils flag-o-matic autotools
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac adplug alsa arts chardet esd flac gnome jack lirc modplug mp3 mtp musepack nls oss pulseaudio scrobbler sdl sid sndfile sse2 timidity tta vorbis wavpack wma"
+
+RDEPEND="app-arch/unzip
+ >=dev-libs/libcdio-0.79-r1
+ >=dev-libs/dbus-glib-0.60
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=media-libs/libcddb-1.2.1
+ >=media-sound/audacious-1.5.1-r1
+ >=net-misc/neon-0.26.4
+ >=x11-libs/gtk+-2.10
+ adplug? ( >=dev-cpp/libbinio-1.4 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.38-r1 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-libs/libmad )
+ mtp? ( media-libs/libmtp )
+ musepack? ( media-libs/libmpcdec media-libs/taglib )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ scrobbler? ( net-misc/curl
+ media-libs/musicbrainz )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ timidity? ( media-sound/timidity++ )
+ tta? ( media-libs/libid3tag )
+ vorbis? ( >=media-libs/libvorbis-1.2.0
+ >=media-libs/libogg-1.1.3 )
+ wavpack? ( >=media-sound/wavpack-4.41.0 )
+ wma? ( >=media-libs/libmms-0.3 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Bug 232418; patch by Ivan Iraci <ivanhoe@vfemail.net>
+ epatch "${FILESDIR}/${PV}-missing-include.patch"
+ # Bug 230995; patch by Linus Walleij
+ # http://bugzilla.atheme.org/show_bug.cgi?id=35
+ # Rebased from hg head to 1.5.1
+ epatch "${FILESDIR}/${PV}-libmtp-0.3.0-API.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ mp3_warning
+
+ econf \
+ --enable-cdaudio \
+ --enable-dbus \
+ --enable-neon \
+ --disable-projectm \
+ --disable-projectm-1.0 \
+ --disable-rootvis \
+ $(use_enable aac) \
+ $(use_enable adplug) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable chardet) \
+ $(use_enable esd) \
+ $(use_enable flac flacng) \
+ $(use_enable flac filewriter_flac) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lirc) \
+ $(use_enable mp3) \
+ $(use_enable modplug) \
+ $(use_enable musepack) \
+ $(use_enable mtp mtp_up) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable sdl paranormal) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable sse2) \
+ $(use_enable timidity) \
+ $(use_enable tta) \
+ $(use_enable vorbis) \
+ $(use_enable wavpack) \
+ $(use_enable wma) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ mp3_warning
+}