summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-25 02:26:18 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-25 02:26:18 +0000
commitf18fdd9eaf407aa04551abd1e5981c3b49ada646 (patch)
tree9510373f3f82188b1a629289f9c716db3115c977 /media-libs
parentUpdates to support BIP16 required by April 1, 2012 (diff)
downloadgentoo-2-f18fdd9eaf407aa04551abd1e5981c3b49ada646.tar.gz
gentoo-2-f18fdd9eaf407aa04551abd1e5981c3b49ada646.tar.bz2
gentoo-2-f18fdd9eaf407aa04551abd1e5981c3b49ada646.zip
Bump to 1.10.0, p.masked, do not use yet
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/ChangeLog7
-rw-r--r--media-libs/cogl/cogl-1.10.0.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
index 01de7c5cf788..93b0c3b2042f 100644
--- a/media-libs/cogl/ChangeLog
+++ b/media-libs/cogl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/cogl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.3 2012/02/19 10:10:03 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.4 2012/03/25 02:26:18 nirbheek Exp $
+
+*cogl-1.10.0 (25 Mar 2012)
+
+ 25 Mar 2012; Nirbheek Chauhan <nirbheek@gentoo.org> +cogl-1.10.0.ebuild:
+ Bump to 1.10.0, p.masked, do not use yet
19 Feb 2012; Tobias Klausmann <klausman@gentoo.org> cogl-1.8.2.ebuild:
Keyworded on alpha, bug #379649
diff --git a/media-libs/cogl/cogl-1.10.0.ebuild b/media-libs/cogl/cogl-1.10.0.ebuild
new file mode 100644
index 000000000000..1241df2847ef
--- /dev/null
+++ b/media-libs/cogl/cogl-1.10.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.10.0.ebuild,v 1.1 2012/03/25 02:26:18 nirbheek Exp $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit clutter gnome2 virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+IUSE="doc examples +introspection +pango"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )
+ test? ( media-libs/mesa[classic] )"
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+
+pkg_setup() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+ # XXX: think about kms-egl, gles, quartz, sdl, wayland
+ G2CONF="${G2CONF}
+ --disable-examples-install
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ --enable-gl
+ --enable-glib
+ --enable-glx
+ --enable-deprecated
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)"
+}
+
+src_test() {
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ LIBGL_DRIVERS_PATH=${EROOT}/usr/$(get_libdir)/mesa Xemake check
+}
+
+src_install() {
+ clutter_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}