summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-14 15:41:32 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-14 15:41:32 +0000
commitf0c83940fb74132013163f5a550602d725c34b7f (patch)
tree102ee25ecc1016759eeebbe0831901e6873a36dd /media-libs
parentVersion bump. (diff)
downloadgentoo-2-f0c83940fb74132013163f5a550602d725c34b7f.tar.gz
gentoo-2-f0c83940fb74132013163f5a550602d725c34b7f.tar.bz2
gentoo-2-f0c83940fb74132013163f5a550602d725c34b7f.zip
Fix documentation directory, bug 364857
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libwpg/ChangeLog9
-rw-r--r--media-libs/libwpg/libwpg-0.1.3-r2.ebuild53
-rw-r--r--media-libs/libwpg/libwpg-0.2.0-r1.ebuild54
3 files changed, 115 insertions, 1 deletions
diff --git a/media-libs/libwpg/ChangeLog b/media-libs/libwpg/ChangeLog
index aa7139ae40d1..44bdcbaf1a74 100644
--- a/media-libs/libwpg/ChangeLog
+++ b/media-libs/libwpg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libwpg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwpg/ChangeLog,v 1.18 2011/04/24 17:22:51 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwpg/ChangeLog,v 1.19 2011/05/14 15:41:32 dilfridge Exp $
+
+*libwpg-0.2.0-r1 (14 May 2011)
+*libwpg-0.1.3-r2 (14 May 2011)
+
+ 14 May 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libwpg-0.1.3-r2.ebuild, +libwpg-0.2.0-r1.ebuild:
+ Fix documentation directory, bug 364857
24 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> libwpg-0.1.3.ebuild:
Move the old ebuild revision to proper slot.
diff --git a/media-libs/libwpg/libwpg-0.1.3-r2.ebuild b/media-libs/libwpg/libwpg-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..393448482c12
--- /dev/null
+++ b/media-libs/libwpg/libwpg-0.1.3-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwpg/libwpg-0.1.3-r2.ebuild,v 1.1 2011/05/14 15:41:32 dilfridge Exp $
+
+EAPI="4"
+
+inherit alternatives
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc tools"
+
+RDEPEND="app-text/libwpd:0.8[tools?]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --program-suffix=-${SLOT} \
+ --disable-dependency-tracking \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with doc docs) \
+ $(use_with tools stream)
+}
+
+src_install() {
+ default
+ # Uses a binary that is conditionaly distributed
+ use tools || rm "${ED}"/usr/bin/wpg2svgbatch.pl-${SLOT}
+ find "${ED}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+ fi
+}
diff --git a/media-libs/libwpg/libwpg-0.2.0-r1.ebuild b/media-libs/libwpg/libwpg-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..f9a0f8fb5af3
--- /dev/null
+++ b/media-libs/libwpg/libwpg-0.2.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwpg/libwpg-0.2.0-r1.ebuild,v 1.1 2011/05/14 15:41:32 dilfridge Exp $
+
+EAPI="4"
+
+inherit alternatives autotools
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="app-text/libwpd:0.9[tools]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.1.3-r1"
+
+src_prepare() {
+ sed -i -e 's: -Werror::g' configure.in || die
+ # FIXME: Touching configure.in triggers maintainer-mode always
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --program-suffix=-${SLOT} \
+ --disable-dependency-tracking \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]" fi
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}