summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2007-01-29 01:31:40 +0000
committerChristian Birchinger <joker@gentoo.org>2007-01-29 01:31:40 +0000
commited457906e1e6ef7987e0c735ca9444a6f5f8be5a (patch)
tree41bd710472730fb4f5614d1a627db4b22d1a8e52 /media-libs
parentwhitespace (diff)
downloadgentoo-2-ed457906e1e6ef7987e0c735ca9444a6f5f8be5a.tar.gz
gentoo-2-ed457906e1e6ef7987e0c735ca9444a6f5f8be5a.tar.bz2
gentoo-2-ed457906e1e6ef7987e0c735ca9444a6f5f8be5a.zip
New version which fixes the old DUMB vulnerability
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/aldumb/ChangeLog10
-rw-r--r--media-libs/aldumb/aldumb-0.9.3.ebuild48
-rw-r--r--media-libs/aldumb/files/aldumb-0.9.3_CVE-2006-3668.patch16
-rw-r--r--media-libs/aldumb/files/digest-aldumb-0.9.33
4 files changed, 75 insertions, 2 deletions
diff --git a/media-libs/aldumb/ChangeLog b/media-libs/aldumb/ChangeLog
index 4141475a52b7..634fce492f4c 100644
--- a/media-libs/aldumb/ChangeLog
+++ b/media-libs/aldumb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/aldumb
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/aldumb/ChangeLog,v 1.16 2006/11/27 01:53:40 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aldumb/ChangeLog,v 1.17 2007/01/29 01:31:40 joker Exp $
+
+*aldumb-0.9.3 (29 Jan 2007)
+
+ 29 Jan 2007; Christian Birchinger <joker@gentoo.org>
+ +files/aldumb-0.9.3_CVE-2006-3668.patch, +aldumb-0.9.3.ebuild:
+ New version which fixes the old DUMB vulnerability.
27 Nov 2006; <blubb@gentoo.org> aldumb-0.9.2-r1.ebuild:
stable on amd64
diff --git a/media-libs/aldumb/aldumb-0.9.3.ebuild b/media-libs/aldumb/aldumb-0.9.3.ebuild
new file mode 100644
index 000000000000..520ede03c563
--- /dev/null
+++ b/media-libs/aldumb/aldumb-0.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aldumb/aldumb-0.9.3.ebuild,v 1.1 2007/01/29 01:31:40 joker Exp $
+
+inherit eutils
+
+IUSE="debug"
+
+DESCRIPTION="Allegro support for DUMB (an IT, XM, S3M, and MOD player library)"
+HOMEPAGE="http://dumb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dumb/dumb-${PV}.tar.gz"
+
+LICENSE="DUMB-0.9.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+
+DEPEND=">=media-libs/dumb-0.9.3
+ media-libs/allegro"
+
+S="${WORKDIR}/${P/aldumb/dumb}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cat << EOF > make/config.txt
+include make/unix.inc
+ALL_TARGETS := allegro allegro-examples allegro-headers
+PREFIX := /usr
+EOF
+ epatch "${FILESDIR}/${PN}-0.9.2-PIC.patch"
+ epatch "${FILESDIR}/${P}_CVE-2006-3668.patch"
+ sed -i '/= -s/d' Makefile || die "sed failed"
+ cp Makefile Makefile.rdy
+}
+
+src_compile() {
+ emake OFLAGS="${CFLAGS}" all || die "emake failed"
+}
+
+src_install() {
+ dobin examples/dumbplay
+ dolib.so lib/unix/libaldmb.so
+
+ use debug && lib/unix/libaldmd.so
+
+ insinto /usr/include
+ doins include/aldumb.h
+}
diff --git a/media-libs/aldumb/files/aldumb-0.9.3_CVE-2006-3668.patch b/media-libs/aldumb/files/aldumb-0.9.3_CVE-2006-3668.patch
new file mode 100644
index 000000000000..09d2fb68f4cb
--- /dev/null
+++ b/media-libs/aldumb/files/aldumb-0.9.3_CVE-2006-3668.patch
@@ -0,0 +1,16 @@
+Index: libdumb-0.9.3/src/it/itread.c
+===================================================================
+--- libdumb-0.9.3.orig/src/it/itread.c 2006-07-21 11:05:48.000000000 +0200
++++ libdumb-0.9.3/src/it/itread.c 2006-07-21 11:07:22.000000000 +0200
+@@ -292,6 +292,11 @@
+
+ envelope->flags = dumbfile_getc(f);
+ envelope->n_nodes = dumbfile_getc(f);
++ if(envelope->n_nodes > 25) {
++ TRACE("IT error: wrong number of envelope nodes (%d)\n", envelope->n_nodes);
++ envelope->n_nodes = 0;
++ return -1;
++ }
+ envelope->loop_start = dumbfile_getc(f);
+ envelope->loop_end = dumbfile_getc(f);
+ envelope->sus_loop_start = dumbfile_getc(f);
diff --git a/media-libs/aldumb/files/digest-aldumb-0.9.3 b/media-libs/aldumb/files/digest-aldumb-0.9.3
new file mode 100644
index 000000000000..803226265cb8
--- /dev/null
+++ b/media-libs/aldumb/files/digest-aldumb-0.9.3
@@ -0,0 +1,3 @@
+MD5 f48da5b990aa8aa822d3b6a951baf5c2 dumb-0.9.3.tar.gz 167379
+RMD160 53c7931fec71dd4e67e19c4acf38c0f9202e5698 dumb-0.9.3.tar.gz 167379
+SHA256 8d44fbc9e57f3bac9f761c3b12ce102d47d717f0dd846657fb988e0bb5d1ea33 dumb-0.9.3.tar.gz 167379