summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-25 13:42:25 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-25 13:42:25 +0000
commite9dd73e5a7d74e1c178825166a5a61a454a343e9 (patch)
tree870599a02089822dd803169b77020b5a78a809f1 /media-libs
parentcleanup (diff)
downloadgentoo-2-e9dd73e5a7d74e1c178825166a5a61a454a343e9.tar.gz
gentoo-2-e9dd73e5a7d74e1c178825166a5a61a454a343e9.tar.bz2
gentoo-2-e9dd73e5a7d74e1c178825166a5a61a454a343e9.zip
version bump
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/allegro/ChangeLog18
-rw-r--r--media-libs/allegro/allegro-4.0.3.ebuild126
-rw-r--r--media-libs/allegro/files/digest-allegro-4.0.31
3 files changed, 134 insertions, 11 deletions
diff --git a/media-libs/allegro/ChangeLog b/media-libs/allegro/ChangeLog
index bff21f73ab42..c292c26e6ddf 100644
--- a/media-libs/allegro/ChangeLog
+++ b/media-libs/allegro/ChangeLog
@@ -1,26 +1,25 @@
# ChangeLog for media-libs/allegro
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.9 2003/02/12 07:05:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.10 2003/04/25 13:42:25 vapier Exp $
+
+*allegro-4.0.3 (25 Apr 2003)
+
+ 25 Apr 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*allegro-4.0.2 (06 Jul 2002)
11 Jan 2003; Seemant Kulleen <seemant@gentoo.org> allegro-4.0.3.ebuild :
-
filtered out the -fPIC flag.
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
06 Jul 2002; Seemant Kulleen <seemant@gentoo.org> allegro-4.0.2.ebuild
files/digest-allegro-4.0.2 :
-
Version bump.
*allegro-4.0.1 (30 Apr 2002)
13 May 2002; Matthew Kennedy <mkennedy@gentoo.org>
- allegro-4.0.1-r2.ebuild
- files/digest-allegro-4.0.1-r2, ChangeLog :
-
+ allegro-4.0.1-r2.ebuild, files/digest-allegro-4.0.1-r2, ChangeLog :
Fixed dependencies. Fixed tetex sandbox violations. Fixed build
flags.
@@ -28,7 +27,6 @@
30 Apr 2002; Seemant Kulleen <seemant@gentoo.org> allegro-4.0.1-r1.ebuild
files/digest-allegro-4.0.1-r1 :
-
Added tetex USE flag dependent dvi documentation compilation. This fixes
bug # 2266 by rparker@ntlworld.com (Robin Parker)
@@ -36,13 +34,11 @@
14 Apr 2002; Seemant Kulleen <seemant@gentoo.org> allegro-4.0.1.ebuild
files/digest-allegro-4.0.1 :
-
Version bump, and changed the fbcon USE flag to just fb
*allegro-3.9.37 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/media-libs/allegro/allegro-4.0.3.ebuild b/media-libs/allegro/allegro-4.0.3.ebuild
new file mode 100644
index 000000000000..82104be6dd6e
--- /dev/null
+++ b/media-libs/allegro/allegro-4.0.3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.1 2003/04/25 13:42:25 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="cross-platform multimedia library"
+SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
+HOMEPAGE="http://alleg.sourceforge.net/"
+
+LICENSE="Allegro"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="mmx esd static tetex X fbcon oss svga alsa"
+
+RDEPEND="X? ( virtual/x11 )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ svga? ( media-libs/svgalib )"
+DEPEND="${RDEPEND}
+ tetex? ( app-text/tetex )"
+
+src_compile() {
+ # Always enable Linux console support and accompanying drivers
+ confopts="${confopts} --enable-linux --enable-vga"
+
+ # if USE static defined, use static library as default to link with
+ use static \
+ && confopts="${confopts} --enable-staticprog --enable-static"
+
+ # Pentium optimizations
+ if [ ${CHOST} = "i586-pc-linux-gnu" -o ${CHOST} = "i686-pc-linux-gnu" ]
+ then
+ confopts="${confopts} --enable-pentiumopts"
+ fi
+
+ # Use MMX instructions
+ use mmx \
+ && confopts="${confopts} --enable-mmx" \
+ || confopts="${confopts} --enable-mmx=no"
+
+ # Have OSS support
+ use oss \
+ && confopts="${confopts} --enable-ossdigi --enable-ossmidi" \
+ || confopts="${confopts} --disable-ossdigi --disable-ossmidi"
+
+ # Have ALSA support
+ use alsa \
+ && confopts="${confopts} --enable-alsadigi --enable-alsamidi" \
+ || confopts="${confopts} --disable-alsadigi --disable-alsamidi"
+
+ # Have ESD support
+ use esd \
+ && confopts="${confopts} --enable-esddigi" \
+ || confopts="${confopts} --disable-esddigi"
+
+ # Have X11 support
+ use X \
+ && confopts="${confopts} \
+ --with-x \
+ --enable-xwin-shm \
+ --enable-xwin-vidmode \
+ --enable-xwin-dga \
+ --enable-xwin-dga2" \
+ || confopts="${confopts} \
+ --without-x \
+ --disable-xwin-shm \
+ --disable-xwin-vidmode \
+ --disable-xwin-dga \
+ --disable-xwin-dga2"
+
+ # Have SVGALib support
+ use svga \
+ && confopts="${confopts} --enable-svgalib" \
+ || confopts="${confopts} --disable-svgalib"
+
+ # Have fbcon support
+ use fbcon \
+ && confopts="${confopts} --enable-fbcon" \
+ || confopts="${confopts} --disable-fbcon"
+
+ # --------------
+
+ econf ${confopts} || die
+
+ # emake doesn't work
+ filter-flags -fPIC
+ make CFLAGS="${CFLAGS/-fPIC/}" || die
+
+ if use tetex;
+ then
+ addwrite "/var/lib/texmf"
+ addwrite "/usr/share/texmf"
+ addwrite "/var/cache/fonts"
+ make docs-dvi docs-ps || die
+ fi
+
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install install-gzipped-man install-gzipped-info || die
+
+ # Different format versions of the Allegro documentation
+
+ dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
+
+ if use tetex;
+ then
+ dodoc docs/allegro.dvi docs/allegro.ps
+ fi
+
+ dohtml docs/html/*
+
+ docinto txt
+ dodoc docs/txt/*.txt
+
+ docinto rtf
+ dodoc docs/rtf/*.rtf
+
+ docinto build
+ dodoc docs/build/*.txt
+}
diff --git a/media-libs/allegro/files/digest-allegro-4.0.3 b/media-libs/allegro/files/digest-allegro-4.0.3
new file mode 100644
index 000000000000..9837759186ee
--- /dev/null
+++ b/media-libs/allegro/files/digest-allegro-4.0.3
@@ -0,0 +1 @@
+MD5 4fd1d27c323ba33b6d6cad6c5a1d8a44 allegro-4.0.3.tar.gz 2440083