summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-02 17:39:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-02 17:39:22 +0000
commitd78e75c35735aa5423eed509b08b2fd26834caab (patch)
tree23b64ce2ecaa6cee1832ea44c8380ba9d13eaa07 /media-libs
parentOK, fix for real this time... (diff)
downloadgentoo-2-d78e75c35735aa5423eed509b08b2fd26834caab.tar.gz
gentoo-2-d78e75c35735aa5423eed509b08b2fd26834caab.tar.bz2
gentoo-2-d78e75c35735aa5423eed509b08b2fd26834caab.zip
remove text relocations in shared library, big thanks to the pax team, bug #135326
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xvid/ChangeLog8
-rw-r--r--media-libs/xvid/files/digest-xvid-1.1.3-r19
-rw-r--r--media-libs/xvid/xvid-1.1.3-r1.ebuild73
3 files changed, 89 insertions, 1 deletions
diff --git a/media-libs/xvid/ChangeLog b/media-libs/xvid/ChangeLog
index a481b01bd017..2d5f82ce4256 100644
--- a/media-libs/xvid/ChangeLog
+++ b/media-libs/xvid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/xvid
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.95 2007/11/27 18:53:20 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.96 2007/12/02 17:39:22 aballier Exp $
+
+*xvid-1.1.3-r1 (02 Dec 2007)
+
+ 02 Dec 2007; Alexis Ballier <aballier@gentoo.org> +xvid-1.1.3-r1.ebuild:
+ remove text relocations in shared library, big thanks to the pax team, bug
+ #135326
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org> xvid-1.0.2.ebuild,
xvid-1.1.0-r1.ebuild, xvid-1.1.0-r3.ebuild:
diff --git a/media-libs/xvid/files/digest-xvid-1.1.3-r1 b/media-libs/xvid/files/digest-xvid-1.1.3-r1
new file mode 100644
index 000000000000..ede909f05770
--- /dev/null
+++ b/media-libs/xvid/files/digest-xvid-1.1.3-r1
@@ -0,0 +1,9 @@
+MD5 919ac7d4f8be05626e4d98abde100ab3 xvid-1.1.2-noexec-stack.patch.bz2 2426
+RMD160 083da9ab8e4fdcd067cd2970eeb7ad634894219f xvid-1.1.2-noexec-stack.patch.bz2 2426
+SHA256 6de38a05303e02a2524e3f0093a3e0b021bba93d0889c2b97a05a29ba21efffa xvid-1.1.2-noexec-stack.patch.bz2 2426
+MD5 03088a8568f91caf570149243b61d48c xvid-1.1.3-textrel.patch.bz2 24760
+RMD160 7a511ce369eade1de7e6d3d3a775cfa37e0e426a xvid-1.1.3-textrel.patch.bz2 24760
+SHA256 46419954aef27ec8a4ab8342eecb99b9816a9a6e233e1b5a8b0268523ec3a819 xvid-1.1.3-textrel.patch.bz2 24760
+MD5 29c60d4d991ac18f687a8fd13cfe64b7 xvidcore-1.1.3.tar.bz2 625974
+RMD160 f890a2ef58be5362aa1d2894e748ef11a0c7bba8 xvidcore-1.1.3.tar.bz2 625974
+SHA256 f5d7f658840ef6fda5b2cd8b105d3738e1a3e735ee12ddc0136527f0185c14ed xvidcore-1.1.3.tar.bz2 625974
diff --git a/media-libs/xvid/xvid-1.1.3-r1.ebuild b/media-libs/xvid/xvid-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..6e3b8185126a
--- /dev/null
+++ b/media-libs/xvid/xvid-1.1.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.1.3-r1.ebuild,v 1.1 2007/12/02 17:39:22 aballier Exp $
+
+inherit eutils fixheadtails autotools
+
+MY_P=${PN}core-${PV}
+
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="http://www.xvid.org"
+SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}-1.1.2-noexec-stack.patch.bz2
+ mirror://gentoo/${P}-textrel.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples altivec"
+
+# once yasm-0.6.0+ comes out, we can switch this to
+# dev-lang/nasm >=dev-lang/yasm-0.6.0
+# and then drop the quotes from section in the noexec-stack.patch
+
+# yasm < 0.6.2 has a bug when computing pic adresses.
+# See http://www.tortall.net/projects/yasm/ticket/114
+# the build system prefers yasm if it finds it
+# thus if we intend to have || (yasm nasm) for building
+# we need to make it block yasm < 0.6.2 on x86
+# otherwise it will compile wrong code
+NASM=">=dev-lang/yasm-0.6.2"
+DEPEND="x86? ( ${NASM} )
+ amd64? ( ${NASM} )"
+RDEPEND=""
+
+S="${WORKDIR}"/${MY_P}/build/generic
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"/${MY_P}
+ epatch "${FILESDIR}"/${PN}-1.1.0_beta2-altivec.patch
+ epatch "${WORKDIR}"/${PN}-1.1.2-noexec-stack.patch
+ epatch "${FILESDIR}"/${PN}-1.1.0-3dnow-2.patch
+ epatch "${FILESDIR}"/${P}-ia64-build.patch
+ epatch "${WORKDIR}/${P}-textrel.patch"
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable altivec)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ dodoc "${S}"/../../{AUTHORS,ChangeLog*,README,TODO}
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.*.dylib))
+ dosym ${mylib} /usr/$(get_libdir)/libxvidcore.dylib
+ else
+ local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.so*))
+ dosym ${mylib} /usr/$(get_libdir)/libxvidcore.so
+ dosym ${mylib} /usr/$(get_libdir)/${mylib/.1}
+ fi
+
+ if use examples; then
+ dodoc "${S}"/../../CodingStyle
+ insinto /usr/share/${PN}
+ doins -r "${S}"/../../examples
+ fi
+}