summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-11 13:54:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-11 13:54:06 +0000
commitd762900c3de5adbdfa427f33e2ff9dc8dc5e00a0 (patch)
tree3282c45f576737b48ea773d6c21c29e0218f403e /media-libs
parentsci-biology/last: Drop old (diff)
downloadgentoo-2-d762900c3de5adbdfa427f33e2ff9dc8dc5e00a0.tar.gz
gentoo-2-d762900c3de5adbdfa427f33e2ff9dc8dc5e00a0.tar.bz2
gentoo-2-d762900c3de5adbdfa427f33e2ff9dc8dc5e00a0.zip
Convert to multilib. Do not build executables for the static libs build, drop the static-libs useflag propagation since the libs do not need it and we do not build the executables anymore.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openjpeg/ChangeLog9
-rw-r--r--media-libs/openjpeg/openjpeg-1.5.1-r1.ebuild73
2 files changed, 81 insertions, 1 deletions
diff --git a/media-libs/openjpeg/ChangeLog b/media-libs/openjpeg/ChangeLog
index 4b6b59dbca8e..9168cd4b9e10 100644
--- a/media-libs/openjpeg/ChangeLog
+++ b/media-libs/openjpeg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/openjpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/ChangeLog,v 1.85 2013/08/06 13:12:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/ChangeLog,v 1.86 2013/08/11 13:54:06 aballier Exp $
+
+*openjpeg-1.5.1-r1 (11 Aug 2013)
+
+ 11 Aug 2013; Alexis Ballier <aballier@gentoo.org> +openjpeg-1.5.1-r1.ebuild:
+ Convert to multilib. Do not build executables for the static libs build, drop
+ the static-libs useflag propagation since the libs do not need it and we do
+ not build the executables anymore.
06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> openjpeg-1.5.1.ebuild:
Stable for s390, wrt bug #472536
diff --git a/media-libs/openjpeg/openjpeg-1.5.1-r1.ebuild b/media-libs/openjpeg/openjpeg-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..903e6c615225
--- /dev/null
+++ b/media-libs/openjpeg/openjpeg-1.5.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/openjpeg-1.5.1-r1.ebuild,v 1.1 2013/08/11 13:54:06 aballier Exp $
+
+EAPI=5
+inherit multilib cmake-utils multilib-minimal
+
+DESCRIPTION="An open-source JPEG 2000 library"
+HOMEPAGE="http://code.google.com/p/openjpeg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lcms:2=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS CHANGES NEWS README THANKS )
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+RESTRICT="test" #409263
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ )
+
+ if multilib_is_native_abi ; then
+ mycmakeargs+=( $(cmake-utils_use_build doc) )
+ else
+ mycmakeargs+=( -DBUILD_CODEC=OFF )
+ fi
+
+ cmake-utils_src_configure
+
+ if use static-libs ; then
+ mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_CODEC=OFF
+ )
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if use static-libs ; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_compile
+ fi
+}
+
+multilib_src_install() {
+ if use static-libs ; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_install
+ #static bins overwritten by shared install
+ fi
+
+ cmake-utils_src_install
+
+ dosym openjpeg-1.5/openjpeg.h /usr/include/openjpeg.h
+ dosym libopenjpeg1.pc /usr/$(get_libdir)/pkgconfig/libopenjpeg.pc
+}