summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-01 02:56:26 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-01 02:56:26 +0000
commitcc84ce96e04054d30400b9e433705c17094e7b13 (patch)
tree42d578d6f5fd1e6275eb1ed891a4e3f2d2f2c62a /media-libs
parentAdded flac USE flag support. (Manifest recommit) (diff)
downloadgentoo-2-cc84ce96e04054d30400b9e433705c17094e7b13.tar.gz
gentoo-2-cc84ce96e04054d30400b9e433705c17094e7b13.tar.bz2
gentoo-2-cc84ce96e04054d30400b9e433705c17094e7b13.zip
bleh, removed wrong ebuild, fix KEYWORDS
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/imlib2/files/digest-imlib2-1.1.21
-rw-r--r--media-libs/imlib2/imlib2-1.1.2.20040912.ebuild3
-rw-r--r--media-libs/imlib2/imlib2-1.1.2.ebuild42
3 files changed, 44 insertions, 2 deletions
diff --git a/media-libs/imlib2/files/digest-imlib2-1.1.2 b/media-libs/imlib2/files/digest-imlib2-1.1.2
new file mode 100644
index 000000000000..eaa399e24c82
--- /dev/null
+++ b/media-libs/imlib2/files/digest-imlib2-1.1.2
@@ -0,0 +1 @@
+MD5 3389bad516032c951fda4fe620df0cef imlib2-1.1.2.tar.gz 875843
diff --git a/media-libs/imlib2/imlib2-1.1.2.20040912.ebuild b/media-libs/imlib2/imlib2-1.1.2.20040912.ebuild
index 147c34c56922..4becf8d32b36 100644
--- a/media-libs/imlib2/imlib2-1.1.2.20040912.ebuild
+++ b/media-libs/imlib2/imlib2-1.1.2.20040912.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.1.2.20040912.ebuild,v 1.1 2004/09/14 22:59:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.1.2.20040912.ebuild,v 1.2 2004/10/01 02:56:25 vapier Exp $
EHACKAUTOGEN=yes
inherit enlightenment
@@ -9,7 +9,6 @@ MY_P=${P/_/-}
DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
-KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64 ppc64"
IUSE="X gif jpeg mmx png tiff"
DEPEND="=media-libs/freetype-2*
diff --git a/media-libs/imlib2/imlib2-1.1.2.ebuild b/media-libs/imlib2/imlib2-1.1.2.ebuild
new file mode 100644
index 000000000000..b58f923441b1
--- /dev/null
+++ b/media-libs/imlib2/imlib2-1.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.1.2.ebuild,v 1.3 2004/10/01 02:56:25 vapier Exp $
+
+EHACKAUTOGEN=yes
+inherit enlightenment
+
+MY_P=${P/_/-}
+DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
+HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
+
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="X gif jpeg mmx png tiff"
+
+DEPEND="=media-libs/freetype-2*
+ gif? ( media-libs/libungif
+ >=media-libs/giflib-4.1.0 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ X? ( virtual/x11 )"
+
+src_compile() {
+ local mymmx=""
+ if [ "${ARCH}" == "amd64" ] ; then
+ mymmx="--disable-mmx"
+ else
+ mymmx="`use_enable mmx`"
+ fi
+
+ export MY_ECONF="
+ ${mymmx} \
+ `use_with X x` \
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+ docinto samples
+ dodoc demo/*.c
+}