summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-28 03:03:00 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-28 03:03:00 +0000
commitb7d276d793a317ddb25910204ed53c18abc81923 (patch)
tree76a8fbb574cd2b800e6d21ff0d1edad9d939d959 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-b7d276d793a317ddb25910204ed53c18abc81923.tar.gz
gentoo-2-b7d276d793a317ddb25910204ed53c18abc81923.tar.bz2
gentoo-2-b7d276d793a317ddb25910204ed53c18abc81923.zip
Fix autotools-utils usage (bug #392155).
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libzen/ChangeLog5
-rw-r--r--media-libs/libzen/libzen-0.4.23.ebuild30
2 files changed, 19 insertions, 16 deletions
diff --git a/media-libs/libzen/ChangeLog b/media-libs/libzen/ChangeLog
index 33abfa1da3d0..edaa5281c42b 100644
--- a/media-libs/libzen/ChangeLog
+++ b/media-libs/libzen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libzen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libzen/ChangeLog,v 1.25 2011/11/27 04:07:20 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libzen/ChangeLog,v 1.26 2011/11/28 03:03:00 radhermit Exp $
+
+ 28 Nov 2011; Tim Harder <radhermit@gentoo.org> libzen-0.4.23.ebuild:
+ Fix autotools-utils usage (bug #392155).
27 Nov 2011; Tim Harder <radhermit@gentoo.org> libzen-0.4.23.ebuild:
Build in the source tree.
diff --git a/media-libs/libzen/libzen-0.4.23.ebuild b/media-libs/libzen/libzen-0.4.23.ebuild
index d0f10a2000eb..b0286190fbfa 100644
--- a/media-libs/libzen/libzen-0.4.23.ebuild
+++ b/media-libs/libzen/libzen-0.4.23.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libzen/libzen-0.4.23.ebuild,v 1.2 2011/11/27 04:07:20 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libzen/libzen-0.4.23.ebuild,v 1.3 2011/11/28 03:03:00 radhermit Exp $
EAPI="4"
-inherit autotools-utils multilib eutils
+inherit autotools-utils multilib
MY_PN="ZenLib"
DESCRIPTION="Shared library for libmediainfo and mediainfo"
@@ -22,35 +22,37 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_PN}/Project/GNU/Library"
-AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.21-no-tinyxml.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.4.21-no-tinyxml.patch
+ autotools-utils_src_prepare
sed -i -e "s:-O2::" configure.ac
eautoreconf
}
src_configure() {
- econf \
- --enable-unicode \
- --enable-shared \
- $(use_enable static-libs static)
+ myeconfargs=(
+ --enable-unicode
+ )
+ autotools-utils_src_configure
}
src_compile() {
- default
+ autotools-utils_src_compile
- if use doc; then
+ if use doc ; then
cd "${WORKDIR}"/${MY_PN}/Source/Doc
doxygen Doxyfile || die
fi
}
src_install() {
- default
+ autotools-utils_src_install
insinto /usr/$(get_libdir)/pkgconfig
- doins "${S}"/${PN}.pc
+ doins "${AUTOTOOLS_BUILD_DIR}"/${PN}.pc
for x in ./ Base64 Format/Html Format/Http HTTP_Client ; do
insinto /usr/include/${MY_PN}/${x}
@@ -58,9 +60,7 @@ src_install() {
done
dodoc "${WORKDIR}"/${MY_PN}/History.txt
- if use doc; then
+ if use doc ; then
dohtml "${WORKDIR}"/${MY_PN}/Doc/*
fi
-
- remove_libtool_files all
}