summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-27 12:08:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-27 12:08:45 +0000
commitb17cfdea22960cf4da2ca233978df4453130b4b5 (patch)
treee4d771df44bd91a69c714519710a373d73f4fef8 /media-libs
parentRespect LDFLAGS, bug #334711, patch by Gavin Pryke (diff)
downloadgentoo-2-b17cfdea22960cf4da2ca233978df4453130b4b5.tar.gz
gentoo-2-b17cfdea22960cf4da2ca233978df4453130b4b5.tar.bz2
gentoo-2-b17cfdea22960cf4da2ca233978df4453130b4b5.zip
Fix strict aliasing warnings, bug #307563
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ladspa-cmt/ChangeLog8
-rw-r--r--media-libs/ladspa-cmt/files/ladspa-cmt-1.16-sa.patch18
-rw-r--r--media-libs/ladspa-cmt/ladspa-cmt-1.16-r2.ebuild57
3 files changed, 82 insertions, 1 deletions
diff --git a/media-libs/ladspa-cmt/ChangeLog b/media-libs/ladspa-cmt/ChangeLog
index a2872849dfaf..e345209ffd0f 100644
--- a/media-libs/ladspa-cmt/ChangeLog
+++ b/media-libs/ladspa-cmt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/ladspa-cmt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ChangeLog,v 1.44 2012/11/27 11:58:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ChangeLog,v 1.45 2012/11/27 12:08:45 aballier Exp $
+
+*ladspa-cmt-1.16-r2 (27 Nov 2012)
+
+ 27 Nov 2012; Alexis Ballier <aballier@gentoo.org> +ladspa-cmt-1.16-r2.ebuild,
+ +files/ladspa-cmt-1.16-sa.patch:
+ Fix strict aliasing warnings, bug #307563
*ladspa-cmt-1.16-r1 (27 Nov 2012)
diff --git a/media-libs/ladspa-cmt/files/ladspa-cmt-1.16-sa.patch b/media-libs/ladspa-cmt/files/ladspa-cmt-1.16-sa.patch
new file mode 100644
index 000000000000..161c06d27eed
--- /dev/null
+++ b/media-libs/ladspa-cmt/files/ladspa-cmt-1.16-sa.patch
@@ -0,0 +1,18 @@
+Fix strict aliasing warnings: reeverb/Components/allpass.h:36:2: warning:
+dereferencing type-punned pointer will break strict-aliasing rules
+
+https://bugs.gentoo.org/show_bug.cgi?id=307563
+
+Index: cmt/src/freeverb/Components/denormals.h
+===================================================================
+--- cmt.orig/src/freeverb/Components/denormals.h
++++ cmt/src/freeverb/Components/denormals.h
+@@ -8,7 +8,7 @@
+ #ifndef _denormals_
+ #define _denormals_
+
+-#define undenormalise(sample) if(((*(unsigned int*)&sample)&0x7f800000)==0) sample=0.0f
++#define undenormalise(sample) if((((unsigned int)sample)&0x7f800000)==0) sample=0.0f
+
+ #endif//_denormals_
+
diff --git a/media-libs/ladspa-cmt/ladspa-cmt-1.16-r2.ebuild b/media-libs/ladspa-cmt/ladspa-cmt-1.16-r2.ebuild
new file mode 100644
index 000000000000..cb888fe24563
--- /dev/null
+++ b/media-libs/ladspa-cmt/ladspa-cmt-1.16-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.16-r2.ebuild,v 1.1 2012/11/27 12:08:45 aballier Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+IUSE=""
+
+S="${WORKDIR}/cmt/src"
+MY_P="cmt_src_${PV}"
+
+DESCRIPTION="CMT (computer music toolkit) Lasdpa library plugins"
+HOMEPAGE="http://www.ladspa.org/"
+SRC_URI="http://www.ladspa.org/download/${MY_P}.tgz"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND="media-libs/ladspa-sdk
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/ s/-O3/${CFLAGS}/" \
+ -e 's|/usr/local/include||g' \
+ -e 's|/usr/local/lib||g' makefile \
+ || die "sed makefile failed"
+ sed -i -e "s/^CXXFLAGS*/CXXFLAGS = ${CXXFLAGS} \$(INCLUDES) -Wall -fPIC\n#/" \
+ "${S}/makefile" || die "sed makefile failed (CXXFLAGS)"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-mallocstdlib.patch"
+ epatch "${FILESDIR}/${P}-respect-ldflags.patch"
+ epatch "${FILESDIR}/${P}-sa.patch"
+ use userland_Darwin && epatch "${FILESDIR}/${P}-darwin.patch"
+}
+
+src_compile() {
+ tc-export CXX
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/share/ladspa/rdf/
+ doins "${FILESDIR}/cmt.rdf"
+
+ insopts -m755
+ insinto /usr/$(get_libdir)/ladspa
+ doins ../plugins/*.so
+
+ dodoc ../README
+ dohtml ../doc/*
+}