summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-04-04 23:20:46 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-04-04 23:20:46 +0000
commita58650d53cf8494409f328bbdf7f61b8c859b3ce (patch)
treef4fd3998572c919af8c7772dd4e838f2f0dad0df /media-libs
parentMarked ~hppa (bug #358079). (diff)
downloadgentoo-2-a58650d53cf8494409f328bbdf7f61b8c859b3ce.tar.gz
gentoo-2-a58650d53cf8494409f328bbdf7f61b8c859b3ce.tar.bz2
gentoo-2-a58650d53cf8494409f328bbdf7f61b8c859b3ce.zip
Bump to 0.6.20, bugfixes. All tests pass.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libexif/ChangeLog8
-rw-r--r--media-libs/libexif/libexif-0.6.20.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/libexif/ChangeLog b/media-libs/libexif/ChangeLog
index 9754ba94c1ae..1d8cc826173b 100644
--- a/media-libs/libexif/ChangeLog
+++ b/media-libs/libexif/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libexif
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.115 2011/02/17 16:58:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.116 2011/04/04 23:20:46 nirbheek Exp $
+
+*libexif-0.6.20 (04 Apr 2011)
+
+ 04 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +libexif-0.6.20.ebuild:
+ Bump to 0.6.20, bugfixes. All tests pass.
17 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> libexif-0.6.19.ebuild:
USE="static-libs" and punt useless libtool archive.
diff --git a/media-libs/libexif/libexif-0.6.20.ebuild b/media-libs/libexif/libexif-0.6.20.ebuild
new file mode 100644
index 000000000000..9c845fe91e42
--- /dev/null
+++ b/media-libs/libexif/libexif-0.6.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.20.ebuild,v 1.1 2011/04/04 23:20:46 nirbheek Exp $
+
+EAPI=2
+inherit eutils libtool
+
+DESCRIPTION="Library for parsing, editing, and saving EXIF data"
+HOMEPAGE="http://libexif.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc nls static-libs"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6.13-pkgconfig.patch
+ elibtoolize # FreeBSD .so version
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable nls) \
+ $(use_enable doc docs) \
+ --with-doc-dir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -exec rm -f {} +
+ rm -f "${D}"usr/share/doc/${PF}/{ABOUT-NLS,COPYING}
+ prepalldocs
+}