summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2010-04-17 18:41:53 +0000
committerMarkus Meier <maekke@gentoo.org>2010-04-17 18:41:53 +0000
commita5135e2b5ca3e490fd7bfa4654dbfc32eae5d1c2 (patch)
treefc7223e6f835cb2c4d8409f5c254cf747f253284 /media-libs
parentTweak the ebuild per suggestions by Monty Taylor of upstream, during the Driz... (diff)
downloadgentoo-2-a5135e2b5ca3e490fd7bfa4654dbfc32eae5d1c2.tar.gz
gentoo-2-a5135e2b5ca3e490fd7bfa4654dbfc32eae5d1c2.tar.bz2
gentoo-2-a5135e2b5ca3e490fd7bfa4654dbfc32eae5d1c2.zip
disable vectorization support for now, by Serge Gavrilov in bug #314643
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lensfun/ChangeLog7
-rw-r--r--media-libs/lensfun/lensfun-0.2.5-r1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index 52c6bb39d74c..469ea6f050d3 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.17 2010/04/02 14:24:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.18 2010/04/17 18:41:53 maekke Exp $
+
+*lensfun-0.2.5-r1 (17 Apr 2010)
+
+ 17 Apr 2010; Markus Meier <maekke@gentoo.org> +lensfun-0.2.5-r1.ebuild:
+ disable vectorization support for now, by Serge Gavrilov in bug #314643
*lensfun-0.2.5 (02 Apr 2010)
diff --git a/media-libs/lensfun/lensfun-0.2.5-r1.ebuild b/media-libs/lensfun/lensfun-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..896802ac32e5
--- /dev/null
+++ b/media-libs/lensfun/lensfun-0.2.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.5-r1.ebuild,v 1.1 2010/04/17 18:41:53 maekke Exp $
+
+EAPI=2
+
+DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens
+distortions"
+HOMEPAGE="http://lensfun.berlios.de/"
+SRC_URI="mirror://berlios/lensfun/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/glib-2.0
+ >=media-libs/libpng-1.0"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.5.0 )"
+
+src_prepare() {
+ # disable stripping, remove ricer CFLAGS
+ sed -i \
+ -e 's:-s -O3 -fomit-frame-pointer -funroll-loops::g' \
+ -e 's:GCC.LDFLAGS.release = -s:GCC.LDFLAGS.release =:g' \
+ build/tibs/compiler/gcc.mak || die
+}
+
+src_configure() {
+ local myconf=""
+ use debug && myconf="--mode=debug"
+ # econf does NOT work
+ ./configure --prefix=/usr --vectorization= ${myconf} || die
+}
+
+src_compile() {
+ emake all V=1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ # TODO remove docs if ! use doc
+}