summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-05-05 13:52:36 +0000
committerOlivier Crête <tester@gentoo.org>2008-05-05 13:52:36 +0000
commita2f076e9eca4c53160731ca7d6c6cd5e4d28cefc (patch)
treeabdc5689c19947aa0cc8c752d163d7b274db1bc5 /media-libs
parentsparc stable wrt #219814 (diff)
downloadgentoo-2-a2f076e9eca4c53160731ca7d6c6cd5e4d28cefc.tar.gz
gentoo-2-a2f076e9eca4c53160731ca7d6c6cd5e4d28cefc.tar.bz2
gentoo-2-a2f076e9eca4c53160731ca7d6c6cd5e4d28cefc.zip
Really add patch for bug #210564
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libid3tag/ChangeLog6
-rw-r--r--media-libs/libid3tag/files/0.15.1b/libid3tag-0.15.1b-fix_overflow.patch11
2 files changed, 16 insertions, 1 deletions
diff --git a/media-libs/libid3tag/ChangeLog b/media-libs/libid3tag/ChangeLog
index 2012288e5d34..651c2dab9b9d 100644
--- a/media-libs/libid3tag/ChangeLog
+++ b/media-libs/libid3tag/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libid3tag
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libid3tag/ChangeLog,v 1.33 2008/05/05 09:43:16 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libid3tag/ChangeLog,v 1.34 2008/05/05 13:52:35 tester Exp $
+
+ 05 May 2008; Olivier Crête <tester@gentoo.org>
+ +files/0.15.1b/libid3tag-0.15.1b-fix_overflow.patch:
+ Really add patch for bug #210564
05 May 2008; Robert Buchholz <rbu@gentoo.org> libid3tag-0.15.1b-r1.ebuild:
Fix quoting so patches are found and applied, thanks to Natanael Copa (bug
diff --git a/media-libs/libid3tag/files/0.15.1b/libid3tag-0.15.1b-fix_overflow.patch b/media-libs/libid3tag/files/0.15.1b/libid3tag-0.15.1b-fix_overflow.patch
new file mode 100644
index 000000000000..26c54c5d2cfe
--- /dev/null
+++ b/media-libs/libid3tag/files/0.15.1b/libid3tag-0.15.1b-fix_overflow.patch
@@ -0,0 +1,11 @@
+--- field.c.orig 2008-05-05 09:49:15.000000000 -0400
++++ field.c 2008-05-05 09:49:25.000000000 -0400
+@@ -291,7 +291,7 @@
+
+ end = *ptr + length;
+
+- while (end - *ptr > 0) {
++ while (end - *ptr > 0 && **ptr != '\0') {
+ ucs4 = id3_parse_string(ptr, end - *ptr, *encoding, 0);
+ if (ucs4 == 0)
+ goto fail;