summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-10 08:09:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-10 08:09:14 +0000
commit9ae729a82f4cd7a2464f3156008f11dd161ef8a5 (patch)
treeb6dec739a1cb578bdb4584ecaec3aa5abb44544a /media-libs
parentQuoting (diff)
downloadgentoo-2-9ae729a82f4cd7a2464f3156008f11dd161ef8a5.tar.gz
gentoo-2-9ae729a82f4cd7a2464f3156008f11dd161ef8a5.tar.bz2
gentoo-2-9ae729a82f4cd7a2464f3156008f11dd161ef8a5.zip
Version bump wrt #468414 by Manuel Rüger
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sbc/ChangeLog9
-rw-r--r--media-libs/sbc/sbc-1.1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/media-libs/sbc/ChangeLog b/media-libs/sbc/ChangeLog
index 2981432e19ec..79e44128c7ec 100644
--- a/media-libs/sbc/ChangeLog
+++ b/media-libs/sbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sbc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sbc/ChangeLog,v 1.6 2012/12/02 10:42:37 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sbc/ChangeLog,v 1.7 2013/05/10 08:09:14 ssuominen Exp $
+
+*sbc-1.1 (10 May 2013)
+
+ 10 May 2013; Samuli Suominen <ssuominen@gentoo.org> +sbc-1.1.ebuild:
+ Version bump wrt #468414 by Manuel Rüger
02 Dec 2012; Markus Meier <maekke@gentoo.org> sbc-1.0.ebuild:
add ~arm, bug #442932
diff --git a/media-libs/sbc/sbc-1.1.ebuild b/media-libs/sbc/sbc-1.1.ebuild
new file mode 100644
index 000000000000..10cd960c6e4d
--- /dev/null
+++ b/media-libs/sbc/sbc-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sbc/sbc-1.1.ebuild,v 1.1 2013/05/10 08:09:14 ssuominen Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="An audio codec to connect bluetooth high quality audio devices like headphones or loudspeakers"
+HOMEPAGE="http://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+DEPEND="virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}