summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-05 22:04:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-05 22:04:53 +0000
commit9a147ae3cf6ad479204c4c9fd522af4e3b64740f (patch)
treebdb1f4b8ff97b77d1b01e9af0a4cac263890e7ac /media-libs
parentAdd a bug number, I didn't know there was a bug.. (diff)
downloadgentoo-2-9a147ae3cf6ad479204c4c9fd522af4e3b64740f.tar.gz
gentoo-2-9a147ae3cf6ad479204c4c9fd522af4e3b64740f.tar.bz2
gentoo-2-9a147ae3cf6ad479204c4c9fd522af4e3b64740f.zip
Fix compile with GCC 4.4
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/rubberband/ChangeLog6
-rw-r--r--media-libs/rubberband/files/rubberband-1.3-gcc44.patch11
-rw-r--r--media-libs/rubberband/rubberband-1.3.ebuild9
3 files changed, 23 insertions, 3 deletions
diff --git a/media-libs/rubberband/ChangeLog b/media-libs/rubberband/ChangeLog
index df35745bc331..277c660d8518 100644
--- a/media-libs/rubberband/ChangeLog
+++ b/media-libs/rubberband/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/rubberband
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.7 2009/03/16 21:01:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.8 2009/06/05 22:04:53 ssuominen Exp $
+
+ 05 Jun 2009; Samuli Suominen <ssuominen@gentoo.org> rubberband-1.3.ebuild,
+ +files/rubberband-1.3-gcc44.patch:
+ Fix compile with GCC 4.4
*rubberband-1.3 (16 Mar 2009)
diff --git a/media-libs/rubberband/files/rubberband-1.3-gcc44.patch b/media-libs/rubberband/files/rubberband-1.3-gcc44.patch
new file mode 100644
index 000000000000..7a6106eace24
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.3-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur rubberband-1.3.orig/src/vamp/RubberBandVampPlugin.cpp rubberband-1.3/src/vamp/RubberBandVampPlugin.cpp
+--- rubberband-1.3.orig/src/vamp/RubberBandVampPlugin.cpp 2009-03-01 23:55:47.000000000 +0200
++++ rubberband-1.3/src/vamp/RubberBandVampPlugin.cpp 2009-06-06 01:05:25.000000000 +0300
+@@ -17,6 +17,7 @@
+ #include "StretchCalculator.h"
+ #include "sysutils.h"
+
++#include <cstdio>
+ #include <cmath>
+
+ using std::string;
diff --git a/media-libs/rubberband/rubberband-1.3.ebuild b/media-libs/rubberband/rubberband-1.3.ebuild
index 22f9bc61c33f..9f0f227e7a98 100644
--- a/media-libs/rubberband/rubberband-1.3.ebuild
+++ b/media-libs/rubberband/rubberband-1.3.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.3.ebuild,v 1.1 2009/03/16 21:01:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.3.ebuild,v 1.2 2009/06/05 22:04:53 ssuominen Exp $
+EAPI=2
inherit eutils multilib
DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
@@ -21,6 +22,10 @@ RDEPEND="media-libs/vamp-plugin-sdk
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_install() {
emake INSTALL_BINDIR="${D}/usr/bin" \
INSTALL_INCDIR="${D}/usr/include/rubberband" \
@@ -29,6 +34,6 @@ src_install() {
INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
- install || die "make install failed"
+ install || die "emake install failed"
dodoc README
}