summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-12-11 02:40:33 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-12-11 02:40:33 +0000
commit7f872a61099cc85a419580875026a4b120b8ab50 (patch)
tree82dbe0225449e42d085fc6a9545f7c3e7c3c53ca /media-libs
parentVersion bump. (diff)
downloadgentoo-2-7f872a61099cc85a419580875026a4b120b8ab50.tar.gz
gentoo-2-7f872a61099cc85a419580875026a4b120b8ab50.tar.bz2
gentoo-2-7f872a61099cc85a419580875026a4b120b8ab50.zip
Version bump, ebuild by Thomas Beierlein
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/hamlib/ChangeLog7
-rw-r--r--media-libs/hamlib/hamlib-1.2.10.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index e11e24d7677c..2c189657340a 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/hamlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.39 2009/08/29 18:14:26 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.40 2009/12/11 02:40:33 darkside Exp $
+
+*hamlib-1.2.10 (11 Dec 2009)
+
+ 11 Dec 2009; Jeremy Olexa <darkside@gentoo.org> +hamlib-1.2.10.ebuild:
+ Version bump, ebuild by Thomas Beierlein
29 Aug 2009; nixnut <nixnut@gentoo.org> hamlib-1.2.9.ebuild:
ppc stable #276423
diff --git a/media-libs/hamlib/hamlib-1.2.10.ebuild b/media-libs/hamlib/hamlib-1.2.10.ebuild
new file mode 100644
index 000000000000..afb9a519dea0
--- /dev/null
+++ b/media-libs/hamlib/hamlib-1.2.10.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.10.ebuild,v 1.1 2009/12/11 02:40:33 darkside Exp $
+
+inherit autotools eutils multilib python
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ python? ( dev-lang/python
+ dev-lang/tcl )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND=" ${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+ sed -i -e "s#/lib/#/$(get_libdir)/#g" \
+ bindings/Makefile.am || die "sed failed"
+
+ if use python ; then
+ # fix python lib path
+ python_version
+ sed -i -e "s#/python#/python${PYVER}#" \
+ bindings/Makefile.am || die "sed failed"
+ fi
+
+ # avoid compilation and use of bundled libltdl copy
+ sed -i -e "s/lib libltdl src/lib src/g" \
+ Makefile.am || die "sed failed"
+ eautoreconf
+ rm -rf libltdl
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-rpc-backends \
+ --without-perl-binding \
+ $(use_with python python-binding) \
+ $(use_enable tcl tcl-binding)
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd doc && make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS PLAN README README.betatester \
+ README.developer NEWS TODO || die "dodoc failed"
+
+ if use doc; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc || die "doins failed"
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib || die "doenvd failed"
+}