summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-30 08:47:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-30 08:47:56 +0000
commit72d6abe22cbf3990664dad2c4dee658267e519a5 (patch)
treec0ad46046a007c7c829cd9bed78383b0bd121345 /media-libs
parentFix building with GCC 4.3 and various other build issues with patch from (diff)
downloadgentoo-2-72d6abe22cbf3990664dad2c4dee658267e519a5.tar.gz
gentoo-2-72d6abe22cbf3990664dad2c4dee658267e519a5.tar.bz2
gentoo-2-72d6abe22cbf3990664dad2c4dee658267e519a5.zip
Fix building with GCC 4.4 wrt #275903.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openexr_ctl/ChangeLog8
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch11
-rw-r--r--media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild20
3 files changed, 27 insertions, 12 deletions
diff --git a/media-libs/openexr_ctl/ChangeLog b/media-libs/openexr_ctl/ChangeLog
index 801ce09db3df..d0f1895a103b 100644
--- a/media-libs/openexr_ctl/ChangeLog
+++ b/media-libs/openexr_ctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/openexr_ctl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/ChangeLog,v 1.17 2008/12/17 07:50:00 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/ChangeLog,v 1.18 2009/07/30 08:47:35 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ openexr_ctl-1.0.1-r1.ebuild, +files/openexr_ctl-1.0.1-gcc44.patch:
+ Fix building with GCC 4.4 wrt #275903.
17 Dec 2008; <ssuominen@gentoo.org> openexr_ctl-1.0.1-r1.ebuild:
x86 stable wrt #207663, Comment #14.
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch
new file mode 100644
index 000000000000..08530bdeaad3
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur openexr_ctl-1.0.1.orig/exr_ctl_exr/applyCtl.cpp openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp
+--- openexr_ctl-1.0.1.orig/exr_ctl_exr/applyCtl.cpp 2007-07-13 06:24:37.000000000 +0300
++++ openexr_ctl-1.0.1/exr_ctl_exr/applyCtl.cpp 2009-07-30 11:46:29.000000000 +0300
+@@ -60,6 +60,7 @@
+ #include <ImfStandardAttributes.h>
+ #include <ImfHeader.h>
+ #include <ImfFrameBuffer.h>
++#include <cstdio>
+ #include <cassert>
+ #include <iostream>
+ #include <vector>
diff --git a/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild
index 687145020dae..f24ab610a171 100644
--- a/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild
+++ b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild,v 1.3 2008/12/17 07:50:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild,v 1.4 2009/07/30 08:47:35 ssuominen Exp $
-inherit eutils autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="OpenEXR CTL libraries"
HOMEPAGE="http://sourceforge.net/projects/ampasctl"
@@ -19,16 +20,15 @@ RDEPEND="media-libs/ilmbase
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-configure_gcc43.patch
- epatch "${FILESDIR}"/${P}-pkgconfig.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-configure_gcc43.patch \
+ "${FILESDIR}"/${P}-pkgconfig.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README
}