summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-10-09 16:02:50 +0000
committerAchim Gottinger <achim@gentoo.org>2000-10-09 16:02:50 +0000
commit729fce81676bb44c7cadac460cb0d4292c060f6b (patch)
tree7ddce26a73dcce633c11585211d8e3f8891bf40a /media-libs
parent*** empty log message *** (diff)
downloadgentoo-2-729fce81676bb44c7cadac460cb0d4292c060f6b.tar.gz
gentoo-2-729fce81676bb44c7cadac460cb0d4292c060f6b.tar.bz2
gentoo-2-729fce81676bb44c7cadac460cb0d4292c060f6b.zip
*** empty log message ***
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glut/files/digest-glut-3.71
-rw-r--r--media-libs/glut/glut-3.7.ebuild49
-rw-r--r--media-libs/libsdl/libsdl-1.1.5.ebuild4
-rw-r--r--media-libs/mesa/files/digest-mesa-glu-3.2.11
-rw-r--r--media-libs/mesa/mesa-glu-3.2.1.ebuild37
5 files changed, 90 insertions, 2 deletions
diff --git a/media-libs/glut/files/digest-glut-3.7 b/media-libs/glut/files/digest-glut-3.7
new file mode 100644
index 000000000000..43dc115eafc1
--- /dev/null
+++ b/media-libs/glut/files/digest-glut-3.7
@@ -0,0 +1 @@
+MD5 dc932666e2a1c8a0b148a4c32d111ef3 glut-3.7.tar.gz
diff --git a/media-libs/glut/glut-3.7.ebuild b/media-libs/glut/glut-3.7.ebuild
new file mode 100644
index 000000000000..0465600ab60a
--- /dev/null
+++ b/media-libs/glut/glut-3.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glut/glut-3.7.ebuild,v 1.1 2000/10/09 16:02:49 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GLUT API for Linux"
+SRC_URI="http://reality.sgi.com/opengl/glut3/${A}"
+HOMEPAGE="http://reality.sgi.com/opengl/glut3/glut3.html"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ mkdir lib
+ cd lib
+ ln -s /usr/X11R6/lib/libGL.so.1 libMesaGL.so
+ ln -s /usr/X11R6/lib/libGLU.so.1 libMesaGLU.so
+}
+
+src_compile() {
+
+ cd ${S}
+ cp linux/Glut.cf .
+ cp mkmkfiles.imake mkmkfiles.imake.orig
+ sed -e "s:/bin/csh:/bin/tcsh:" mkmkfiles.imake.orig > mkmkfiles.imake
+ unset LS_COLORS
+ try ./mkmkfiles.imake
+ cp linux/Makefile lib/glut
+ cd ${S}/lib/glut
+ try make
+ ln -s libglut.so.3.7 libglut.so.3
+ ln -s libglut.so.3.7 libglut.so
+ cd ${S}
+ try make
+}
+
+src_install () {
+
+ cd ${S}
+ insinto /usr/X11R6/include/GL
+ doins include/GL/*.h
+ into /usr/X11R6
+ dolib lib/glut/libglut.so.3.7
+ preplib /usr/X11R6
+ prepallstrip
+}
+
+
diff --git a/media-libs/libsdl/libsdl-1.1.5.ebuild b/media-libs/libsdl/libsdl-1.1.5.ebuild
index 174112f186f3..a298436f64e4 100644
--- a/media-libs/libsdl/libsdl-1.1.5.ebuild
+++ b/media-libs/libsdl/libsdl-1.1.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.1.5.ebuild,v 1.1 2000/10/04 15:28:46 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.1.5.ebuild,v 1.2 2000/10/09 16:02:49 achim Exp $
A=SDL-${PV}.tar.gz
S=${WORKDIR}/SDL-${PV}
@@ -22,7 +22,7 @@ src_compile() {
src_install() {
cd ${S}
try make DESTDIR=${D} install
-
+ prepman
dodoc BUGS COPYING CREDITS README* TODO WhatsNew
docinto html
dodoc *.html
diff --git a/media-libs/mesa/files/digest-mesa-glu-3.2.1 b/media-libs/mesa/files/digest-mesa-glu-3.2.1
new file mode 100644
index 000000000000..8600dc9088ee
--- /dev/null
+++ b/media-libs/mesa/files/digest-mesa-glu-3.2.1
@@ -0,0 +1 @@
+MD5 5b1c54fb8f0f130ac53cceb5010460f6 MesaLib-3.2.1.tar.gz
diff --git a/media-libs/mesa/mesa-glu-3.2.1.ebuild b/media-libs/mesa/mesa-glu-3.2.1.ebuild
new file mode 100644
index 000000000000..4a5856f9cc38
--- /dev/null
+++ b/media-libs/mesa/mesa-glu-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-glu-3.2.1.ebuild,v 1.1 2000/10/09 16:02:49 achim Exp $
+
+P=MesaLib-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux"
+SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ rm -f ${D}/usr/X11R6/lib/libGL.*
+
+ rm -f ${D}/usr/X11R6/include/GL/gl.h
+ rm -f ${D}/usr/X11R6/include/GL/glx.h
+ rm -f ${D}/usr/X11R6/include/GL/osmesa.h
+ cd ${D}/usr/X11R6/lib
+ ln -s libGLU.so.1.1.030201 libMesaGLU.so.3
+
+ cd ${S}
+ dodoc docs/*
+}
+