summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-28 14:40:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-28 14:40:45 +0000
commit70eca4b8c30de7a2189d0b7f94377e4e2f4a2a47 (patch)
treebf1b6e798e85781b077cd912d0b4f38e00047b2b /media-libs
parentAdd patch to fix linking against tinyxml[stl]. Fixes #384781 (diff)
downloadgentoo-2-70eca4b8c30de7a2189d0b7f94377e4e2f4a2a47.tar.gz
gentoo-2-70eca4b8c30de7a2189d0b7f94377e4e2f4a2a47.tar.bz2
gentoo-2-70eca4b8c30de7a2189d0b7f94377e4e2f4a2a47.zip
Snapshot from new upstream. This one is using libcrypto instead of private MD5 implementation.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/liblrdf/ChangeLog9
-rw-r--r--media-libs/liblrdf/liblrdf-0.4.0_p20110928.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/media-libs/liblrdf/ChangeLog b/media-libs/liblrdf/ChangeLog
index 57343d5419c6..d16871c0f68c 100644
--- a/media-libs/liblrdf/ChangeLog
+++ b/media-libs/liblrdf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/liblrdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/liblrdf/ChangeLog,v 1.42 2011/09/20 13:17:52 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblrdf/ChangeLog,v 1.43 2011/09/28 14:40:45 ssuominen Exp $
+
+*liblrdf-0.4.0_p20110928 (28 Sep 2011)
+
+ 28 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +liblrdf-0.4.0_p20110928.ebuild:
+ Snapshot from new upstream. This one is using libcrypto instead of private
+ MD5 implementation.
20 Sep 2011; Tony Vroon <chainsaw@gentoo.org> liblrdf-0.4.0-r20.ebuild:
Marked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Ian
diff --git a/media-libs/liblrdf/liblrdf-0.4.0_p20110928.ebuild b/media-libs/liblrdf/liblrdf-0.4.0_p20110928.ebuild
new file mode 100644
index 000000000000..a0a92904c0d6
--- /dev/null
+++ b/media-libs/liblrdf/liblrdf-0.4.0_p20110928.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblrdf/liblrdf-0.4.0_p20110928.ebuild,v 1.1 2011/09/28 14:40:45 ssuominen Exp $
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="A library for the manipulation of RDF file in LADSPA plugins"
+HOMEPAGE="http://lrdf.sourceforge.net/ http://github.com/swh/LRDF"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-1
+ media-libs/raptor:2
+ >=media-libs/ladspa-sdk-1.12"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ # http://github.com/swh/LRDF/issues/6
+ sed -i -e '/^Libs/s:Private:private:' lrdf.pc.in || die
+ # http://github.com/swh/LRDF/issues/5
+ mkdir m4
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/lib*/liblrdf.la
+}