summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-08-12 08:28:49 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-08-12 08:28:49 +0000
commit6cf3fc161e90573eb60817124127244a63593a6c (patch)
treea00297bf78530a65ffc70d06673c3b6141e82f60 /media-libs
parentsci-chemistry/ccpn: Todays python patches (diff)
downloadgentoo-2-6cf3fc161e90573eb60817124127244a63593a6c.tar.gz
gentoo-2-6cf3fc161e90573eb60817124127244a63593a6c.tar.bz2
gentoo-2-6cf3fc161e90573eb60817124127244a63593a6c.zip
Revision bump: add compatibility patch for >=media-libs/leptonica-1.70, wrt bug #513954
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/jbig2enc/ChangeLog11
-rw-r--r--media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch52
-rw-r--r--media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild32
3 files changed, 93 insertions, 2 deletions
diff --git a/media-libs/jbig2enc/ChangeLog b/media-libs/jbig2enc/ChangeLog
index 63135193102e..46594bd567f0 100644
--- a/media-libs/jbig2enc/ChangeLog
+++ b/media-libs/jbig2enc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/jbig2enc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2enc/ChangeLog,v 1.3 2013/09/22 06:45:53 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2enc/ChangeLog,v 1.4 2014/08/12 08:28:48 pinkbyte Exp $
+
+*jbig2enc-0.28-r1 (12 Aug 2014)
+
+ 12 Aug 2014; Sergey Popov <pinkbyte@gentoo.org> +jbig2enc-0.28-r1.ebuild,
+ +files/jbig2enc-0.28-leptonica-1.70.patch:
+ Revision bump: add compatibility patch for >=media-libs/leptonica-1.70, wrt
+ bug #513954
22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> jbig2enc-0.28.ebuild:
Stable for x86, wrt bug #485256
diff --git a/media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch b/media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch
new file mode 100644
index 000000000000..e2ed771d2045
--- /dev/null
+++ b/media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch
@@ -0,0 +1,52 @@
+From 53ce5fe7e73d7ed95c9e12b52dd4984723f865fa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zdenko=20Podobn=C3=BD?= <zdenop@gmail.com>
+Date: Sun, 6 Apr 2014 21:25:27 +0200
+Subject: [PATCH] fix build with leptonica 1.70
+
+Merged upstream
+
+---
+ configure.ac | 1 +
+ src/jbig2.cc | 13 +++++++++----
+ 2 files changed, 10 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fe37c22..753a607 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,6 +55,7 @@ AC_CHECK_LIB([lept], [findFileFormatStream], [], [
+ echo "Error! Leptonica not detected."
+ exit -1
+ ])
++AC_CHECK_FUNCS(expandBinaryPower2Low,,)
+ # test for function - it should detect leptonica dependecies
+
+ # Check for possible dependancies of leptonica.
+diff --git a/src/jbig2.cc b/src/jbig2.cc
+index e10f042..515c1ef 100644
+--- a/src/jbig2.cc
++++ b/src/jbig2.cc
+@@ -130,11 +130,16 @@ segment_image(PIX *pixb, PIX *piximg) {
+ // input color image, so we have to do it this way...
+ // is there a better way?
+ // PIX *pixd = pixExpandBinary(pixd4, 4);
+- PIX *pixd = pixCreate(piximg->w, piximg->h, 1);
+- pixCopyResolution(pixd, piximg);
+- if (verbose) pixInfo(pixd, "mask image: ");
+- expandBinaryPower2Low(pixd->data, pixd->w, pixd->h, pixd->wpl,
++ PIX *pixd;
++#ifdef HAVE_EXPANDBINARYPOWER2LOW
++ pixd = pixCreate(piximg->w, piximg->h, 1);
++ pixCopyResolution(pixd, piximg);
++ expandBinaryPower2Low(pixd->data, pixd->w, pixd->h, pixd->wpl,
+ pixd4->data, pixd4->w, pixd4->h, pixd4->wpl, 4);
++#else
++ pixd = pixExpandBinaryPower2(pixd4, 4);
++#endif
++ if (verbose) pixInfo(pixd, "mask image: ");
+
+ pixDestroy(&pixd4);
+ pixDestroy(&pixsf4);
+--
+2.0.3
+
diff --git a/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
new file mode 100644
index 000000000000..fb54630a48a6
--- /dev/null
+++ b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild,v 1.1 2014/08/12 08:28:48 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="JBIG2 Encoder and libs"
+HOMEPAGE="https://github.com/agl/jbig2enc"
+SRC_URI="https://github.com/agl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="media-libs/leptonica[gif?,jpeg?,png?,tiff?,webp?]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-leptonica-1.70.patch" )
+
+src_prepare() {
+ # remove -Werror
+ sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac || die 'sed on configure.ac failed'
+ # prevent static linking and QA notice about insecure RUNPATHs
+ sed -i -e '/jbig2_LDFLAGS/d' src/Makefile.am || die 'sed on src/Makefile.am failed'
+
+ autotools-utils_src_prepare
+}