summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-07 08:44:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-07 08:44:19 +0000
commit6036cdeed0f14383d058afc2f61c8b54e5fc3a69 (patch)
tree9f8fa99e320cb168de44873585395ffb66d7e642 /media-libs
parentRemove unnecessary dev-perl/Module-Install and virtual/perl-Module-Build from... (diff)
downloadgentoo-2-6036cdeed0f14383d058afc2f61c8b54e5fc3a69.tar.gz
gentoo-2-6036cdeed0f14383d058afc2f61c8b54e5fc3a69.tar.bz2
gentoo-2-6036cdeed0f14383d058afc2f61c8b54e5fc3a69.zip
Lower the number of available versions a bit.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/ChangeLog9
-rw-r--r--media-libs/x264/files/x264-altivec.patch52
-rw-r--r--media-libs/x264/files/x264-onlylib-20100605.patch30
-rw-r--r--media-libs/x264/x264-0.0.20100605.ebuild61
-rw-r--r--media-libs/x264/x264-0.0.20101029.ebuild63
-rw-r--r--media-libs/x264/x264-0.0.20110223.ebuild62
-rw-r--r--media-libs/x264/x264-0.0.20110825-r1.ebuild88
-rw-r--r--media-libs/x264/x264-0.0.20111017.ebuild88
-rw-r--r--media-libs/x264/x264-0.0.20111218.ebuild76
9 files changed, 8 insertions, 521 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index c6c9d2f8fa76..313c8148c01f 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.71 2012/04/15 18:14:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.72 2012/05/07 08:44:18 scarabeus Exp $
+
+ 07 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> -files/x264-altivec.patch,
+ -files/x264-onlylib-20100605.patch, -x264-0.0.20100605.ebuild,
+ -x264-0.0.20101029.ebuild, -x264-0.0.20110223.ebuild,
+ -x264-0.0.20110825-r1.ebuild, -x264-0.0.20111017.ebuild,
+ -x264-0.0.20111218.ebuild:
+ Lower the number of available versions a bit.
15 Apr 2012; Raúl Porcel <armin76@gentoo.org> x264-0.0.20111220.ebuild:
alpha/sparc stable wrt #411396
diff --git a/media-libs/x264/files/x264-altivec.patch b/media-libs/x264/files/x264-altivec.patch
deleted file mode 100644
index a185dcd5081d..000000000000
--- a/media-libs/x264/files/x264-altivec.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-http://git.videolan.org/?p=x264.git;a=commitdiff;h=7f5771a13aec5a8a724e0d0c9d761f5a82e74af0
-https://bugs.gentoo.org/343893
-
---- a/common/ppc/dct.c
-+++ b/common/ppc/dct.c
-@@ -91,14 +91,14 @@ void x264_sub8x8_dct_altivec( int16_t dct[4][16], uint8_t *pix1, uint8_t *pix2 )
- VEC_DCT( dct0v, dct1v, dct2v, dct3v, tmp0v, tmp1v, tmp2v, tmp3v );
- VEC_DCT( dct4v, dct5v, dct6v, dct7v, tmp4v, tmp5v, tmp6v, tmp7v );
-
-- vec_st(vec_perm(tmp0v, tmp1v, permHighv), 0, dct);
-- vec_st(vec_perm(tmp2v, tmp3v, permHighv), 16, dct);
-- vec_st(vec_perm(tmp4v, tmp5v, permHighv), 32, dct);
-- vec_st(vec_perm(tmp6v, tmp7v, permHighv), 48, dct);
-- vec_st(vec_perm(tmp0v, tmp1v, permLowv), 64, dct);
-- vec_st(vec_perm(tmp2v, tmp3v, permLowv), 80, dct);
-- vec_st(vec_perm(tmp4v, tmp5v, permLowv), 96, dct);
-- vec_st(vec_perm(tmp6v, tmp7v, permLowv), 112, dct);
-+ vec_st(vec_perm(tmp0v, tmp1v, permHighv), 0, *dct);
-+ vec_st(vec_perm(tmp2v, tmp3v, permHighv), 16, *dct);
-+ vec_st(vec_perm(tmp4v, tmp5v, permHighv), 32, *dct);
-+ vec_st(vec_perm(tmp6v, tmp7v, permHighv), 48, *dct);
-+ vec_st(vec_perm(tmp0v, tmp1v, permLowv), 64, *dct);
-+ vec_st(vec_perm(tmp2v, tmp3v, permLowv), 80, *dct);
-+ vec_st(vec_perm(tmp4v, tmp5v, permLowv), 96, *dct);
-+ vec_st(vec_perm(tmp6v, tmp7v, permLowv), 112, *dct);
- }
-
- void x264_sub16x16_dct_altivec( int16_t dct[16][16], uint8_t *pix1, uint8_t *pix2 )
---- a/common/ppc/mc.c
-+++ b/common/ppc/mc.c
-@@ -460,8 +460,8 @@ static void mc_chroma_altivec_8xh( uint8_t *dstu, uint8_t *dstv, int i_dst_strid
- dstv_16h = vec_sr( dstv_16h, shiftv );
- dstv_16l = vec_sr( dstv_16l, shiftv );
-
-- dstuv = vec_perm( dstv_16h, dstv_16l, perm0v );
-- dstvv = vec_perm( dstv_16h, dstv_16l, perm1v );
-+ dstuv = (vec_u8_t)vec_perm( dstv_16h, dstv_16l, perm0v );
-+ dstvv = (vec_u8_t)vec_perm( dstv_16h, dstv_16l, perm1v );
-
- VEC_STORE8( dstuv, dstu );
- VEC_STORE8( dstvv, dstv );
-@@ -498,8 +498,8 @@ static void mc_chroma_altivec_8xh( uint8_t *dstu, uint8_t *dstv, int i_dst_strid
- dstv_16h = vec_sr( dstv_16h, shiftv );
- dstv_16l = vec_sr( dstv_16l, shiftv );
-
-- dstuv = vec_perm( dstv_16h, dstv_16l, perm0v );
-- dstvv = vec_perm( dstv_16h, dstv_16l, perm1v );
-+ dstuv = (vec_u8_t)vec_perm( dstv_16h, dstv_16l, perm0v );
-+ dstvv = (vec_u8_t)vec_perm( dstv_16h, dstv_16l, perm1v );
-
- VEC_STORE8( dstuv, dstu );
- VEC_STORE8( dstvv, dstv );
diff --git a/media-libs/x264/files/x264-onlylib-20100605.patch b/media-libs/x264/files/x264-onlylib-20100605.patch
deleted file mode 100644
index 3f400ce9b2f8..000000000000
--- a/media-libs/x264/files/x264-onlylib-20100605.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: x264-snapshot-20100605-2245/Makefile
-===================================================================
---- x264-snapshot-20100605-2245.orig/Makefile
-+++ x264-snapshot-20100605-2245/Makefile
-@@ -118,7 +118,7 @@ DEP = depend
-
- .PHONY: all default fprofiled clean distclean install uninstall dox test testclean
-
--default: $(DEP) x264$(EXE)
-+default: $(DEP)
-
- libx264.a: .depend $(OBJS) $(OBJASM)
- $(AR) rc libx264.a $(OBJS) $(OBJASM)
-@@ -193,7 +193,7 @@ distclean: clean
- rm -f config.mak config.h config.log x264.pc
- rm -rf test/
-
--install: x264$(EXE) $(SONAME)
-+install: libx264.a $(SONAME)
- install -d $(DESTDIR)$(bindir)
- install -d $(DESTDIR)$(includedir)
- install -d $(DESTDIR)$(libdir)
-@@ -201,7 +201,6 @@ install: x264$(EXE) $(SONAME)
- install -m 644 x264.h $(DESTDIR)$(includedir)
- install -m 644 libx264.a $(DESTDIR)$(libdir)
- install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
-- install x264$(EXE) $(DESTDIR)$(bindir)
- $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
- ifeq ($(SYS),MINGW)
- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
diff --git a/media-libs/x264/x264-0.0.20100605.ebuild b/media-libs/x264/x264-0.0.20100605.ebuild
deleted file mode 100644
index aabb7f13c4a6..000000000000
--- a/media-libs/x264/x264-0.0.20100605.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20100605.ebuild,v 1.7 2010/11/14 19:07:01 armin76 Exp $
-
-EAPI=2
-inherit eutils multilib toolchain-funcs versionator
-
-MY_P=x264-snapshot-$(get_version_component_range 3)-2245
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug +threads pic"
-
-RDEPEND=""
-DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( >=dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-nostrip.patch \
- "${FILESDIR}"/${PN}-onlylib-20100605.patch
-}
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use debug && myconf="${myconf} --enable-debug"
-
- if use x86 && use pic; then
- myconf="${myconf} --disable-asm"
- fi
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --disable-avs-input \
- --disable-lavf-input \
- --disable-mp4-output \
- $(use_enable threads pthread) \
- --enable-pic \
- --enable-shared \
- --extra-asflags="${ASFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --host="${CHOST}" \
- ${myconf} \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS doc/*.txt
-}
diff --git a/media-libs/x264/x264-0.0.20101029.ebuild b/media-libs/x264/x264-0.0.20101029.ebuild
deleted file mode 100644
index 66aac08b0707..000000000000
--- a/media-libs/x264/x264-0.0.20101029.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20101029.ebuild,v 1.7 2011/07/10 14:59:23 armin76 Exp $
-
-EAPI=2
-inherit eutils multilib toolchain-funcs versionator
-
-MY_P=x264-snapshot-$(get_version_component_range 3)-2245
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-SRC_URI="http://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~mips ~ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug +threads pic"
-
-RDEPEND=""
-DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( >=dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-nostrip.patch \
- "${FILESDIR}"/${PN}-onlylib-20100605.patch \
- "${FILESDIR}"/${PN}-altivec.patch
-}
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use debug && myconf="${myconf} --enable-debug"
-
- if use x86 && use pic; then
- myconf="${myconf} --disable-asm"
- fi
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-gpac \
- $(use threads || echo "--disable-pthread") \
- --enable-pic \
- --enable-shared \
- --extra-asflags="${ASFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --host="${CHOST}" \
- ${myconf} \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS doc/*.txt
-}
diff --git a/media-libs/x264/x264-0.0.20110223.ebuild b/media-libs/x264/x264-0.0.20110223.ebuild
deleted file mode 100644
index f7fb7ff7b1f5..000000000000
--- a/media-libs/x264/x264-0.0.20110223.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110223.ebuild,v 1.1 2011/02/24 13:25:45 aballier Exp $
-
-EAPI=2
-inherit eutils multilib toolchain-funcs versionator
-
-MY_P=x264-snapshot-$(get_version_component_range 3)-2245
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-SRC_URI="http://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug +threads pic"
-
-RDEPEND=""
-DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( >=dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-nostrip.patch \
- "${FILESDIR}"/${PN}-onlylib-20100605.patch
-}
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use debug && myconf="${myconf} --enable-debug"
-
- if use x86 && use pic; then
- myconf="${myconf} --disable-asm"
- fi
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-gpac \
- $(use threads || echo "--disable-thread") \
- --enable-pic \
- --enable-shared \
- --extra-asflags="${ASFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --host="${CHOST}" \
- ${myconf} \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS doc/*.txt
-}
diff --git a/media-libs/x264/x264-0.0.20110825-r1.ebuild b/media-libs/x264/x264-0.0.20110825-r1.ebuild
deleted file mode 100644
index 410c03044abc..000000000000
--- a/media-libs/x264/x264-0.0.20110825-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110825-r1.ebuild,v 1.1 2011/09/07 23:17:44 chutzpah Exp $
-
-EAPI=4
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- V_ECLASS="git-2"
-else
- V_ECLASS="versionator"
-fi
-
-inherit multilib toolchain-funcs flag-o-matic ${V_ECLASS}
-
-if [ "${PV#9999}" = "${PV}" ]; then
- MY_P="x264-snapshot-$(get_version_component_range 3)-2245-stable"
-fi
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-if [ "${PV#9999}" != "${PV}" ] ; then
- EGIT_REPO_URI="git://git.videolan.org/x264.git"
- SRC_URI=""
-else
- SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-IUSE="10bit custom-cflags debug +interlaced pic static-libs +threads"
-
-RDEPEND=""
-DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( >=dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-
-if [ "${PV#9999}" = "${PV}" ]; then
- S="${WORKDIR}/${MY_P}"
-fi
-
-DOCS="AUTHORS doc/*.txt"
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use 10bit && myconf+=" --bit-depth=10"
- use debug && myconf+=" --enable-debug"
- use interlaced || myconf+=" --disable-interlaced"
- use static-libs && myconf+=" --enable-static"
- use threads || myconf+=" --disable-thread"
-
- # let upstream pick the optimization level by default
- use custom-cflags || filter-flags -O?
-
- if use x86 && use pic; then
- myconf+=" --disable-asm"
- fi
-
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-cli \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-ffms \
- --disable-gpac \
- --enable-pic \
- --enable-shared \
- --host="${CHOST}" \
- ${myconf} || die
-
- # this is a nasty workaround for bug #376925 as upstream doesn't like us
- # fiddling with their CFLAGS
- if use custom-cflags; then
- local cflags
- cflags="$(grep "^CFLAGS=" config.mak | sed 's/CFLAGS=//')"
- cflags="${cflags//$(get-flag O)/}"
- cflags="${cflags//-O? /$(get-flag O) }"
- cflags="${cflags//-g /}"
- sed -i "s:^CFLAGS=.*:CFLAGS=${cflags//:/\\:}:" config.mak
- fi
-}
diff --git a/media-libs/x264/x264-0.0.20111017.ebuild b/media-libs/x264/x264-0.0.20111017.ebuild
deleted file mode 100644
index fa23b1de95f1..000000000000
--- a/media-libs/x264/x264-0.0.20111017.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20111017.ebuild,v 1.1 2011/10/19 16:26:12 lu_zero Exp $
-
-EAPI=4
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- V_ECLASS="git-2"
-else
- V_ECLASS="versionator"
-fi
-
-inherit multilib toolchain-funcs flag-o-matic ${V_ECLASS}
-
-if [ "${PV#9999}" = "${PV}" ]; then
- MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
-fi
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-if [ "${PV#9999}" != "${PV}" ] ; then
- EGIT_REPO_URI="git://git.videolan.org/x264.git"
- SRC_URI=""
-else
- SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-IUSE="10bit custom-cflags debug +interlaced pic static-libs +threads"
-
-RDEPEND=""
-DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( >=dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
-
-if [ "${PV#9999}" = "${PV}" ]; then
- S="${WORKDIR}/${MY_P}"
-fi
-
-DOCS="AUTHORS doc/*.txt"
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use 10bit && myconf+=" --bit-depth=10"
- use debug && myconf+=" --enable-debug"
- use interlaced || myconf+=" --disable-interlaced"
- use static-libs && myconf+=" --enable-static"
- use threads || myconf+=" --disable-thread"
-
- # let upstream pick the optimization level by default
- use custom-cflags || filter-flags -O?
-
- if use x86 && use pic; then
- myconf+=" --disable-asm"
- fi
-
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-cli \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-ffms \
- --disable-gpac \
- --enable-pic \
- --enable-shared \
- --host="${CHOST}" \
- ${myconf} || die
-
- # this is a nasty workaround for bug #376925 as upstream doesn't like us
- # fiddling with their CFLAGS
- if use custom-cflags; then
- local cflags
- cflags="$(grep "^CFLAGS=" config.mak | sed 's/CFLAGS=//')"
- cflags="${cflags//$(get-flag O)/}"
- cflags="${cflags//-O? /$(get-flag O) }"
- cflags="${cflags//-g /}"
- sed -i "s:^CFLAGS=.*:CFLAGS=${cflags//:/\\:}:" config.mak
- fi
-}
diff --git a/media-libs/x264/x264-0.0.20111218.ebuild b/media-libs/x264/x264-0.0.20111218.ebuild
deleted file mode 100644
index 3ccb4f5cb714..000000000000
--- a/media-libs/x264/x264-0.0.20111218.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20111218.ebuild,v 1.1 2011/12/19 17:16:55 aballier Exp $
-
-EAPI=4
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- V_ECLASS="git-2"
-else
- V_ECLASS="versionator"
-fi
-
-inherit multilib toolchain-funcs ${V_ECLASS}
-
-if [ "${PV#9999}" = "${PV}" ] ; then
- MY_P="x264-snapshot-$(get_version_component_range 3)-2245-stable"
-fi
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-if [ "${PV#9999}" != "${PV}" ] ; then
- EGIT_REPO_URI="git://git.videolan.org/x264.git"
- SRC_URI=""
-else
- SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-IUSE="debug +threads pic static-libs"
-
-RDEPEND=""
-ASM_DEP=">=dev-lang/yasm-0.6.2"
-DEPEND="
- amd64? ( ${ASM_DEP} )
- x86? ( ${ASM_DEP} )
- x86-fbsd? ( ${ASM_DEP} )
-"
-if [ "${PV#9999}" = "${PV}" ] ; then
- S=${WORKDIR}/${MY_P}
-fi
-DOCS="AUTHORS doc/*.txt"
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use debug && myconf+=" --enable-debug"
- use static-libs && myconf+=" --enable-static"
- use threads || myconf+=" --disable-thread"
-
- if use x86 && use pic; then
- myconf+=" --disable-asm"
- fi
-
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-cli \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-ffms \
- --disable-gpac \
- --enable-pic \
- --enable-shared \
- --extra-asflags="${ASFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --host="${CHOST}" \
- ${myconf} || die
-}