summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-22 08:02:42 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-22 08:02:42 +0000
commit544b0ba818dcb29648c3713fee847d4ac7dc0e1d (patch)
treebeaf018ac36bf0867c58c015affc261acf4b0dcb /media-libs
parentVersion bump. Removed old (diff)
downloadgentoo-2-544b0ba818dcb29648c3713fee847d4ac7dc0e1d.tar.gz
gentoo-2-544b0ba818dcb29648c3713fee847d4ac7dc0e1d.tar.bz2
gentoo-2-544b0ba818dcb29648c3713fee847d4ac7dc0e1d.zip
Version bump (bug #376261 by Alex Barker). Add static-libs USE flag.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsoundtouch/ChangeLog10
-rw-r--r--media-libs/libsoundtouch/files/libsoundtouch-1.6.0-flags.patch25
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.6.0.ebuild48
3 files changed, 81 insertions, 2 deletions
diff --git a/media-libs/libsoundtouch/ChangeLog b/media-libs/libsoundtouch/ChangeLog
index e9741c029e89..a50969a9c521 100644
--- a/media-libs/libsoundtouch/ChangeLog
+++ b/media-libs/libsoundtouch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsoundtouch
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.41 2010/10/15 13:50:25 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.42 2011/08/22 08:02:42 radhermit Exp $
+
+*libsoundtouch-1.6.0 (22 Aug 2011)
+
+ 22 Aug 2011; Tim Harder <radhermit@gentoo.org> +libsoundtouch-1.6.0.ebuild,
+ +files/libsoundtouch-1.6.0-flags.patch:
+ Version bump (bug #376261 by Alex Barker). Add static-libs USE flag.
15 Oct 2010; Brent Baude <ranger@gentoo.org> libsoundtouch-1.5.0.ebuild:
stable ppc, bug 325875
diff --git a/media-libs/libsoundtouch/files/libsoundtouch-1.6.0-flags.patch b/media-libs/libsoundtouch/files/libsoundtouch-1.6.0-flags.patch
new file mode 100644
index 000000000000..94c37dbbe409
--- /dev/null
+++ b/media-libs/libsoundtouch/files/libsoundtouch-1.6.0-flags.patch
@@ -0,0 +1,25 @@
+--- soundtouch.orig/source/SoundStretch/Makefile.am
++++ soundtouch/source/SoundStretch/Makefile.am
+@@ -43,11 +43,5 @@
+ ## linker.
+ soundstretch_LDADD=../SoundTouch/libSoundTouch.la -lm
+
+-## linker flags
+-soundstretch_LDFLAGS=-s
+-
+-## additional compiler flags
+-soundstretch_CXXFLAGS=-O3
+-
+ #clean-local:
+ # -rm -f additional-files-to-remove-on-make-clean
+--- soundtouch.orig/source/SoundTouch/Makefile.am
++++ soundtouch/source/SoundTouch/Makefile.am
+@@ -36,7 +36,7 @@
+ # Note by authore: '-msse2' might not work in non-X86 compilations. If someone can
+ # fix this script to automatically check for CPU architecture, please submit a patch
+ # to me.
+-AM_CXXFLAGS=-O3 -msse2 -fcheck-new -I../../include
++AM_CXXFLAGS=-fcheck-new -I../../include
+
+
+ # other linking flags to add
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.6.0.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.6.0.ebuild
new file mode 100644
index 000000000000..66328bac2c74
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-1.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo FoundationOU
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.6.0.ebuild,v 1.1 2011/08/22 08:02:42 radhermit Exp $
+
+EAPI=4
+inherit autotools eutils flag-o-matic
+
+MY_PN=${PN/lib}
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates."
+HOMEPAGE="http://www.surina.net/soundtouch/"
+SRC_URI="http://www.surina.net/soundtouch/${P/lib}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="sse2 static-libs"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ sed -i -e "s:^\(pkgdoc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ eautoreconf
+
+ if use sse2; then
+ append-flags -msse2
+ else
+ sed -i -e '/^.*#define ALLOW_X86_OPTIMIZATIONS.*$/d' \
+ include/STTypes.h || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-integer-samples \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" pkgdocdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+}