summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-08 18:38:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-08 18:38:31 +0000
commit526f84d31f12a359ce533467b81fd0852ba0ea30 (patch)
treedc6d7057b03c6d5df952b8febb3c0cf52eec682b /media-libs
parentStable on sparc wrt #160163 (diff)
downloadgentoo-2-526f84d31f12a359ce533467b81fd0852ba0ea30.tar.gz
gentoo-2-526f84d31f12a359ce533467b81fd0852ba0ea30.tar.bz2
gentoo-2-526f84d31f12a359ce533467b81fd0852ba0ea30.zip
Version bump. Bug #117655
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/atlas-c++/ChangeLog7
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.0.ebuild38
-rw-r--r--media-libs/atlas-c++/files/digest-atlas-c++-0.6.03
-rw-r--r--media-libs/atlas-c++/metadata.xml7
4 files changed, 53 insertions, 2 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index ea168fdd45cc..a9b51b2add42 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/atlas-c++
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.14 2007/01/06 19:32:30 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.15 2007/01/08 18:38:31 tupone Exp $
+
+*atlas-c++-0.6.0 (08 Jan 2007)
+
+ 08 Jan 2007; <tupone@gentoo.org> metadata.xml, +atlas-c++-0.6.0.ebuild:
+ Version bump. Bug #117655 by Sascha Silbe
06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -atlas-c++-0.4.4.ebuild,
-atlas-c++-0.4.6.ebuild:
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
new file mode 100644
index 000000000000..80f6d673f3d6
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild,v 1.1 2007/01/08 18:38:31 tupone Exp $
+
+inherit eutils
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.net"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc"
+IUSE="bzip2 doc zlib"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ econf \
+ $(use_enable zlib) \
+ $(use_enable bzip2 bzlib) \
+ || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+ if use doc; then
+ emake docs || die "Error: emake failed!"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dohtml -r doc/html/*
+ dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
+}
diff --git a/media-libs/atlas-c++/files/digest-atlas-c++-0.6.0 b/media-libs/atlas-c++/files/digest-atlas-c++-0.6.0
new file mode 100644
index 000000000000..74355f5fea81
--- /dev/null
+++ b/media-libs/atlas-c++/files/digest-atlas-c++-0.6.0
@@ -0,0 +1,3 @@
+MD5 1343d74747a831f2b7b080a51cb4747a Atlas-C++-0.6.0.tar.bz2 316498
+RMD160 04f2800951475c2bdae2bf12c71e4a0e19d537fc Atlas-C++-0.6.0.tar.bz2 316498
+SHA256 30865a568185260fa7d9d4a7bb8e8eb6a1edf5b326e98ac45178fc10d001822f Atlas-C++-0.6.0.tar.bz2 316498
diff --git a/media-libs/atlas-c++/metadata.xml b/media-libs/atlas-c++/metadata.xml
index d9cd2cad66c2..d27f50114e84 100644
--- a/media-libs/atlas-c++/metadata.xml
+++ b/media-libs/atlas-c++/metadata.xml
@@ -2,6 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
-<email>maintainer-needed@gentoo.org</email>
+<email>tupone@gentoo.org</email>
</maintainer>
+<longdescription lang="en">
+Atlas-C++ is the current C++ implementation of the Atlas protocol, a
+communications layer designed to be used in the WorldForge MMORPG gaming
+system.
+</longdescription>
</pkgmetadata>